QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#653 - crash on some file operations may be Qt related

Attached to Project: QCAD
Opened by Pete Martin (ac90pilot) - Friday, 27 July 2012, 05:47 GMT+2
Last edited by Andrew (andrew) - Saturday, 28 July 2012, 11:01 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Linux (All / Other)
Severity Medium
Priority Normal
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On file open selection from main menu or on output to PDF Qcad crashes

error:

I/O error : No such file or directory
/usr/share/mime/inode/directory.xml:1: parser error : Extra content at the end of the document

This task depends upon

Closed by  Andrew (andrew)
Saturday, 28 July 2012, 11:01 GMT+2
Reason for closing:  Fixed
Comment by Andrew (andrew) - Friday, 27 July 2012, 09:24 GMT+2

This is very likely an incompatibility of the QCAD binary with your particular Linux distribution or version thereof. Please indicate the exact name and version of your Linux distribution, thanks.

Comment by james a r brown (jamesarbrown) - Friday, 27 July 2012, 12:08 GMT+2

Same here Fedora 15...

[jamesarbrown@jblaptop qcad-3.0.0-prof-linux-x86]$ ./qcad
Debug: TIMER: 65 ms - "loading plugins"
Debug: TIMER: 848 ms - "initializing plugins"
I/O error : No such file or directory
/usr/share/mime/inode/directory.xml:1: parser error : Extra content at the end of the document

./qcad: line 38: 12302 Segmentation fault (core dumped) LD_LIBRARY_PATH="$DIR" "$binary" $OPT1 $OPT2 "$@"
[jamesarbrown@jblaptop qcad-3.0.0-prof-linux-x86]$ uname -r
2.6.43.8-1.fc15.i686.PAE
[jamesarbrown@jblaptop qcad-3.0.0-prof-linux-x86]$

Comment by james a r brown (jamesarbrown) - Friday, 27 July 2012, 12:09 GMT+2

Oh BTW.. double clicking the file works and opens, running as root works also.... so some folder access permission failure I guess is not being handled in a nice way

Comment by Andrew (andrew) - Friday, 27 July 2012, 12:13 GMT+2

Thanks James. I can confirm that the current binary is not compatible with Fedora 14 and 15 (17 should work fine). Also unsupported at this point: Debian 6 and (X)Ubuntu 10.04

Comment by Pete Martin (ac90pilot) - Friday, 27 July 2012, 18:53 GMT+2

Problem also with Fedora 17. Looks like it is Qt related

Comment by Andrew (andrew) - Friday, 27 July 2012, 19:06 GMT+2

I cannot reproduce the problem with Fedora 17 here. Please note also that we have released an alternative binary for Linux which should work under Fedora 14. Check your download are for the download.

Comment by Pete Martin (ac90pilot) - Friday, 27 July 2012, 20:36 GMT+2

Problem also with Fedora 17. Looks like it is Qt related

Comment by Pete Martin (ac90pilot) - Friday, 27 July 2012, 21:23 GMT+2

The alternative binary for Linux works fine with Fedora 17. (no problems very nice)

I believe the download caption "openSUSE 11.4, 12.1; Ubuntu 12.04; Fedora 17; many others." should be changed.
The alternative should say "Ubuntu 10.04; Debian 6; Fedora 14-17; XUbuntu 10.04; many others."

Comment by Andrew (andrew) - Friday, 27 July 2012, 21:27 GMT+2

Well, the odd thing is that the the alternative binary does not work here with Fedora 17 but with the regular one does.

Did you apply any updates to your system or run an automatic update since installing Fedora 17? Somehow your Fedora 17 behaves differently then mine. Anyway - thanks for the feedback!

Loading...