QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#668 - QCAD sefaulting under OpenSUSE 12.1 64bit (wrong or broken package installed?)

Attached to Project: QCAD
Opened by Pascal VOLAT (Pascal) - Friday, 10 August 2012, 14:48 GMT+1
Last edited by Andrew (andrew) - Friday, 10 August 2012, 17:03 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System OpenSUSE Linux
Severity Low
Priority Normal
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I installed the professional edition of QCAD 3.0 on a fresh OpenSUSE 12.1/x86_64 system. After installing the 32bit freeglut (freeglut-32bit-100529-8.1.2.x86_64) package, the application still won’t start and fails with a sefault :

/opt/qcad-3.0.0-prof-linux-x86> ./qcad
./qcad : line 38 : 5843 Segmentation fault LD_LIBRARY_PATH=”$DIR” “$binary” $OPT1 $OPT2 “$@”

/opt/qcad-3.0.0-prof-linux-x86> LD_LIBRARY_PATH=. ./qcad-bin -style plastic
Segmentation fault

Here is a gdb backtrace, hoping that it may help diagnose the problem :
(gdb) bt
#0 0x09af5d81 in ?? ()
#1 0xf4b2ddbf in FT_Has_PS_Glyph_Names () from /usr/lib/libfreetype.so.6
#2 0xf4babe44 in ?? () from /usr/lib/libfontconfig.so.1
#3 0xf4bac91e in FcFreeTypeCharSetAndSpacing () from /usr/lib/libfontconfig.so.1
#4 0xf4badf53 in FcFreeTypeQueryFace () from /usr/lib/libfontconfig.so.1
#5 0xf4bae654 in FcFreeTypeQuery () from /usr/lib/libfontconfig.so.1
#6 0xf4ba9509 in ?? () from /usr/lib/libfontconfig.so.1
#7 0xf4ba987d in ?? () from /usr/lib/libfontconfig.so.1
#8 0xf4ba9a57 in ?? () from /usr/lib/libfontconfig.so.1
#9 0xf4ba59d1 in ?? () from /usr/lib/libfontconfig.so.1
#10 0xf4ba5c86 in FcConfigBuildFonts () from /usr/lib/libfontconfig.so.1
#11 0xf4baebac in FcInitLoadConfigAndFonts () from /usr/lib/libfontconfig.so.1
#12 0xf4baee1d in FcInit () from /usr/lib/libfontconfig.so.1
#13 0xf53537e1 in qt_init(QApplicationPrivate*, int, _XDisplay*, unsigned long, unsigned long) ()

 from ./libQtGui.so.4

#14 0xf52d5db8 in QApplicationPrivate::construct(_XDisplay*, unsigned long, unsigned long) ()

 from ./libQtGui.so.4

#15 0xf52d649a in QApplication::QApplication(int&, char**, bool, int) () from ./libQtGui.so.4
#16 0x08b59746 in ?? ()
#17 0x08171cd6 in ?? ()
#18 0xf4bf6003 in __libc_start_main () from /lib/libc.so.6
#19 0×08171701 in ?? ()
Backtrace stopped: Not enough registers or memory available to unwind further

libfreetype installed version is libfreetype6-32bit-2.4.7-6.1.x86_64

This task depends upon

Closed by  Andrew (andrew)
Friday, 10 August 2012, 17:03 GMT+1
Reason for closing:  Not a bug
Additional comments about closing:  Issue with OTF font files / freetype.
Comment by Andrew (andrew) - Friday, 10 August 2012, 16:03 GMT+1

Unable to reproduce here on a fresh installation of OpenSUSE 12.1 64 bit.

Please find attached a list of 32bit packages installed on my system. Most of them were either installed by default or as dependency of these three packages I had to install manually:

Mesa-32bit
libgthread-2_0-0-32bit
libgobject-2_0-0-32bit
Comment by Andrew (andrew) - Friday, 10 August 2012, 16:04 GMT+1

Note that I did NOT install any packages called "*freeglut-32bit*"

Comment by Pascal VOLAT (Pascal) - Friday, 10 August 2012, 16:57 GMT+1

Ok, I looked a bit more into this and with strace noticed that the culprit were OTF font loaded by freetype. This looks like a distro bug, thanks for your package list and time!

Comment by Andrew (andrew) - Friday, 10 August 2012, 17:02 GMT+1

Thanks for the feedback on OTF fonts. This might help some other people with similar issues. I will close this task.

Loading...