QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#678 - Text box does not accept the "enter" key

Attached to Project: QCAD
Opened by Koos Uys (koosjr) - Tuesday, 11 September 2012, 05:02 GMT+1
Last edited by Andrew (andrew) - Friday, 21 September 2012, 09:34 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Low
Reported Version 3 Beta
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since the new QCAD 3, it is not possible any more to use “enter” in text boxes. The “enter” is always replaced by another symbol, which makes it impossible to have a long text string as a unit - like it always was in QCAD.

Could this please be fixed? It makes text control difficult.

This task depends upon

Closed by  Andrew (andrew)
Friday, 21 September 2012, 09:34 GMT+1
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Thursday, 20 September 2012, 15:05 GMT+1

Which text box in which tool is affected by this? Can you give an example?
What operating system are you on?
Thanks.

Comment by Koos Uys (koosjr) - Thursday, 20 September 2012, 15:11 GMT+1

I am only aware of one Text tool In QCAD - the one in the LH toolbar. It affects both Windows and Linux versions and I found it from Beta to Final.

I tried changing fonts, but it has no effect.

Comment by Andrew (andrew) - Thursday, 20 September 2012, 15:28 GMT+1

Yes, there is only one text tool. There are various text boxes though, everywhere where you can input texts, numbers, etc.
Pressing the enter key has a different meaning in some of those text input boxes.

I'm not sure if I understand your report correctly:

Possibility A:

  1. You start the text tool.
  2. The text dialog is displayed.
  3. You enter a text, for example "ABC".
  4. You press the enter key to create a new line.
  5. A special character is now displayed in the text editor instead of creating a new line.

This would likely be a Qt bug in combination with your keyboard configuration or layout.

Possibility B:

  1. You start the text tool.
  2. The text dialog is displayed.
  3. You enter a text, for example "ABC".
  4. You press the enter key to create a new line.
  5. The text editor creates a new line as expected.
  6. On the second line, you enter more text, e.g. "123".
  7. You click "OK"
  8. You place the text with the mouse in your drawing.
  9. The text in the drawing is displayed without line breaks.

If this is the case, please make sure that you have NOT checked the option [ ] Simple text in the text dialog which is for simple, one line texts without formatting only.

Comment by Koos Uys (koosjr) - Friday, 21 September 2012, 05:24 GMT+1

Aha!

It was that simple text option! On the Beta it was switched off by default, but did not work in either mode.

On Final, it now makes a difference, but I missed clicking it.

Thanks a million.

Loading...