QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#679 - When drawing, a "escape" does not always cancel the last function.

Attached to Project: QCAD
Opened by Koos Uys (koosjr) - Tuesday, 11 September 2012, 03:10 GMT
Last edited by Andrew (andrew) - Monday, 16 December 2013, 13:46 GMT
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Low
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This problem experienced since the first beta in both Win and Linux versions.

When a function (like a line) was selected for use and one press ESC twive to get back tot he main menu, it sort of does not cancel that last function. If one wouls now press on another function (like edit or circle) QCAD goes back to the line function.

the only way to rectify this is to press Esc many times. Sometimes the process needs to be repeated more than once.

I could not yet devise a sure fire way of reproducing this, but it does seems to happen as soon as the drawing gets bigger. I could not make it work with a clean page.

Although not crippling, it does break the elegance of drawing seamlessly and is a bit frustrating..

That said, I find QCAD 3.0.0 now significanlty faster than the Betas when loading and zooming in and out.

This task depends upon

Closed by  Andrew (andrew)
Monday, 16 December 2013, 13:46 GMT
Reason for closing:  Works for me
Comment by Andrew (andrew) - Thursday, 20 September 2012, 13:03 GMT

Reported version is indicated as "3 Beta". Is this the case or does this affect QCAD 3.0.0 final?

Comment by Koos Uys (koosjr) - Thursday, 20 September 2012, 13:09 GMT

Yes, it still affects 3.0.0 Final as well.

Loading...