QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#686 - Bibliothekbrowser zeigt keinen Inhalt

Attached to Project: QCAD
Opened by Helmut Niedermeyer (Helmut_N) - Saturday, 22 September 2012, 08:57 GMT
Last edited by Andrew (andrew) - Wednesday, 10 July 2013, 11:41 GMT
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity Low
Priority Normal
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Ich verwende QCAD normalerweise unter Windows 7 als Benutzer ohne Privilegien. In diesem Modus zeigt der Bibliothekbrowser keinen Inhalt. Der Pfad zur Bibliothek ist in den Applikationseinstellungen korrekt eingerichtet. Wenn ich auf “Aktualisieren” klicke, läuft der Vorgang ab, aber danach ist immer noch kein Inhalt im Browser sichtbar. Starte ich QCAD als Administrator, habe ich keinerlei Probleme mit dem Bibliothekbrowser. Ich vermute, dass bei der Installation von QCAD die Privilegien nicht richtig gesetzt wurden. Eine Neuinstallation hat allerdings keine Abhilfe geschaffen.

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 10 July 2013, 11:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  Likely fixed.
Comment by -- (clive) - Saturday, 22 September 2012, 10:33 GMT

Hallo - versuchen:
Ein. Zum Programm Dateien in Windows> Wechseln Sie zu dem Ordner QCAD> 'Rechtsklick' und wählen Sie "Eigenschaften".

2. Wählen Sie die "Registerkarte Sicherheit" und highlght - Benutzer (Eigentümer-PC \ Users)> klicken Sie nun auf Bearbeiten.

3. Jetzt in der Berechtigungen Dialogfenster> erneut wählen Sie Benutzer (Eigentümer-PC \ Users).

4. Überprüfen Sie Volle Kontrolle und klicken Sie auf "Übernehmen und OK '.

5. Dies sollte zu aktualisieren und damit alle Berechtigungen für alle QCAD Ordner, so jetzt sollten Sie in der Lage sein zu starten QCAD ohne Admin Control!

Comment by Helmut Niedermeyer (Helmut_N) - Saturday, 22 September 2012, 14:14 GMT

Ich hatte vorher schon ohne Erfolg die Zugriffsrechte für mich auf Vollzugriff erhöht und habe das jetzt noch einmal für die Gruppe Benutzer getan, leider wieder ohne Erfolg. Ich habe QCAD noch einmal neu installiert, diesmal nicht als Administrator, sondern unter meinem Account, nachdem ich mich zu einem Mitglied der Gruppe Administratoren gemacht hatte. Danach habe ich die Mitgliedschaft wieder entfernt, da ich normalerweise nicht mit Administratorrechten arbeiten will. Auch diese Neuinstallation hat nicht geholfen. Bisher funktioniert nur ein Programmstart als Administrator. Mein Verdacht ist, dass das Programm den Index an eine Stelle schreiben will, für die ich keine ausreichenden Zugriffsrechte habe oder daas das Programm den Index nach dem Schreiben an einer anderen Stelle sucht.

Comment by Andrew (andrew) - Saturday, 22 September 2012, 14:49 GMT

Das Verzeichnis der Bibliothek (Quelldateien) benötigt nur Leseberechtigung.

Der Index (DB) wird generiert unter:
%APPDATA%\RibbonSoft\library_3_0_0_9.db

z.B.:
C:\Documents and Settings\User Name\Application Data\RibbonSoft\library_3_0_0_9.db

Comment by Helmut Niedermeyer (Helmut_N) - Saturday, 22 September 2012, 15:48 GMT

Hallo,
Dateien "library_3_0_0_9.db" habe ich auf meinem PC (Windows 7) gefunden in C:\Users\Administrator\AppData\Roaming\RibbonSoft bzw. C:\Users\(mein Account)\AppData\Roaming\RibbonSoft. Den Inhalt des Ordners von meinem Account, in dem auch noch eine Datei library_3_0_0_7.db und einige ini-Dateien waren, habe ich gelöscht, aus dem Administrator-Ordner habe ich die Dateien library_3_0_0_9.db und QCAD3.ini hineinkopiert. Nun erscheint der Inhalt der Bibliothek auch, wenn ich QCAD unter meinem Account starte.
Vielen Dank!
Helmut

Comment by Helmut Niedermeyer (Helmut_N) - Saturday, 29 September 2012, 14:26 GMT

Nachdem ich nun einige Erfahrung mit dem Bibliothekbrowser gesammelt habe, möchte ich noch eine Bemerkung anfügen bzw. eine Frage stellen. Die Aktualisierung des Index beim Programmstart dauert relativ lange, wenn man eine größere Bibliothek hat. Da ich die Bibliothek nicht ständig verändere, dachte ich, ich könnte mir die Wartezeit ersparenl, indem ich in den Applikationseinstellungen das Häkchen bei "Suchindex beim Start aktualisieren" entferne. Das hat aber nichts bewirkt. Dann habe ich den Pfad unter "Bibliothekquellen" gelöscht. Auch das hat nichts bewirkt. Die Aktualisierung habe ich erst dadurch stoppen können, dass ich mit einem Editor im QCAD3.ini-File im Ordner ...\Roaming\RibbonSoft die Zeile RebuildDatabase=true durch RebuildDatabase=false ersetzt habe. Die Aktualisierung duch Anklicken des Icons rechts unten im Bibliothekbrowser wird aber immer noch durchgeführt, obwohl kein Pfad bei den Bibliothekquellen eingetragen ist. Habe ich etwas völlig falsch verstanden oder hat das Programm in Bezug auf die Aktualisierung einen Fehler?

Loading...