QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#688 - QCAD3: Deadlock happens during text operation when one tries to select a font style

Attached to Project: QCAD
Opened by Karl Bernhardi (kabnh) - Monday, 24 September 2012, 00:08 GMT+2
Last edited by Andrew (andrew) - Thursday, 25 October 2012, 10:56 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System OpenSUSE Linux
Severity Medium
Priority Normal
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I just use QCAD3 for the first time. I work with OpenSuse 12.2.
After having unpacked the downloaded package, I am able to start QCAD3 with the QCAD command icon.
Check shows that i used the most actual version.
Obviously no further installation steps are necessary.
I am able to draw some lines, etc.
However, when trying to select a font, I recognized that the computer hangs at least for 5 minutes.
The CPU load is about 50%, and i am not able to move the mouse and to do anything else.
During this time, sometimes there is access to disk, sometimes not.
So, in order lo cancel the hanging, i must make a hard system reboot.
Before i have entered the font selection, i have tried to look into the help options.
However, It was not possible to get the FAQs and the QCAD forum, so i am not aware about similar documented problems.
I have looked after similar bugs, using the words ‘text, font’. No similar bugs found.

This task depends upon

Closed by  Andrew (andrew)
Thursday, 25 October 2012, 10:56 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  Likely a bug in Qt/X11/Freetype or system libraries. Fixed with described workaround for QCAD 3.1.
Comment by Andrew (andrew) - Monday, 24 September 2012, 09:53 GMT+2

This is indeed an unknown problem. I can imagine that it might be caused by either a particular font installed on your system, or a huge number of fonts installed on your system. Is there anything special about fonts on your installation?

A possible fix for QCAD 3.1 could be a user preference to switch off font previews in font selection.

Comment by Karl Bernhardi (kabnh) - Monday, 24 September 2012, 23:35 GMT+2

I haven't installed any special font.
Please tell me the interface QCAD calls for access to fonts.
Since according to your comment QCAD3 uses fonts of the Linux-system,
I wonder why QCAD3 has its own folder for fonts.
I made several observations:
1.) QCAD2 is ok in all OPENSUSE versions. Font selecting in the text editor goes quickly without "stutter".
2.) In QCAD3 I have exchanged the QCAD3 font folder with that of QCAD2: no success.
3.) Just by moving the scraller in the QCAD3 font selection menue alone one arrives at the deadlock situation.

  For the first few seconds it is possible to move the scraller up and down, however with "stutter".
  After this initial time the scraller gets immovable. 
  To achieve the deadlock, it is not "necessary" to select a particular font.

4.) Both font selectors in the QCAD3 text menue have the deadlock problem.
5.) Other scrallers, e.g., that of the main display frame, are ok.

Comment by Andrew (andrew) - Tuesday, 25 September 2012, 10:29 GMT+2

QCAD 3 supports system fonts and the CAD fonts included with QCAD.
QCAD 2 only supports the CAD fonts included with it.

Please note that QCAD 3 has not been tested on OpenSUSE 12.2 yet (only up to 12.1). See also list of supported platforms:
http://www.ribbonsoft.com/en/qcad-documentation/supported-platforms

OpenSUSE 12.2 support will likely be added in the coming days.

Comment by Karl Bernhardi (kabnh) - Tuesday, 25 September 2012, 11:38 GMT+2

I observed the same problem in openSUSE 11.4 and openSUSE 12.1, both with KDE4.
In openSUSE12.1 with GNOME i cannot start QCAD3 (by clicking the QCAD3-icon).

Comment by Andrew (andrew) - Tuesday, 25 September 2012, 12:03 GMT+2

Karl: Thanks for the clarification.

Unfortunately, I cannot reproduce the problem here on either OpenSUSE 12.2 or 12.1 (also KDE 4).

Scrolling up and down in the font combo boxes is slightly jerky at first, until all fonts are loaded for the preview. This is to be expected and shouldn't cause any problems other than a slight delay when first scrolling through the font previews

Can you post a few details about your hardware (RAM, processor)?
E.g. 'cat /proc/cpuinfo' and 'cat /proc/meminfo'

Thanks.

Comment by Karl Bernhardi (kabnh) - Wednesday, 26 September 2012, 00:00 GMT+2

Hello,
in the attachment please find the required info for openSUSE12.2.
Further remarks:
1a) i have installed QCAD3.bin and have called the resulting QCAD3 in the opt-folder.
1b) i have unpacked the QCAD3 package from the zip file.
Both cases (OpenSUSE12.2) show the blockade during scrolling the fonts.
2.) I have re-installed the minimal openSUSE 12.1 configuration (as suggested by the installation CD) on an

  64-bit laptop (SamsungN220 plus). My idea was to check if the error occurs even in the minimum config.
   But there was a problem: QCAD3 didn't find the libGLU.so.1.
   "error while loading shared libraries: libGLU: cannot open shared object file: no such file or directory.
   Which additional features are required to get QCAD3 running?
Comment by Andrew (andrew) - Thursday, 27 September 2012, 09:54 GMT+2

Dependencies can likely be resolved through the same packages as for OpenSUSE 12.1 as described in the installation instructions at:

http://www.ribbonsoft.com/en/qcad-installation#linux

OpenSUSE 12.1, 64bit

Install the following packages with the YaST - Software Management tool, including automatically resolved dependencies:

Mesa-32bit
libgthread-2_0-0-32bit
libgobject-2_0-0-32bit

Comment by Karl Bernhardi (kabnh) - Thursday, 27 September 2012, 16:44 GMT+2

I have a 64-bit laptop free for some install experiments with QCAD.
Therefore i try to do a successful qcad install in a 64bit surrounding.
I did:
1.) install of OPENSUSE 12.2 with the (minimum) standard configuration as suggested by the openSUSE install DVD after having formatted the system and home partition.
2.) install of MESA-32 bit, etc, as suggested by you.
3.) ./qcad is still not started, therefore i installed also the software you suggested for FEDORA. Then qcad started and this time the font selection menue works well without stuttering.
4.) Install of additional software schemata: Basic development, c&C++ develop, QT devel, Python devel, Perl devel done;
QCAD remains ok.
5.) I compared the configuration of qcad on the 64bit laptop with that of the 32 bit laptop. Fonts, as displayed in YAST install software,schematic overview, fonts (Schriften) are the same. After install of glibc-devel-static and mesa-libglu-devel also the suggested additional software parts are the same (besides the 32-64 bit variant). In spite of this, scrolling the font selection menue still yields the blocking.
6.) I have done the same compare checks with the qcad3 installation on openSUSE 12.1 on the 64bit laptop. Also, without success.Font selector hangs.
7.) Summary: if i use a well prepared openSUSE platform for qcad3 with welldefined additional installed software, QCAD3 works well. If, however, i use a openSUSE platform with older and possibly unkwown installation history, there is a danger that the font scrollbar hangs due to some unknown software clashes. I dont know at the moment, which later changes in the openSUSE platforms yield the described problem.

Comment by Andrew (andrew) - Thursday, 27 September 2012, 16:57 GMT+2

Thanks for the details.

I estimate that figuring out the exact cause of the problem on those systems affected would be a very time consuming and might not even yield a solution other than uninstalling or downgrading certain packages.

Since we cannot control the environment in which QCAD is being used, I'm working on a solution (workaround) from a different angle:

QCAD 3.1 will offer some user preferences for texts / fonts:
- An option to disable the font preview in the font selection combo box (this should solve the problem on your installations of QCAD 3).
- An option to select which fonts should be displayed in the font selection list. Such a reduced list will generally make font selection faster and makes sense for the vast majority of users, who only use a small sub-set of installed fonts in QCAD (e.g. 'standard' and 'Arial').

Comment by Karl Bernhardi (kabnh) - Friday, 28 September 2012, 09:07 GMT+2

The suggested solution is ok for me.

IMPORTANT HINT for the BUGTRACKER: If i enter www.ribbonsoft.com, then the bugtracker shows not the most actual bugs,
and the submitting of new bugs FAILS, so data are lost! Please deactivate the bugtracker on ribbonsoft.com.

Comment by Karl Bernhardi (kabnh) - Friday, 28 September 2012, 19:43 GMT+2

If I use the up-down-keys for scrolling of fonts instead the scrollbar&mouse, then scrolling can be done very slowly, with a velocity of 1 font per second. In this way the described blocking can be avoided. This method is also a workaround usable for me.

Loading...