QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#690 - Text Position errors on imported DXF files

Attached to Project: QCAD
Opened by Sisto Zanier (SiCadZaMac) - Tuesday, 25 September 2012, 08:42 GMT+2
Last edited by Andrew (andrew) - Tuesday, 25 September 2012, 15:38 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Dear Sirs,
I have found that QCad 3 does not properly handle the X and Y coordinates of the texts.
In fact, when I open an existing DXF file (AutoCad 2007รท2010), the texts are placed in different coordinates than the original file.
With version 2.2.2 QCad this problem is less obvious.

This task depends upon

Closed by  Andrew (andrew)
Tuesday, 25 September 2012, 15:38 GMT+2
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Tuesday, 25 September 2012, 10:11 GMT+2

Please attach or e-mail the DXF file that has that problem for testing, thanks.

Comment by -- (clive) - Tuesday, 25 September 2012, 11:19 GMT+2

Hi, I have tested this on Windows 7 -64
My test case attached:
I added text at specific coordinates in AutoCAD 2010 saved both files one in dxf and one in dwg, opened up in QCAD 3, tested - I couldn`t find any problems!

Comment by Sisto Zanier (SiCadZaMac) - Tuesday, 25 September 2012, 14:52 GMT+2

I've seen... but may be that's I use QCAD3 on a MAC (OSX 10.6.8) ?
I attach a DXF file.
Try to open the same file using QCad 2.2.2 and then, without saving, using new QCAD 3 and see the texts on layers "FONDELLO", "CORNICELAT" and "QUOTEPLEXI"
Notice that after import, the text are not in true font but a transposition of vectorised texts.

Comment by Andrew (andrew) - Tuesday, 25 September 2012, 15:09 GMT+2

Thanks for the file.

Which text in particular is affected for example on layer "FONDELLO"?

If you are referring to the last line of the text at the bottom starting with "dal muro. ...", the text likely references a font that is not available, at least on my system. QCAD 2 defaults to CAD font 'standard' and QCAD 3 defaults to the TrueType font 'Arial' in this case. Since the text is centered and the two fonts have different font metrics, it appears to be dislocated.

I cannot spot any other obvious differences (also using Mac OS X 10.6.8).

Comment by Andrew (andrew) - Tuesday, 25 September 2012, 15:11 GMT+2

P.S. Can you please double-check that you are indeed using QCAD version 3.0.0 final (see QCAD Professional - About QCAD Professional). If you are using a Release Candidate (RC) or Beta version, please update to QCAD 3 final.

Comment by Sisto Zanier (SiCadZaMac) - Tuesday, 25 September 2012, 15:33 GMT+2

Ok! Alright.
I think the best thing to do, after importing from AutoCAD, is to change the font from "Standard" to "CourierCad" or other True Font selected from pop-up menus.
Thanks for Your support.
Sisto

Comment by -- (clive) - Tuesday, 25 September 2012, 15:39 GMT+2

Andrew, I have no problem here also on Windows 7-64

Sisto Zanier - I think your issue is about the style right? Quite simply just select your layer > select the text > in the property Editor > go to geometry > Font name, and change to the style you want.

Loading...