QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System Windows 7
  • Severity Low
  • Priority Very Low
  • Reported Version Development
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by -- - 06.11.2012
Last edited by Andrew - 21.05.2013

FS#709 - Move/copy MV - GUI -button (on docked tool bar) not working in 3.0.3 snapshot release

Windows 7 - 64
To reproduce:
1.Select entity.
2.Using a ‘docked’ Modify tool bar, click on the Move/Copy button.
3.Unable to move cross hairs to snap properly to a reference point.

* No problems with this from either - the Menu > Modify > Move/Copy or the Main CAD tools > Modification tools or from using keycode MV!
Only from a ‘docked’ modify tool bar.

Closed by  Andrew
21.05.2013 06:58
Reason for closing:  Fixed
Additional comments about closing:  

Workaround: no status tip when running under Windows and compiled against Qt 4.8.x

Admin
Andrew commented on 07.11.2012 21:58

I cannot produce that problem here. Is this reproducible on your installation (even after restarting QCAD)?
On which side did you dock the tool bar (in case that matters somehow, one never knows)?
Thanks.

-- commented on 08.11.2012 09:53

It doesn`t seem to matter where the toolbar is docked.

However upon further investigation:
When you first click on the move button the cross hairs freeze, but if you then hover (not click on) over the move/copy button again, all is OK and the cross hairs un-freeze and you are able to continue!
I`ve tried this at home/work on win 7-64 and vista.

Admin
Andrew commented on 20.05.2013 16:43

Another Qt 4.8.x problem. Works fine when linked against Qt 4.7.x.

Workaround: don't use status tips (the move tool has a status bar tip; rotate, mirror, etc. don't which is why they don't exhibit this problem).

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing