QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#709 - Move/copy MV - GUI -button (on docked tool bar) not working in 3.0.3 snapshot release

Attached to Project: QCAD
Opened by -- (clive) - Tuesday, 06 November 2012, 22:50 GMT+2
Last edited by Andrew (andrew) - Tuesday, 21 May 2013, 08:58 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity Low
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Windows 7 - 64
To reproduce:
1.Select entity.
2.Using a ‘docked’ Modify tool bar, click on the Move/Copy button.
3.Unable to move cross hairs to snap properly to a reference point.

* No problems with this from either - the Menu > Modify > Move/Copy or the Main CAD tools > Modification tools or from using keycode MV!
Only from a ‘docked’ modify tool bar.

This task depends upon

Closed by  Andrew (andrew)
Tuesday, 21 May 2013, 08:58 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  Workaround: no status tip when running under Windows and compiled against Qt 4.8.x
Comment by Andrew (andrew) - Wednesday, 07 November 2012, 22:58 GMT+2

I cannot produce that problem here. Is this reproducible on your installation (even after restarting QCAD)?
On which side did you dock the tool bar (in case that matters somehow, one never knows)?
Thanks.

Comment by -- (clive) - Thursday, 08 November 2012, 10:53 GMT+2

It doesn`t seem to matter where the toolbar is docked.

However upon further investigation:
When you first click on the move button the cross hairs freeze, but if you then hover (not click on) over the move/copy button again, all is OK and the cross hairs un-freeze and you are able to continue!
I`ve tried this at home/work on win 7-64 and vista.

Comment by Andrew (andrew) - Monday, 20 May 2013, 18:43 GMT+2

Another Qt 4.8.x problem. Works fine when linked against Qt 4.7.x.

Workaround: don't use status tips (the move tool has a status bar tip; rotate, mirror, etc. don't which is why they don't exhibit this problem).

Loading...