QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#71 - Save fails with uncaught exception

Attached to Project: QCAD
Opened by Martin (martin) - Wednesday, 11 May 2011, 09:59 GMT+2
Last edited by Martin (martin) - Wednesday, 11 May 2011, 10:38 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Linux (All / Other)
Severity High
Priority High
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

  1. New File
  2. Save, enter name without extension
Uncaught exception at /home/martin/workspace/rsframework/scripts/File/SaveAs/../Save/Save.js:40: TypeError: Result of expression 'di.getCorrectedFileName' [undefined] is not a function.
40	    fileName = di.getCorrectedFileName(fileName, fileVersion);
This task depends upon

Closed by  Martin (martin)
Wednesday, 11 May 2011, 10:38 GMT+2
Reason for closing:  Not a bug
Additional comments about closing:  it's "qcad-bin" now, so I started the old binary
Comment by Andrew (andrew) - Wednesday, 11 May 2011, 10:09 GMT+2

Might need a rebuild. Function 'getCorrectedFileName' should be defined in src/scripting/ecmaapi/REcmaDocumentInterface.cpp : 163

Edit: If not, the ECMA script generator might have failed there (check with svn diff src/scripting/ecmaapi/REcmaDocumentInterface.cpp)

Comment by Martin (martin) - Wednesday, 11 May 2011, 10:22 GMT+2

the function is there (both cpp and header file), but still got the exception

Comment by Andrew (andrew) - Wednesday, 11 May 2011, 10:25 GMT+2

Could it be a debug / release mix up? I.e. building the debug version, running the release version or something similar?

Comment by Martin (martin) - Wednesday, 11 May 2011, 10:32 GMT+2

there are some strange warnings on the console:

Debug:    KGlobal::locale::Warning your global KLocale is being recreated with a valid main
component instead of a fake component, this usually means you tried to call i18n related functions
before your main component was created. You should not do that since it most likely will not work 
...
Debug:    kfilemodule(23528)/kio (KDirModel) KDirModelPrivate::_k_slotDeleteItems: No node found
for item that was just removed: KUrl("file:///home/martin/Documents/1line.dxf") 
Comment by Martin (martin) - Wednesday, 11 May 2011, 10:32 GMT+2

it's in both, release and debug bin

Loading...