QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#739 - QCAD fails to open a DXF file generated by itself

Attached to Project: QCAD
Opened by Renaud GILLON (Herge) - Wednesday, 02 January 2013, 18:24 GMT+1
Last edited by Andrew (andrew) - Thursday, 03 January 2013, 15:24 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System OpenSUSE Linux
Severity Medium
Priority Normal
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

QCAD does not manage to load an DXF file created by itself (presumably, I don’t remember excactly, could be the last 2.x version). When selecting File ⇒ Open on the file in attachment, QCAD shows a pop-up reporting the following error :

Cannot open file
»‘/home/gillonr/Documents/Projects/Familly/Br.../Chambre Parents/Plans/Plan-PaterNoster.dxf’.
» Please check your access rights, the file format and file extension.

The file permissions are OK, there is no issue of disk space on the volume where the file reside or where the QCAD distribution is installed or at any other critical location. The problem does not happen on other files created with QCAD, so it appears to be data dependent.

The file causing trouble in QCAD can be imported in LibreOffice 3.4.2 w/o reporting errors (but that application does not provide the suitable methods / tools to edit this format...).

(1) Is there a way to activate debugging when reading in data from a DXF ?
(2) Is there some tool (ev. 3rd party) allowing to check that the data is clean ?
(3) Can someone identify the cause of the problem (presumably some data construct or maybe corruption) ?
(4) In case it would turn out that the problem is a QCAD bug, is there a work-around (I need these drawings...).

This task depends upon

Closed by  Andrew (andrew)
Thursday, 03 January 2013, 15:24 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  Customer was running a release candidate
Comment by Andrew (andrew) - Wednesday, 02 January 2013, 20:46 GMT+1

There appears to be an invalid entity in that file.

The latest release candidate of QCAD simply drops invalid entities when a file is loaded.

You can download the package from your usual download area:
http://www.ribbonsoft.com/en/customer-area

→ QCAD 3 (Development Snapshot)

With the snapshot release you can load your file(s) and save them under a new name.

It's recommendable to keep the QCAD 3.0 stable release installed for production use.

Comment by Renaud GILLON (Herge) - Thursday, 03 January 2013, 15:06 GMT+1

OK, I was running the QCAD 3.0.0-RC2. I upgraded to 3.0.0 and was able to open the file. Thanks.

As DXF is a text format, it would be nice to have some debugging capabilities... as minor bugs can be easily corrected manually.

Loading...