QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#742 - Autosave weird behavior ...

Attached to Project: QCAD
Opened by Husky (Husky) - Tuesday, 08 January 2013, 09:14 GMT+2
Last edited by Andrew (andrew) - Saturday, 12 January 2013, 22:16 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows XP
Severity Low
Priority Normal
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

QCAD 3.0.5

Case:
Start QCAD → Went to the Menu → File → Open recent → choose a Drawing out of the List → click to open this existing drawing.
Message windows appears: QCAD found an Autosave drawing .... will you open it? I choose NO!!!
I go back to the Menu → File → Open recent → will choose the same Drawing .... but it is not anymore listed!!!
Ok - I’m not lazy ...
... back to the Menu → File → Open → find the original file on my Hard drive → click to open it and get the Warning Message:
“Can not open the File ...... Please check your access rights bla bla bla....”

Question: In this case I’m only able to open the bak file and “Save as” under the old name to get my starting situation back ...?
Just because I said “NO” to load the Backup File in first place ... ? :-(

This task depends upon

Closed by  Andrew (andrew)
Saturday, 12 January 2013, 22:16 GMT+2
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Saturday, 12 January 2013, 22:16 GMT+2

This seems to be correct behavior, yes. Answering the recovery question with 'no' means that that QCAD will try to load the selected file (not the autosave file). The autosave file is backed up for exactly that reason that you might change your mind after trying to load the selected file.

Loading...