QCAD Bugtracker

  • Status Closed
  • Percent Complete
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
  • Operating System Windows XP
  • Severity Low
  • Priority Very Low
  • Reported Version 3.0.6 (snapshot)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by Husky - 19.01.2013
Last edited by Andrew - 20.06.2013

FS#749 - QCAD 3.0.6 / 3.0.7 autosave crashes

XP32/ QCAD 3.0.6

The 3.0.6 Version (Snapshot) is very instable - crashed always after a couple minutes ... :-(

Problem signatur:
AppName: qcad.exe AppVer: ModName: qtcore4.dll
ModVer: Offset: 0005d1e8

Closed by  Andrew
20.06.2013 09:55
Reason for closing:  Fixed
Additional comments about closing:  

Not reproducible, no new information about newer versions. Should the problem persist, please re-open.

Husky commented on 19.01.2013 07:52

Additional Info:
The last crash with 3.0.6 caused a drawing lost. I was not able to reopen the last drawing - File size = 0 bytes!
The Autosave function is enabled - 15 min - but I found only backups dated 9 days ago ....... unusable after 9 days permanent working on that drawing!
Nice to have an additional Backup Program running ... ;-)

Andrew commented on 19.01.2013 09:10

Thanks for the quick feedback. I've taken down the Windows snapshots for now until I have more time for testing / trying to reproduce this problem.

Andrew commented on 21.01.2013 10:17

3.0.7 development snapshot is now available for download. It fixes one potential problem with crashes under Windows but I cannot tell yet if this is what has been the cause of the problems you have been experiencing.

-- commented on 21.01.2013 13:51

Windows 7-64

3.0.7 seems good so far, the previous reports of zooming problems with the grid and the 'flickering' doesn`t happen now, is this due to a QT 'roll back' here?

The only thing I`ve found so far is that I`ve had to disable the auto-save function as it just gives repeated warnings;

Can't open file: "C:/Users/cct38/AppData/Roaming/RibbonSoft\~~Untitled_2.dxf"
[13:35:46] Autosave failed: C:\Users\cct38\AppData\Roaming\RibbonSoft\~Untitled_2.dxf

Is this due to only using 3.0.7 from the zip file and not fully installing it?



Andrew commented on 21.01.2013 15:28

Thanks Clive!

The zooming / flickering issues were caused by the Qt update, yes. I've decided to use Qt 4.7 for now.
An install from the ZIP should not cause any problems / different behavior for the autosave.
I'll check if I can reproduce that here under Windows.

Husky commented on 21.01.2013 21:57

Nice - we have a rule!
I tested a little bit the new release 3.0.7 under XP/32
Crashes - the same problem like the 3.0.6 ...
Beforehand: I lost my Autosave function in the 3.0.0 and if I remember right it must happen after installing the 3.0.6 .... ? The Function was still enabled but not working!

Now my testing:
After running the 3.0.7 (from zip!) it crashed again every couple minutes. After disabling the Autosave function QCAD doesn't crash ......!!!
If I enable the Autosave function it will crash again - exactly in the Time guideline from the Autosave function. To make it more interesting for the programmer ;-) it will only crash after the third run of Autosave. Working or not working on the drawing doesn't matter.

My 2 cents: It has definitive something to do with the Autosave Function ...

Andrew commented on 21.01.2013 21:59

Many thanks Husky - that will definitely give me an idea where to look!

PS: Can you check if it does or does not crash when saving a drawing normally (Ctrl-S or File - Save) a couple of times?

-- commented on 21.01.2013 22:33

OK, here`s my testing:

I`ve now downloaded 3.0.7 at home on windows 7-64 and running side by side with 3.00.

1.In 3.0.7 same problems with auto-saving but disabled it and then tested 'Ctrl save' and File > save with no problems at all.

2.Then - totally un-installed/removed both 3.00 and 3.0.7 and 'cleaned up' everything (appdata -roaming files etc...

3.Then installed with installer 3.0.7 and now I have absolutely no problems at all -auto-save function working as it should and Ctrl save and File > Save working with no problems!
So for now I`ll leave things like this and test some more.

My theory is that somehow both applications when run 'side by side' are using the appdata function and maybe this is conflicting in some way, is this possible here?

Husky commented on 21.01.2013 23:06

3.0.7 XP/32

Autosave OFF:
10x "Save" → NO problems
10x "Ctrl-S" → NO problems

Autosave ON:
Below Time schedule of Autosave:
10x "Save" → 10x "Crtl-S" → No Problem
Autosave kicks in: 10x "Autosave" → NO PROBLEMS!

Interesting - is the curse broken with the manually saves of the drawing?

I guess you are right with your "side by side" theory but I like to mention that I was never running two different versions at the same time for this testing ....

Husky commented on 22.01.2013 03:41

Just saying...
... since many hours 3.0.7 works stable ... inclusive Autosave!!! :-) During my test I haven't open any erstwhile version.

-- commented on 22.01.2013 10:04

Me too, still no problems, 3.0.7 still stable and I have used it successfully when editing and saving 2 files to laser cutter :)

Husky commented on 22.01.2013 20:53

After many hours without problems - 3.0.7 crashes again and set the drawing AND the Backup file to 0 bytes.
First crash today was directly after a manually "Save".

Husky commented on 23.01.2013 01:02

3.0.7 running without Autosave, worked on a drawing,
Manually saved the drawing 3 times in row with "Save",
1. time - OK,
2. time - OK,
3. time - crash!
Drawing has again a 0 Byte size ...
Between savings I haven't changed anything on the drawing.

-- commented on 30.01.2013 10:40


Windows 7-64

Still no problems after lots of production work/editing etc.

savong works fine for me with or without Autosave enabled.

Husky commented on 30.01.2013 18:08

I'm jealous - what ever I have tried - nothing works .... :-(

-- commented on 30.01.2013 18:55

Husky - just curious, do you get a crash on simple or complex drawings -or both?

Husky commented on 30.01.2013 19:38


Husky commented on 20.02.2013 22:17


Any luck?

Andrew commented on 21.02.2013 06:58

Husky: no, this has not been reproducible here so far.

Husky commented on 21.02.2013 07:14

Thanks for the Info!


Available keyboard shortcuts


Task Details

Task Editing