QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#759 - Button "Flip Block" doesn't remains Highlighted ...

Attached to Project: QCAD
Opened by Husky (Husky) - Friday, 08 February 2013, 00:56 GMT
Last edited by Andrew (andrew) - Friday, 08 February 2013, 23:51 GMT
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Insert Block:

If I use the “Flip Block” option (Horizontal and/or Vertical) the Buttons doesn’t remains Highlighted. It should remain Highlighted ... ;-)

This task depends upon

Closed by  Andrew (andrew)
Friday, 08 February 2013, 23:51 GMT
Reason for closing:  Not a bug
Comment by -- (clive) - Friday, 08 February 2013, 11:10 GMT

Hi Husky

I actually prefer the way it is, otherwise I may insert a block persistently in a certain 'flipped' way.

I guess its a matter of personal taste here ;)

Comment by Husky (Husky) - Friday, 08 February 2013, 18:01 GMT

Hi Clive,
I said it isn't Highlighted - I don't said it is not working! What means you have never the visual info about the "Flip Status" what brings you in danger to insert a block persistently on an unwanted way ... ;-)

I don't just think it is only a matter of personal taste here - it's for me more a matter of Informational Feedback and consistency of the Program. E.g. the Insert Function of the clipboard is already working with Highlighted Flip buttons ...

Comment by -- (clive) - Friday, 08 February 2013, 20:13 GMT

Husky - yes fair enough, good point!

Comment by Andrew (andrew) - Friday, 08 February 2013, 23:50 GMT

This is intended behavior.

Basically, block inserts cannot be flipped (only scaled and rotated). QCAD achieves flipping by changing scale signs and rotating.
E.g. clicking the horizontal flip button is just another way for changing the sign of the scale factor in Y and applying a 180 degree rotation. The flip buttons do not apply an additional operation (like the flip buttons of the paste tool). They are not switches but helper tools to apply a flip by scaling and rotating.

Loading...