QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#765 - Imprecise drawing of circle

Attached to Project: QCAD
Opened by Christian Aigner (caigner) - Thursday, 14 February 2013, 19:29 GMT+2
Last edited by Andrew (andrew) - Monday, 18 February 2013, 17:59 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I use version 3.0.8

By accident I stumbled across a minor bug.

I wanted to connect two arcs seamlessly with a third arc. (Image 1)

So I drew two straight lines at right angles at the end of each arc, and at the crossing I put the center point of a circle. (Image 2)

Out of curiosity I zoomed in to the end of the second arc and discovered that the circle did not go through the end point of the arc, even tough I snapped it to the end point. (Image 3)

I could trim the circle to the wanted arc and the arc is displayed without any displacement.

So it seems that only the display of the circle is faulty, not the internal representation of it.

This task depends upon

Closed by  Andrew (andrew)
Monday, 18 February 2013, 17:59 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  Caused by new approximation of arcs with splines. New implementation reverts back to line segments.
Comment by Christian Aigner (caigner) - Friday, 15 February 2013, 07:22 GMT+2

Oh, I forgot to mention that I use the Linux version. Sorry.

Comment by -- (clive) - Monday, 18 February 2013, 11:50 GMT+2

Testing 3.0.8
Windows 7 - 64
I can reproduce this also.

Loading...