QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#768 - Polyline > Delete segments between two nodes not working

Attached to Project: QCAD
Opened by -- (clive) - Monday, 18 February 2013, 16:17 GMT+1
Last edited by Andrew (andrew) - Monday, 18 February 2013, 19:21 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity Low
Priority Normal
Reported Version 3.0.6 (snapshot)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Windows 7 - 64
3.0.8
Polyline > Delete segments between two nodes not working.

This task depends upon

Closed by  Andrew (andrew)
Monday, 18 February 2013, 19:21 GMT+1
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Monday, 18 February 2013, 18:06 GMT+1

Do you have steps to reproduce?

Procedure should be:
- Draw polyline (e.g. with 6 nodes)
- Start tool to delete segments between two nodes
- Click polyline
- Click first node
- Click second node
→ All segments between the first and the second node are removed

Thanks

Comment by Christian Aigner (caigner) - Monday, 18 February 2013, 19:05 GMT+1

I use Version 3.0.8 / Linux

I can confirm the bug. I drew a polyline and then tried to remove segments from the polyline. What happened was that the nodes between the selected start and end node were removed and the start and end node were then connected with a line.

Maybe the tool has the wrong label and should be called "remove nodes from polyline".

Comment by Andrew (andrew) - Monday, 18 February 2013, 19:21 GMT+1

This is indeed expected behavior. The tool does not split up the polyline into two polylines. It removes all segments between two chosen nodes and replaces them with a new, straight segment to keep the polyline intact.

Comment by -- (clive) - Monday, 18 February 2013, 20:16 GMT+1

Actually yes this does work as I would expect, I wasn't selecting the start and end nodes correctly.

Loading...