QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#79 - SUSE binary crashes under Fedora

Attached to Project: QCAD
Opened by Martin (martin) - Thursday, 12 May 2011, 15:40 GMT+1
Last edited by Andrew (andrew) - Sunday, 22 May 2011, 15:21 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Linux (All / Other)
Severity Low
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

  • during the start up
  • last info from splash screen: LibraryBrowser: Directory: metric
./qcad: line 5:  2321 Segmentation fault      (core dumped)
LD_LIBRARY_PATH=/home/martin/opt/qcad-3.0.0-tp1-prof-linux /home/martin/opt/qcad-3.0.0-tp1-prof-linux/qcad-bin $*
(gdb) bt
#0  0x03180194 in __strncmp_ssse3 () from /lib/libc.so.6
#1  0x08c7741e in __xmlParserInputBufferCreateFilename ()
#2  0x04333e04 in xmlParserInputBufferCreateFilename ()
   from /usr/lib/libxml2.so.2
#3  0x043bc9c0 in xmlNewTextReaderFilename () from /usr/lib/libxml2.so.2
#4  0x041fde98 in ?? () from /usr/lib/libgnomevfs-2.so.0
#5  0x041fe381 in gnome_vfs_mime_get_value () from /usr/lib/libgnomevfs-2.so.0
#6  0x041fbb38 in gnome_vfs_mime_get_icon () from /usr/lib/libgnomevfs-2.so.0
#7  0x040d0ab6 in gnome_icon_lookup () from /usr/lib/libgnomeui-2.so.0
#8  0x040d1037 in gnome_icon_lookup_sync () from /usr/lib/libgnomeui-2.so.0
#9  0x0240ee92 in ?? ()
   from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtGui.so.4
#10 0x026a0658 in QFileIconProvider::icon(QFileInfo const&) const ()
   from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtGui.so.4
#11 0x025cd467 in ?? ()
   from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtGui.so.4
#12 0x025c2f89 in ?? ()
   from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtGui.so.4
#13 0x025c3ba4 in QFileSystemModel::index(QString const&, int) const ()
   from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtGui.so.4
#14 0x025c7289 in QFileSystemModel::sort(int, Qt::SortOrder) ()
   from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtGui.so.4
#15 0x025bc86c in ?? ()
---Type <return> to continue, or q <return> to quit---
   from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtGui.so.4
#16 0x025c6d68 in QFileSystemModel::qt_metacall(QMetaObject::Call, int, void**)
    () from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtGui.so.4
#17 0x08881dc2 in RFileSystemModel::qt_metacall(QMetaObject::Call, int, void**)
    ()
#18 0x02cd3c83 in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtCore.so.4
#19 0x02cdede6 in QMetaCallEvent::placeMetaCall(QObject*) ()
   from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtCore.so.4
#20 0x02ce09a0 in QObject::event(QEvent*) ()
   from /home/martin/opt/qcad-3.0.0-tp1-prof-linux/libQtCore.so.4
#21 0x025c07c3 in QFileSystemModel::event(QEvent*) ()
This task depends upon

Closed by  Andrew (andrew)
Sunday, 22 May 2011, 15:21 GMT+1
Reason for closing:  Not a bug
Additional comments about closing:  looks like a bug in vbox, works under vmware
Comment by Andrew (andrew) - Friday, 13 May 2011, 09:25 GMT+1

looks like we need to compile a separate binary for fedora to support it.

Loading...