QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#804 - "Color by Layer" uses wrong Layer for Blocks

Attached to Project: QCAD
Opened by Matthias Melcher (matthiaswm) - Monday, 29 April 2013, 18:10 GMT+1
Last edited by Andrew (andrew) - Saturday, 04 May 2013, 19:54 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Not sure whether this is intentional, but IMHO it is not logical and wrong:

When loading a block that has a drawing set to “color by layer” into any layer but “0”, it will still always show the color of the “0” layer.

However, it should show the color of the layer that this Block is in (this is likely true for all the other attributes).

This task depends upon

Closed by  Andrew (andrew)
Saturday, 04 May 2013, 19:54 GMT+1
Reason for closing:  Not a bug
Comment by Matthias Melcher (matthiaswm) - Monday, 29 April 2013, 18:13 GMT+1

PS: very funky: if you have a Block in a non "0" layer, and you make the "0" layer invisible, the Block vanishes. It *also* vanishes if you make the Block's layer invisible. Double invisibility ;-)

Comment by Andrew (andrew) - Monday, 29 April 2013, 20:04 GMT+1

Please read our FAQ at:
http://www.ribbonsoft.com/en/qcad-documentation/faq#q26 → "My entities in a block appear to be on more than one layer"

Please post back if that does not explain the behavior you are experiencing.

Comment by Matthias Melcher (matthiaswm) - Monday, 29 April 2013, 20:19 GMT+1

Sorry, I did not see that. I will read the FAQ more carefully. Very unexpected, but probably why this is in the FAQ. Sorry for the noise.

Loading...