QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#848 - Tool selection not as expected

Attached to Project: QCAD
Opened by Harold Fanshawe (modratec) - Friday, 05 July 2013, 01:28 GMT+2
Last edited by Andrew (andrew) - Friday, 05 July 2013, 11:14 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Mac OS X Snow Leopard
Severity Low
Priority Normal
Reported Version 3.1.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Tool selection does not behave as I would expect.

For example, opened existing file. Select Dimension Tools. Dimension Tools show. Select Vertical. Selection successful, and tools change to show dimension sub menu. (OK so far.)

Now hit Back twice to return to main tool menu. Select Modification Tools. Instead of seeing the modification tools menu, I see (again) the dimension tools sub menu. I have to hit Back once to see the modification tools menu.

Perhaps this behaviour is as intended, but it is very annoying.

This task depends upon

Closed by  Andrew (andrew)
Friday, 05 July 2013, 11:14 GMT+2
Reason for closing:  Not a bug
Comment by Husky (Husky) - Friday, 05 July 2013, 09:37 GMT+2

Hi Harold,

yes - to my knowledge this behavior is intended.

Maybe you like to try this:
Instead of using the Back Button in the CAD Tool Menu use the right mouse button twice. It will bring you back to the Cad Tools Start position.
Same works on the Keyboard - hit qq or alternate hit the Arrow Symbol Button - see screen shot.
The command is called "Reset/Idle".

Loading...