QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#877 - Patches to build QCAD 3.2.0.0 on FreeBSD

Attached to Project: QCAD
Opened by Thierry Thomas (thierry) - Saturday, 10 August 2013, 14:28 GMT+1
Last edited by Andrew (andrew) - Saturday, 10 August 2013, 16:58 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Linux (All / Other)
Severity Low
Priority Normal
Reported Version 3.2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hello,

The attached patches are used to build QCAD on FreeBSD.

Notes:

- patch-shared_app.pri adds a dependency to libexecinfo. It is marked as fixed in  FS#876 , but still there.

It could be useful also for the other BSDs.

- patch-src_3rdparty_opennurbs_opennurbs_system.h remove malloc.h. It is marked as fixed in  FS#875 , but still there.

- patch-src_3rdparty_3rdparty.pro, patch-src_core_core.pro, patch-src_core_math_RSpline.h and patch-src_entity_entity.pro allow to use opennurbs as a dependency from the ports system, which is the recommended method, but you may ignore them in the general distribution sources if you prefer.

- patch-src_core_RSettings.cpp is specific to the ports system (”/usr/local/share/qcad” is not really hardcoded, and modified according to $PREFIX at build time): you may ignore it if you want.

Best regards,

Th. Thomas

This task depends upon

Closed by  Andrew (andrew)
Saturday, 10 August 2013, 16:58 GMT+1
Reason for closing:  Not a bug
Additional comments about closing:  Moved to user forum at:
http://qcad.org/rsforum/viewtopic.php?f= 30&t=2509
Comment by Andrew (andrew) - Saturday, 10 August 2013, 14:35 GMT+1
patch-shared_app.pri adds a dependency to libexecinfo. It is marked as fixed in  FS#876  , but still there.
patch-src_3rdparty_opennurbs_opennurbs_system.h remove malloc.h. It is marked as fixed in  FS#875  , but still there.

Note that fixes are applied to the master branch, not tagged versions.
You can find the diffs in the closed bug reports.
Checking out master should fix these two build problems on FreeBSD.

Comment by Andrew (andrew) - Saturday, 10 August 2013, 14:37 GMT+1

We might want to move this report to the user forum since this is more informational than a bug report. What do you think?

Comment by Thierry Thomas (thierry) - Saturday, 10 August 2013, 14:54 GMT+1

OK, no problem for me.

Loading...