QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#887 - Wrong warning window with area selection ...

Attached to Project: QCAD
Opened by Husky (Husky) - Thursday, 15 August 2013, 22:09 GMT+2
Last edited by Andrew (andrew) - Tuesday, 27 August 2013, 13:14 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows XP
Severity Low
Priority Normal
Reported Version 3.2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Lower left to upper right selection which includes invisible blocks causes warning window if I try to use the clipboard “copy” or “cut” function:

“Trying to draw on or modify entities on a locked or invisible layer”

... but it works!

Upper right to lower left selection over all doesn’t calls the warning window!

This task depends upon

Closed by  Andrew (andrew)
Tuesday, 27 August 2013, 13:14 GMT+2
Reason for closing:  Fixed
Comment by -- (clive) - Friday, 16 August 2013, 15:08 GMT+2

I cannot reproduce this problem here, can you attach an example file for testing ?

Comment by Husky (Husky) - Friday, 16 August 2013, 20:16 GMT+2

Step/Pic 1: Situation ...
Step/Pic 2: Block twitched to invisible, rectangle selection lower left to upper right,
Step/Pic 3: Click on copy (clipboard) ... warning pops up ....

Rectangle selection from upper right to lower left works fine!

Comment by -- (clive) - Friday, 16 August 2013, 20:43 GMT+2

Thanks, I understand you correctly and I see what you mean now.
Does seem to be confusing -unless there is an explanation for this (a bug..?)
The only way I've found to avoid the warning currently is to first select all with window left to right, then make the block invisible...then the copy option works out ok!

Comment by Husky (Husky) - Friday, 16 August 2013, 20:50 GMT+2

It's only the warning window - everything else works as expected.

Comment by -- (clive) - Friday, 16 August 2013, 21:07 GMT+2

Yes agreed everything else works as expected!

@Andrew, I agree with Husky here -unless we are both missing something and the warning is for something, but not working ??? otherwise we don't need the warning!

Comment by Husky (Husky) - Sunday, 25 August 2013, 04:21 GMT+2

Additional!
Tool - Select rectangular area, lower left upper right, will also select invisible blocks in that area. If I use afterwards the delete function .... the invisible blocks are deleted too :-(

Upper right to lower left selection works as expected what means: Invisible blocks are invisible ;-)

Comment by Andrew (andrew) - Tuesday, 27 August 2013, 13:14 GMT+2

This should be fixed for the next release (invisible blocks are not selectable).
Please note that a block might contain another invisible block, in which case it can be selected. However, when trying to copy it, a more generic warning appears:
"Transaction failed. Please check for block recursions and locked or invisible layers or blocks."

Comment by Husky (Husky) - Tuesday, 27 August 2013, 19:08 GMT+2

Sounds good - I will check it out with the next release. Thanks!

Loading...