QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#890 - Relative zero point mark artifact on print preview

Attached to Project: QCAD
Opened by Tamas TEVESZ (kazmer) - Saturday, 17 August 2013, 15:42 GMT+2
Last edited by Andrew (andrew) - Saturday, 17 August 2013, 15:48 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Very Low
Priority Normal
Reported Version 3.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The relative zero point mark appears on the print preview screen. I don’t know, if it also gets printed (my printer setup appears to be broken at the moment), but it does not get exported to PDF, so I guess it is only on the print preview.

On a side note, I think that the reset command (qq) should also clear this. The manual states:

The Neutral State of QCAD
Menu:    Edit - Reset
Keycode: QQ

After the start, QCAD is in its neutral state. That means that no special tool is active and QCAD waits for you to click a menu or tool button to start a tool and start doing something.

As there is no relative zero point just after startup, I think it should also not persist a qq.

This task depends upon

Closed by  Andrew (andrew)
Saturday, 17 August 2013, 15:48 GMT+2
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Saturday, 17 August 2013, 15:48 GMT+2

This is intended behavior.

The relative zero point indicates what coordinate is used as reference for relative coordinates as well as snap restrictions. Since it is perfectly possible to construct and modify a drawing in print preview mode, the relative zero point can be useful in print preview as well. It never gets printed or exported though.

Reset should not reset the position of the relative zero point. This too is intended behavior.

If you find the relative zero point gets in your way, you might want to adjust its color / transparency in the application preferences.

Loading...