QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#898 - Circle tool regression in git ec746571

Attached to Project: QCAD
Opened by Tamas TEVESZ (kazmer) - Wednesday, 21 August 2013, 13:23 GMT+2
Last edited by Andrew (andrew) - Wednesday, 21 August 2013, 15:56 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Git ec746571 introduced the following artifact:

  • Start circle tool, center and radius
  • Click on point to select radius
  • Circle appears, along with a line to the coordinate system origin; also circle is not closed at around where this ghost line hits the circle entity
  • Happens with any circle tool, in slightly different manners
  • Doesn’t happen with any other tool, as far as I can tell

100% reproducible, doesn’t happen on git 6171094d.

This ghost line is also added to existing circles; ie. opening a drawing that has circles, a ghost line is attached to each of them. Not always pointing to the origin, but seems kind of random (changes with zoom level etc.)

It doesn’t seem to be a part of the drawing as such, as in ZA will not zoom so that all these ghost lines are fully visible, but the visual artifact remains.

If relevant: Linux/amd64 (Ubuntu 12.04), Qt 4.8.1, GCC 4.6.3, and as said, QCAD git ec746571.

Lines on attached illustration were not actually drawn in any way, shape or form; also they behave as if a particular line and its corresponding circle were a block, except one end of the line is firmly attached to origin.

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 21 August 2013, 15:56 GMT+2
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Wednesday, 21 August 2013, 14:13 GMT+2

Thanks for the heads-up.
I cannot reproduce that problem here. I'm using Qt 4.8.4 but don't think that should be the problem.
Could it be that the sources were updated and built without doing a 'make clean' in between? Just guessing..

Comment by Tamas TEVESZ (kazmer) - Wednesday, 21 August 2013, 15:53 GMT+2

Building a completely new clean checkout indeed seems to have resolved this. Strange, because I do do a make clean between build passes.

Loading...