QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#916 - SVG export: make zero line width behaviour configurable

Attached to Project: QCAD
Opened by Peter (hungerburg) - Tuesday, 17 September 2013, 13:35 GMT+1
Last edited by Andrew (andrew) - Wednesday, 18 September 2013, 13:53 GMT+1
Task Type Feature Request
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.2.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Somewhere in the 3.1 series the SVG exporter (both precise and PG) started to make lines that are zero (0) width in CAD 0.01 (@scale 1:1) points wide in exported files (0.1 @scale 1:10). I use such lines to constrain exported files to a common size and rather not have them show. In my view, this is a regression, as there is no reason for changing line weight, isnt it? If I wanted the lines to have weight, I’d draw them with a weight.

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 18 September 2013, 13:53 GMT+1
Reason for closing:  Won't implement
Additional comments about closing:  Feature might not be necessary (see comments).
Comment by Andrew (andrew) - Tuesday, 17 September 2013, 13:57 GMT+1

The problem here is that most users expect a line to show up in the SVG drawing if it also shows up in QCAD.

In the context of CAD, zero width lines are defined as 'as thin as possible' (thinnest plotter pen or thinnest line a printer can produce).
In the context of SVG, zero width means zero width (i.e. not visible).

In that sense this is intended behavior. As always in such cases, a configuration option might be the solution, so I'll change this into a feature request for such an option.

Comment by Peter (hungerburg) - Tuesday, 17 September 2013, 14:52 GMT+1

Thank You Andrew for the explanation. I consider mine a legitimate use case still, so thank you for turning this into an enhancement request. I single stepped the exporter. Unfortunately, I cannot patch the script, and as RS.PointTolerance is immutable, I can not help myself at the moment. I liked QCAD more, when the PRO scripts lived in the filesystem, but you surely know your reasons ;)

I also cannot think of another way, how to determine a fixed plane (viewbox) for my exports, can you? Possibly, thats a better feature request?

Comment by Peter (hungerburg) - Tuesday, 17 September 2013, 15:11 GMT+1

Andrew, I guess I got it! No need for lines, just put two points in diagonally opposing corners of my plane, they will be used to calculate the viewbox in the resulting SVG (at least if nothing else sticks outer there), even when export points is false! No need for another configuration switch, at least not for me :)

Comment by Andrew (andrew) - Tuesday, 17 September 2013, 15:16 GMT+1

Great, thanks for the update. I really should have thought of that since I'm doing exactly the same for all the figures in the QCAD book.

Loading...