QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#925 - Attribute definitions duplicated when loaded from DWG

Attached to Project: QCAD
Opened by kurt (kurtforrester) - Tuesday, 24 September 2013, 21:31 GMT+1
Last edited by Andrew (andrew) - Wednesday, 25 September 2013, 12:15 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.3.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Title says it all. Cannot get QCAD to synchronise attributes on Fedora 19 box with QCAD 3.2.2 installed as the machine hangs (a single core of CPU maxed out). This is not present on my Windows machine (Windwows 7).

I can provide a sample file privately if needed.

Kurt

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 25 September 2013, 12:15 GMT+1
Reason for closing:  Fixed
Comment by Andrew (andrew) - Tuesday, 24 September 2013, 21:38 GMT+1

Thanks for your report. Please send the file to info [at] qcad.org, thanks.

Comment by Andrew (andrew) - Wednesday, 25 September 2013, 12:11 GMT+1

Thanks for the file.

The file contains many (in some cases >100) duplicate attribute definitions in some blocks. It also contains many duplicate attribute entities, likely as a result from synchronizations.

The cause of the problem appears to be a Teigha bug which leads to duplicate imports of attribute definitions from DWG files.

I've fixed the file and sent you a copy. As a workaround for the bug, please save to the DXF format for now.

The next release of QCAD has a workaround built in and should no longer suffer from this problem. Also attribute synchronization has been improved to never synchronize duplicate attribute definitions.

Loading...