QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#987 - Window size bigger than screen, unable to reduce it

Attached to Project: QCAD
Opened by Robert von Knobloch (BobvonKnobloch) - Friday, 06 December 2013, 12:13 GMT+2
Last edited by Andrew (andrew) - Monday, 09 December 2013, 12:17 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System OpenSUSE Linux
Severity Low
Priority Normal
Reported Version 3.4.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Using the 32-bit linux .tar.gz package on Opensuse 12.3 - KDE4, it opens with a window size larger than the screen (you cannot reach the maximise, minimise icons with the mouse.
Having maximised it with the keyboard, using the mouse on the corners the window can only be stretched in the east-west dimension and remains at a fixed height. I have reverted to 3.4.2 which is fine.

Bob

This task depends upon

Closed by  Andrew (andrew)
Monday, 09 December 2013, 12:17 GMT+2
Reason for closing:  Not a bug
2013-12-11: A request to re-open the task has been made. Reason for request: Problem still there
Comment by Andrew (andrew) - Friday, 06 December 2013, 19:35 GMT+2

Thanks for your report.

I suspect that there is a docked widget or series of docked widgets that don't fit on your screen.
Could you attach a screenshot? Thanks.

Comment by Robert von Knobloch (BobvonKnobloch) - Monday, 09 December 2013, 10:46 GMT+2

I think that this was the case. I removed most of the docked windows and could then resize the window normally. Unfortunately, I have been unable to get back to the 'locked' condition, even though I tried removing the qcad.conf file.

Oh well, it works now.
Thanks,

Bob

Comment by Robert von Knobloch (BobvonKnobloch) - Wednesday, 11 December 2013, 13:38 GMT+2

I spoke too soon.
Every time I open a new QCAD session following a reboot (e.g. first thing in the morning), the QCAD window is bigger than the screen, hiding the maximise, minimise etc. buttons..
Control can be regained using <alt> F3 and maximising it (which makes it smaller!).
After this it can be used normally, but I think many people will nave trouble if this occurs on many platforms.

Regards,

Bob

Comment by Andrew (andrew) - Wednesday, 11 December 2013, 13:50 GMT+2

This is the first and only such report I am aware of.
If would help if you could attach a screenshot which shows the situation or attach your ~/.config/QCAD.ini and indicate the screen resolution you are using.

Comment by Robert von Knobloch (BobvonKnobloch) - Wednesday, 11 December 2013, 14:13 GMT+2

I cannot make a sensible screenshot, it captures a full QCAD window, but this is not displayed.
My screen resolution is 1680 x 1050.
I have no .config/QCAD.ini , but I do have a .config/QCAD/QCAD3.conf (attached).
If I am the only case, I would suggest that it is not worth following up. I can work around it anyway and can wait for the next release.

Thanks,

Bob

Comment by Andrew (andrew) - Wednesday, 11 December 2013, 14:26 GMT+2

Thanks. The window position / size are stored in QCAD3.conf:

[Appearance]
Position.X=188
Position.Y=0
Width=1393
Height=1065

This looks like it won't fit on your screen of 1680x1050 (height wise). If you make the window smaller, the smaller size should be written to QCAD3.conf

Some ideas from the top of my head:

  • QCAD might not be able to save its size (e.g. file permission problem)
  • QCAD is not being properly shut down and therefore does not have a chance to save all of its settings.

This is for example the case if you launch QCAD from a terminal and shut it down using Ctrl-C.

Comment by Andrew (andrew) - Wednesday, 11 December 2013, 14:26 GMT+2

You can also try to delete the QCAD3.conf file in case that file got corrupted somehow.

Comment by Robert von Knobloch (BobvonKnobloch) - Wednesday, 11 December 2013, 14:49 GMT+2

Permissions are OK, file is saved on exit, BUT the height is rewritten to a larger value that my screen each time.
I deleted QCAD3.conf and all was OK until I shut it down (properly) and on re-opening the old problem reappeared. Now the screen height is 1137 (why it is different, I don't know).
AHA! with some experimenting, I (believe I) have found the feature that causes this.
It only occurs with the Library browser enabled and docked (it doesn't seem to matter which other panes are docked).
If I un-dock it or disable it, all is OK.

Hope this is useful,

Bob

Loading...