QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategory  descTask TypeSeveritySummaryStatusProgress
1518QCAD (main)Bug ReportVery LowLandscape/Portrait gets confused for custom page sizeAssigned
0%
Task Description

Hello

In the Print Preview or Drawing Preferences / Page Settings if I select a Custom size, then landscape/portrait does not really make sense.

For instance, at work we have a laser cutter which uses a printer driver. The bed of the laser is 600 wide by 300 high. When I wanted to cut
something, I created a custom page size of 600×300 and selected Landscape (because it is wider than high)

Strangely, back in the Print Preview, the page is now sized opposite with regards to Portrait / Landscape mode, which was confusing somewhat.

(see pictures attached)

I think that for ‘Custom’ page size in Drawing Preferences, the option of Portrait or Landscape should probably be ghosted

Then, I think that for Portrait / Landscape mode in the Print Preview, it should display the shape most appropriate, rather than just assuming that the document fits the norm:

  1. Taller than Wide for Portrait mode
  2. Wider than Tall for Landscape mode
1587QCAD (main)Bug ReportVery LowPDF export created with wrong date timeAssigned
0%
Task Description

Hi guys,

when I export my dxf drawing to pdf, the pdf properties shows wrong “created date”. I am in UTC+2, the date shows 2 hours less.
I exported the pdf at 12:24, the attached ps shows 10:24.

BR,
Soma

1660QCAD (main)Bug ReportVery LowViewport in Model Space ...Assigned
0%
Task Description

... I have the feeling that wasn’t the idea. I’m correct?

Case:
in Model Space, launch Add Viewport, determine the Viewport rectangle - when done QCAD will switch to a Layout Block.
Now in Layout Block, don’t(!) place the Viewport, switch back to Model Space and the Viewport is still attached to the Mouse pointer and you can place it in your Model Space. The source of the Viewport will then disappear.

1691QCAD (main)Bug ReportVery LowIssue with Layouts after "File-Revert"Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Liux Mint

Case:
1. Open some saved drawing with viewport entities on layout block (paper space). Print Preview mode is “On” automatically.
2. After “File-Revert” drawing is reopened on layout block (paper space), but now Print Previw mode is “Off” .

For example can try on “flange.dxf”

1692QCAD (main)Bug ReportVery LowIssue with Layouts. "Viewport" enteties are not highlig...Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Linux Mint

Case:
1. Open some drawing with viewport entities on layout block (paper scace). Print Preview mode is “On” automatically.
2. Switch to “Black/White Mode” from toolbar and move cursor on “Viewport” enteties. This entitie is not highlighted. With other enteties all works as expected.
In “Full Color Mode” and “Grayscale Mode” no problems.

For example can try on “flange.dxf”

1719QCAD (main)Bug ReportVery LowUndo on converted drawing leads to wrong label position...Assigned
0%
Task Description

Drawing converted from inch to mm - undo leads to wrong dim label position. I can fix that with “Reset Label position” but it would be nice if QCAD could to that in first place.

1743QCAD (main)Bug ReportVery LowAutozoom does not work when text contains superscriptAssigned
0%
Task Description

Hi,

I have a drawing where I use text with superscript. In this case when I use autozoom, it does not work as I expect. It includes the 0,0 coordinates too. The problem also occures when I export the drawing into svg.

I attached an example, just use the autozoom.

Thanks,
Soma


1744QCAD (main)Bug ReportLowQCAD crashes when opening .dgn filesAssigned
0%
Task Description

Have tried several samples from the web and the result is the same.

Here is the event log entry:
Faulting application name: qcad.exe, version: 3.20.0.0, time stamp: 0x5ad07892
Faulting module name: MSVCR120.dll, version: 12.0.21005.1, time stamp: 0x524f83ff
Exception code: 0xc0000409
Fault offset: 0x000000000006dd27
Faulting process id: 0x34d0
Faulting application start time: 0x01d3dbdf73dc50d2
Faulting application path: C:\Program Files\QCAD\qcad.exe
Faulting module path: C:\Program Files\QCAD\MSVCR120.dll
Report Id: 0644b1d2-d503-4525-ab02-fc36f87288a0
Faulting package full name:
Faulting package-relative application ID:

1506dxflibFeature RequestLowwriteVPort parametersAssigned
0%
Task Description

Add parameters to the function DL_Dxf::writeVPort.
This way users will be able to specify the desired viewport.

Is the github the official repository? Are pull requests sent there accepted?

976dxflibBug ReportLowDXF import errors related to hatches, textsAssigned
0%
Task Description

See:
http://www.qcad.org/rsforum/posting.php?mode=reply&f=30&t=2677

1180dxflibBug ReportLowdxflib cannot open files with international characters ...Assigned
0%
3 Task Description

With dxflib, QCAD cannot open any file with Chinese file name or path name, it popups a “Important Error” dialog.
But the writing (”Save As” command) with Chinese file name or path name is of no problem.
Does it mean dxflib can only handle single byte characters file name/path name?
WinXP, QCAD 3.8.0

1203dxflibBug ReportLowImages not saved (dxflib)Assigned
0%
Task Description

I am doing a bit of landscaping and using a (big) ortophoto as one of my layers in order to sanity-check on the ground measurements.

The layer contains a point and the image and nothing else.

The image is a 8MB file: “PNG image data, 4200 x 2980, 8-bit/color RGB, non-interlaced” and it is scaled to 210 coordinate units (meter) horizontally in the drawing.

With approx 50% probability the image disappears during Save, as see for instance in this diff of the DXF file:

      @@ -158699,28 +153057,6 @@ AcDbXrecord
        90
       6
         0
      -IMAGEDEF
      -  5
      -A1
      -100
      -AcDbRasterImageDef
      - 90
      -0
      -  1
      -/critter/HTV10/Ortofoto/ortofoto201502f.png
      - 10
      -210.0
      - 20
      -149.0
      - 11
      -1.0
      - 21
      -1.0
      -280
      -1
      -281
      -0
      -  0
       ENDSEC
         0
       EOF

The point in the same layer does not similarly disappear, the bug only seems to affect images.

I have seen this bug from version 3.7.5.0 to git as of yesterday (63e06c778926a803bdfbffdf27b8c24d41511072).

I have not been able to correlate the bug with anything.

Looking closer at the DXF file (attached), there seems to be some residuce of attempts to insert images in protected/invisible layers, so this may be some kind of refcounting issue.

(Any chance of getting FreeBSD into the “Operating System” field ?)

1542dwg2svgFeature RequestLowdwg2svg: add switch to show only given layer(s)Assigned
0%
Task Description

Implement a command line switch to only show a list of given layers for dwg2* command line tools.

1021dwg2pdfFeature RequestLowdwg2pdf: switch to set block to exportAssigned
0%
1 Task Description

Add a command line switch to dwg2pdf to export a given block instead of “*Model_Space”.

1700dwg2pdfFeature RequestLowdwg2pdf: output multiple layoutsAssigned
0%
Task Description

Add support to specify multiple blocks (layouts) to output (one per page).

Showing tasks 351 - 365 of 365 Page 8 of 8<<First - 4 - 5 - 6 - 7 - 8

Available keyboard shortcuts

Tasklist

Task Details

Task Editing