QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategory  ascTask TypeSeveritySummaryStatusProgress
1719QCAD (main)Bug ReportVery LowUndo on converted drawing leads to wrong label position...Assigned
0%
Task Description

Drawing converted from inch to mm - undo leads to wrong dim label position. I can fix that with “Reset Label position” but it would be nice if QCAD could to that in first place.

 1743 QCAD (main)Bug ReportVery Low Draw > Text: Wrong bounding box for text with empty sup ...Closed
100%
1 Task Description

Hi,

I have a drawing where I use text with superscript. In this case when I use autozoom, it does not work as I expect. It includes the 0,0 coordinates too. The problem also occures when I export the drawing into svg.

I attached an example, just use the autozoom.

Thanks,
Soma


 1751 QCAD (main)Bug ReportVery Low Can't open files from terminal Closed
100%
Task Description

I have file /home/test/test.dxf . When i try open file from terminal (qcad test.dxf), i have warning “File not found”. When i write full path (qcad /home/test/test.dxf), the file opens.

 1759 QCAD (main)SuggestionVery Low Modify // .... selection of entities on locked layer al ...Closed
100%
Task Description

Without any selection.
Entities on a locked layer can be selected after choosing:

Asumed wrong
- Modify DI
- Modify
B2
- Modify D3
- Modify
MT

Questionable
- Modify RM
- Modify
CH
- Modify RN Less severe
- Modify
OF
- Modify OH
- Modify
SS

Regards

1760QCAD (main)Bug ReportVery LowSelf-crossing polylines can't be cut twice at segment c...Assigned
0%
Task Description

Re-entering dividing problem from  FS#1757 

Divide the poly selecting near segment 1 at the segment crossing.
> A new node is inserted on the crossing and made start and end node.
Divide the poly again selecting near segment 2 at the segment crossing.
> no division appears to be done.

One can’t divide the second segment at the crossing

Presumed intended behaviour like  FS#1750 

Regards

 1762 QCAD (main)Bug ReportVery Low Modify // .... selection of entities on locked layer al ...Closed
100%
Task Description

Not served with the degration to ‘Suggestion’  FS#1759 .
Demanded closing  FS#1759  & re-entered

Locking entities (by layer) to avoid selection,eg. nearby,very close by or on the same spot, does not have the intended influence.

Asumed wrong:
- Modify DI
- Modify B2
- Modify D3
- Modify MT
These 4 need a single entity to be selected and selection of a locked entity is allowed.(=questionable)
The action will allways leed to ‘not allowed’.(=correct)

Questionable:
- Modify RM
- Modify CH
- Modify RN
These 3 need a pair of entities.
RM: Selection of a locked limiting entity is allowed (=questionable), enity to trim not.(=correct)
The action will trim unlocked entities to the locked limiter.(=questionable)
CH & RN: Selection of a pair of entities is allowed.(=questionable)
Trimming if ‘trim’ is on will not occur because locked and leeds to ‘not allowed’.(=correct)
The creation of the bevel or rounding on an active locked layer will not occur because locked and leeds to ‘not allowed’.(=correct)
The creation, except for polyline segments (because locked themself), on an active unlocked layer will be done.(=correct)

Less severe but still questionable: (because these don’t necerally act on the locked entities themselves)
- Modify OF
- Modify OH
- Modify SS
OF: Selection of a locked base entity is allowed.(=questionable)
The preview is casted only if the active layer is unlocked.(=correct)
The creation is only done on an active unlocked layer.(=correct)
OH: Selection of a locked base entity is allowed.(=questionable)
Selection of point references from entities on locked layers is allowed.(=questionable)
The preview is casted only if the active layer is unlocked.(=correct)
The creation is only done on an active unlocked layer.(=correct)
SS: Selection of point references from entities on locked layers is allowed.(=questionable)
Strechting is only done for unlocked entities. (=correct)

1765QCAD (main)Bug ReportVery LowErrors with polyline offsetAssigned
0%
1 Task Description

Win 7 32 bit QCAD 3.20.1

Ofsset of a base-line with arcs results in massive ammount of errors.
Most of them occur as a cluster of very tiny segments and are part of the offset. (zoom far in at the red circles)
Mostly they occur where the offsetted arcs should merely be trimmend pairwise.
Some occur as detached entities or as detached strings of entities very near the offset (strings not documented).
Spooks occur at opposite site when base-line is not closed.
360° curls can occur with R = Offset.
Null-entities may occur (not documented, hard to find and not able to copy).

The base-line is checked and sound and has mixed tangentially or not tangentially connected arcs.
Offsetting the mother base-line of the base in the file has similar effect but not all and/or different ones.
Also encountered with offseting polys from fonts.
Used to define pocket paths for CNC.
Detected because the CNC driver will not accept Self-crossers, Null-entities or open ends depending on the settings.

Work arround is to explode and select small entities but this does not solves the issues.
1) Choosing the tolerance large enough will detect small segments that should stay.
2) Recombining will generate new ones at the place where the main segments remain crossed.
Cleaning up the paths is a daunting process with some thousand segments for several offsets.

I assume this has an infuence on the CAM part of QCAD too unless the offset method is different.

 1767 QCAD (main)Bug ReportVery Low Dimension Leader Closed
100%
Task Description

On print mode, the arrow not appear in the dimension

1788QCAD (main)Feature RequestVery LowNew snap: reference points of a block referencesAssigned
0%
Task Description

I know this was reported and fixed before ...

https://www.qcad.org/bugtracker/index.php?do=details&task_id=843

... but it looks like we have the issue now back with some kind of variation.

If I use the test drawing which I posted in 2013 ( FS#843 ) it works still as expected after it was fixed.

If I create a new block it won’t work in a new drawing nor in the old test drawing - no chance to snap to the Block Reference.

Edit: New Test drawing:

 1795 QCAD (main)Bug ReportVery Low Quit Menu Item disabled after opening preferences Closed
100%
Task Description

Quit Menu Item disabled after opening preferences.

System: OSX 10.13.6
Qcad version: 3.21.2.0

How to repeat:

  1. Open QCad
  2. Open preferences dialogue “QCad Pro → Preferences”
  3. Close dialogue
  4. The menu item “Quit QCad Pro” is now disabled. See attached screenshot

Repeatability: 100%

 1798 QCAD (main)Bug ReportVery Low Drawing Pref > Linetype > Scale of linetypes matches th ...Closed
100%
Task Description

“Drawing Preferences / General / Linetype / Scale of linetypes matches the scale of each viewport” is checked by default for new drawings, however the option is not applied until you open the “Drawing Preferences / General / Linetype” screen and click OK – no need to change anything, just opening the screen and clicking OK is sufficient.

 1804 QCAD (main)Bug ReportVery Low Application Preferences > Tool Settings: Filter for "Vi ...Closed
100%
Task Description

1. Search the Tool Settings for “View” and you will only find “Overlays” without the submenu information.
2. Check View manually without a search will provide the submenu information.

 1806 QCAD (main)Bug ReportVery Low Overlay Toolbar visibility in GUI not saved Closed
100%
Task Description

Switch “Overlay” Toolbar to visible below:
View/Toolbars and Widgets/Toolbars/View/Overlays, place the Toolbar in GUI, restart QCAD and the Toolbar is back to invisible.

 1572 QCAD Community EditionBug ReportLow Dimension font not set to "Standard" when importing thr ...Closed
100%
Task Description

Since updating to QCAD 3.16 on MacOS, my dimension font face suddenly changed to something very unattractive and I can’t figure out how to reset it. I tried deleting QCAD and all references to it in ~/Library and then reinstalling, but no luck. Something weird has gone wrong with QCAD’s fonts.

The font change has made it impossible to open and redraw many DXF files because the new font face is larger and wider spaced and it ruins the layout of many documents.

Attached is an example of what the same DXF file looked like in the prior QCAD version, and the new version. No change to the DXF file.

Dan.

 1639 QCAD Community EditionBug ReportLow Layer > Hide all Layers: cannot turn individual layer b ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=76&t=5092

 1724 QCAD Community EditionSuggestionLow "OVERKILL" command Closed
100%
Task Description

Is it possible to create “OVERKILL” command like in AUTOCAD

 1465 QCAD/CAMBug ReportCritical Circle is drawn as polygon Closed
100%
Task Description

Hi,

I have a circle and circle is not round.
Unit of drawing is in metres and radius is set to 2.38.
The circle displays as a polygon instead.

 1076 QCAD/CAMBug ReportHigh Crash on Mac OS X when using internal Trackpad Closed
100%
1 Task Description

Hi,

I have just updated my Mac OS from 10.9.2 to 10.9.4. QCAD 3.6.2 seems to be working normally under the newest version of Mac OS, but has developed a very specific bug which leads to reproducible crashes when a text object is edited.

Steps to minimally reproduce:
1. Open QCAD
2. Create a text object
3. Place the text object on the canvas
4. double-click the text object and edit its contents
5. click OK to accept changes
6. repeat from step 4 three or four times.

After several attempts to edit a text object, QCAD will crash with EXC_BAD_ACCESS (SIGBUS) in thread 0 (QCoreApplication).
The crash can also be triggered by moving the text object around on the canvas (instead of editing its contents).
The bug does not require anything else (no other objects on the canvas, no particular font, occurs in both new and previously saved documents).

Apart from this bug, QCAD seems to work fine on OS X 10.9. The text editing crash did not occur before the latest OS update. No other applications on my system seem to be having any problems. If this problem can be fixed, I think QCAD will be quite usable on 10.9.

See also related bugs in:
 FS#1091 

 1137 QCAD/CAMBug ReportHigh segfault creating dashed spline (without addons) Closed
100%
Task Description

Hello,

This is my first real bug report so please advise how i could provide more useful information.

I am not certain if the severity is correct.

The bug: segfault when creating a spline with a dashed linetype or opening a file containing one.

The bug isn’t present with the dwg extension installed

Steps to reproduce:
1. create drawing
2. create spline
3. set linetype to dashed
4. crash

 1322 QCAD/CAMBug ReportHigh Fonts mixed up witch code tables Closed
100%
Task Description

Hi,

In ‘Application preferences, Draw, Text’ fonts can be selected.

There is a mixing up between fonts (the appearance of characters on screen) and code tables (what digital code is used for each character).

‘ISO8859-11’ is the 8 bit Thai (!) code table and not a font
‘Unicode’ is the 16 bit code table and not a font.

For downward comptability QCAD should use default font Standard (ISO3098) with code table ISO8859-1 (US-ASCII Latin-1).

 1237 QCAD/CAMBug ReportMedium Blocks should be layer agnostic Closed
100%
Task Description

I have created a block from a selection. I have then later created more items on my CAD page using that block, then later yet, moved the objects to a new layer. I noticed that while the object has accepted being on the new layer, the color hasn’t changed to the new layer’s color. I can only get the line color to change if I go into the block itself and move the individual segments of the block to that new layer, then save the new block (which, by the way, I can’t save over the existing block?!?!)

In the sample file attached, you will see that the block item in the 3 o’clock position is in layer 0, while the rest are in “Vent Holes” layer. If you make layer 0 hidden, the one block is hidden (like it should), but the block item refuses to take on the layer’s color even though the block’s color is “By Layer”

 1293 QCAD/CAMBug ReportMedium Crash when snapping to intersection points between 3d l ...Closed
100%
Task Description

I have a file that makes QCAD crash. I’ve been editing this design across different versions of QCAD over time and this is the first time I have a problem with it.

Steps to reproduce:
Open the attached file and try to add some entities or dimensions to it (you may need to create large ones since it seems to depend on the zoom factor; for example a very large ellipse). After a freeze of a few seconds QCAD will quit.

The attached file is a simplified version from which I deleted a number of entities; on the original I can’t do anything – QCAD crashes as soon as I try to create any object.

Cause: 3D lines with x1==x2, y1==y2 but z1!=z2

 1564 QCAD/CAMBug ReportMedium QCAD/CAM: black main window or main window not painted  ...Closed
100%
Task Description

QCAD/CAM version 3.16.7.1 (snapshot release)

QCAD/CAM version 3.16.7.1 for Ubuntu Linux starts up with a totally black screen with only the title bar showing. By clicking around at the top of the screen I can get the menus to drop down and appear over the blank black screen. That is how I captured all the version information below. QCAD/CAM version: 3.15.5.0 for Ubuntu Linux starts with all the normal screen graphics appearing normally. I labeled this bug report as critical because QCAD/CAM is unusable on Ubuntu Linux, but for me it is not so critical since I can use the Windows version.

Versions
QCAD version: 3.16.7.1
Date: Mar 22 2017
Qt version: 5.8.0
Compiler version: gcc 4.8.1
Build Date: Mar 22 2017
Revision: 17a80fac27c3ae6aa68cd4ee15ffa4f3e2ab0a9a

Architecture: x86_64
OS: Linux
OS version: Unknown

Locale
QCAD locale: en
Name: en_US
Country: 225
Country name: United States
Language: 31
Language name: American English
Script: 7
Script name: Latin
Decimal point: 46
Negative sign: 45
Positive sign: 43
Text direction: 0
System codec: UTF-8

Arguments: /home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/qcad-bin

Plugins
Description=CAM tools.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadcamscripts.so
ID=CAM
License=Proprietary
Name=CAM
NamePostfix=/CAM
PurchaseURL=http://ribbonsoft.com/add-ons/qcadcam-purchase QtVersion=5.8.0
SplashOverride=:/scripts/Cam/splashscreen.png
SplashOverride@2x=:/scripts/Cam/splashscreen@2x.png
URL=http://ribbonsoft.com/add-ons/qcadcam Version=3.16.7.1

FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcaddwg.so
ID=DWG
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
SystemCodePage=0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1 (Teigha® 4.02.2.0)

Description=Import/export support for the DXF format. Based on dxflib.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcaddxf.so
ID=DXF
License=GPLv2+
Name=DXF
QtVersion=5.8.0
URL=http://www.qcad.org Version=3.16.7.1 (dxflib 3.12.2.0)

Description=OpenGL ES 3D display.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadgles3d.so
ID=GLES
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Description=Integrated help browser.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadhelp.so
ID=HELP
License=Proprietary
Name=QCAD Pro
QtVersion=5.8.0
URL=http://www.ribbonsoft.com Version=3.16.7.1

Description=Polygon clipping, boolean polygon operations, path offset.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadpolygon.so
ID=POLYGON
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Description=QCAD Professional tools.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadproscripts.so
ID=PROTOOLS
License=Proprietary
Name=QCAD Pro
NamePostfix= Professional
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Description=Polygon triangulation.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadtriangulation.so
ID=TRIANGULATION
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Environment
LC_TIME=en_US.UTF-8
DESKTOP_SESSION=default
SSH_AGENT_PID=1743
XMODIFIERS=@im=ibus
LOGNAME=dave
QT_ACCESSIBILITY=1
PAPERSIZE=letter
HOME=/home/dave
LC_NUMERIC=en_US.UTF-8
XDG_DATA_DIRS=/usr/share/default:/usr/share/gnome:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop
XDG_VTNR=2
SHELL=/bin/bash
XDG_SEAT=seat0
GIO_LAUNCHED_DESKTOP_FILE=/home/dave/Desktop/Ribbonsoft-qcad.desktop
WINDOWPATH=2
QT_IM_MODULE=ibus
XDG_SESSION_TYPE=x11
XDG_RUNTIME_DIR=/run/user/1000
LC_MEASUREMENT=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
XDG_CURRENT_DESKTOP=GNOME
UNICODEMAP_JP=cp932
DEFAULTS_PATH=/usr/share/gconf/default.default.path
LC_PAPER=en_US.UTF-8
XAUTHORITY=/run/user/1000/gdm/Xauthority
LC_ADDRESS=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
QT_STYLE_OVERRIDE=gtk
LC_NAME=en_US.UTF-8
GIO_LAUNCHED_DESKTOP_FILE_PID=13310
LC_MONETARY=en_US.UTF-8
XDG_SESSION_DESKTOP=default
GTK_MODULES=gail:atk-bridge
XDG_MENU_PREFIX=gnome-
XDG_SESSION_ID=1
QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
XDG_CONFIG_DIRS=/etc/xdg/xdg-default:/etc/xdg
DISPLAY=:1
LD_LIBRARY_PATH=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64
PWD=/home/dave
USER=dave
SHLVL=1
_=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/qcad-bin
MANDATORY_PATH=/usr/share/gconf/default.mandatory.path
LANG=en_US.UTF-8
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-S2ePMZG3dG,guid=e590a63ac7ca3b971f776cae58d663c0
GDMSESSION=default
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
SESSION_MANAGER=local/OPA:@/tmp/.ICE-unix/1681,unix/OPA:/tmp/.ICE-unix/1681
USERNAME=dave
PATH=/home/dave/bin:/home/dave/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin

 1646 QCAD/CAMBug ReportMedium 3.18 has a HATCH issue Closed
100%
Task Description

If you pres the “hatch icon” then the word “hatch” appears in the command window, but. . . nothing happens.

But if you type “hatch” followed by “enter” then finally the Hatch Window pops up.

 1820 QCAD/CAMBug ReportMedium CAM Export: exporting text entities broken Closed
100%
Task Description

Hi Andrew,

Kubuntu, QCAD/CAM 3.21.3

Font Standard. Selected as ‘single line’ font for engraving with mill or laser.

While CAM Exporting as G-code Laser (Offset) MM, or as Linux CNC, Exporting gets trapped in a loop.

In Font Standard the glyph’s ? & $ @ s S Q and 2 contains unwanted Z-movements. It seems these glyphs entities are not alligned properly; endpoint last line does not meet startpoint next line; why else the Z-movements?

Could this misallignment also traps Exporting?

 1848 QCAD/CAMFeature RequestMedium PWM Laser Closed
100%
Task Description

Hi Andrew,

I have added a PWM Laser post processor.

You can add it to QCAD’s post processor directory

 958 QCAD/CAMBug ReportLow CAM Export: points not exported Closed
100%
Task Description

Points are not being exported.

 961 QCAD/CAMBug ReportLow transactionlistener.so plugin gets installed to the wro ...Closed
100%
Task Description

When compiling QCAD 3.4.2.0 on Linux, the transactionlistener plugin gets installed to the wrong folder. The attached patch provides the correct directory path that trasactionlistener.so file gets installed too.

 1003 QCAD/CAMFeature RequestLow QCAD Community Edition: add unicode support for layer n ...Closed
100%
Task Description

Community version (still on FBSD only), so dxflib. I suspect the culprit is dxflib.

I have created layers and blocks and whatnot with (hungarian) accented characters in their names.
Apparently (according to the Internet, as evidenced probably most glaringly by usa.autodesk.com /adsk/servlet/ps/dl/item?siteID=123112&id=7586582&linkID=9240617) the R15 DXF version assumes single-byte character sets being used. Quick grepping the DXF2000 mentions “String (255-character maximum; less for Unicode strings)” (Group Code Value types), so it may be a false track...

Anyway, the DXF file written does have strings converted to single-byte encoding, but it seems it’s always ANSI-1252. When the output encoder encounters a character that is not representable in this one, it will use a literal question mark.

Actual case, I have a block with the name

106 egypólusú váltókapcsoló jelzőfénnyel

Of this, “ő” (U+0151) is not representable in ANSI-1252, so what gets written to the dxf is (non-ASCII shown in hex)

106 egyp<f3>lus<fa> v<e1>lt<f3>kapcsol<f3> jelz?f<e9>nnyel

Note the literal question mark.

Now the problem is this is an irreversible operation but the result is perfectly valid ANSI-1252, so upon opening the file again, I will get a block named

106 egypólusú váltókapcsoló jelz?fénnyel

IMHO the ideal resolution is to

  1. Have a preference for the export code page (and use it, too, circumstances permitting)
  2. Iff this is not set (or set to a default “Use system locale to determine” or something), use a look-up table to take a good guess (like old QCAD2 qcadlib/src/engine/rs_system.cpp:QCString RS_System::localeToISO())
  3. If the output encoder encounters a character that is not representable in the target code page, throw an error with an option to ignore the error (and keep using question marks, but then this must have been acknowledged by the user so not silent problem anymore), pick a new output code page, whatever else

This all assuming the R15 doesn’t actually depends hardly on ANSI-1252 and ANSI-1252 only. In that case, option #3 would still be nice.

Most Western European languages (and English) are not affected by this as ANSI-1252 has most of them covered, but a little to the east, a little to the south, a little to the north, and it does make a bit of a difference :)

 1013 QCAD/CAMBug ReportLow Option icon goes huge Closed
100%
Task Description

I moved all my tools bars to the side of the screen (vertical). only options was at the top. next restart it went HUGE.
it would only revert after putting another toolbar back (horizontal) and restarting qcad.

 1037 QCAD/CAMBug ReportLow great number of text editing operation leads to QCAD cr ...Closed
100%
Task Description

Hello!

When I’m trying to make a great number of text editing operation the QCAD 3.4.6 application crashes with following errors:

lman@lman:~/opt/qcad-3.4.6-linux-x86_32$ ./qcad
Debug: RCamScriptsPlugin: init
Debug: RDwgPlugin::init: trial
Debug: RDxfPlugin::init
Debug: RHelpPlugin::init
Debug: RProScriptsPlugin::init
Debug: TIMER: 56 ms - “loading add-ons”
Debug: TIMER: 672 ms - “initializing add-ons”
Debug: checking for updates...
Warning: QSslSocket: cannot resolve SSLv2_client_method
Warning: QSslSocket: cannot resolve SSLv2_server_method
Debug: no updates available
Debug: checking for updates...
Debug: no updates available
Warning: RHatchData::getPainterPaths: cannot load hatch pattern: “”
Warning: RHatchData::getPainterPaths: cannot load hatch pattern: “”
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Could not allocate register file: 12
./qcad: line 18: 7332 Segmentation fault LD_LIBRARY_PATH=”$DIR” “$binary” -style plastique “$@”

OS: Linux Debian 7.0.1 (”uname -a” return: SMP Debian 3.13.7-1 (2014-03-25) i686 GNU/Linux)
Thanks.

 1055 QCAD/CAMBug ReportLow code page problem Closed
100%
Task Description

After creating the labels in drawing in Russian (Cyrillic), after saving and reopening the drawing file - changing the text encoding (??????????). Need to re-type the text ... How to fix this error?

 1089 QCAD/CAMBug ReportLow Convert polyline from segments on locked layers deletes ...Closed
100%
1 Task Description

If you select (line) segments in a visible yet locked layer and choose “convert segments to polyline” (OG), the segments are deleted, but inserting the polyline fails.
So you can easily destroy locked layers by mistake which contradicts the idea of locking layers.

 1097 QCAD/CAMBug ReportLow uncaught exception: /LibraryBrowser.js:362 Closed
100%
Task Description

$ git status
On branch master
Your branch is up-to-date with ‘origin/master’.

$ qcad
Debug: RDxfPlugin::init
Debug: RExamplePlugin::init
Debug: TransactionListenerPlugin::init
Debug: TIMER: 59 ms - “loading add-ons”
Warning: “QFormBuilder was unable to create a custom widget of the class ‘QWebView’; defaulting to base class ‘QWidget’.”
Debug: TIMER: 602 ms - “initializing add-ons”
Warning: Script Exception:
“TypeError: Result of expression ‘tagsBrowser.page’ [undefined] is not a function.”
Warning: “<anonymous>()@/home/mo/opt/qcad/scripts/Widgets/LibraryBrowser/LibraryBrowser.js:362”
Warning: RScriptHandlerEcma::eval: script engine exception: “TypeError: Result of expression ‘tagsBrowser.page’ [undefined] is not a function.”
Warning: “<anonymous>()@/home/mo/opt/qcad/scripts/Widgets/LibraryBrowser/LibraryBrowser.js:362”
Warning: At least one uncaught exception:
Warning: “<anonymous>()@/home/mo/opt/qcad/scripts/Widgets/LibraryBrowser/LibraryBrowser.js:362”

I have some large library, but the library browser is always crashing since long time and several versions, also tagged versions. I need to disable it by removing LibraryBrowser.js completely or deleting my configuration in order to get QCad starting again.
This is the master head from git, on Gentoo@amd64

 1122 QCAD/CAMBug ReportLow Objects move inappropriately when confirming alignment  ...Closed
100%
Task Description

I am trying to use the align tool (M, A) to align two text objects vertically. I am able to get them aligned how I want them, but when I confirm (click the green check box in the upper right-hand corner) they mysteriously jump up a large grid square or so. I am then able to get them back into the alignment by the “undo” command. In case that didn’t make sense I’ll try this one more time:

{Result} (User Action)

{text boxes out of alignment}(Align tool “M,A”){text boxes aligned}(click green checkmark){text boxes move randomly}(undo “ctrl-z”){text boxes aligned}

I’m thinking this is either operator error or a bug. It is consistent though.

 1134 QCAD/CAMBug ReportLow CAM Export: cut inner paths before outer paths broken Closed
100%
Task Description

This option seems to only work with the script debugger enabled.
See:
http://www.qcad.org/rsforum/viewtopic.php?f=33&t=3091

 1142 QCAD/CAMFeature RequestLow Distance Entry in "Feet and Inches" Closed
100%
1 Task Description

I use architectural units everyday in QCAD and would appreciate being able to enter feet and inches from the “command line” for convenience and accuracy.

I have been entering “calculations” to arrive at the distance values (i.e. 10*12+6.125 = 10’-6 1/8”), but this method is time consuming and prone to input error.

I would like to see Acad’s architectural distance method implemented in QCAD. This entry method would replace the “calculated” entry with (as an example): 10’6-1/8.

Command Line: Next point: 10’6-1/8
The <’> mark triggers a 12 times multiplier for the proceeding number,
the next number is the whole inches and
the ↔ is a separator that adds the fraction to the whole inches before it.

Thanks for considering this feature request. I’m certain that many QCAD users in the Architectural, Mechanical, Electrical and Construction professions wold appreciate this convenience (especially those moving past Acad).

 1183 QCAD/CAMBug ReportLow Info arc area specified on drawing is not the same as s ...Closed
100%
Task Description

Info arc area specified on drawing is no where near the same as shown in properties editor.

 1194 QCAD/CAMBug ReportLow Rounding fourth corner of rectangle causes rectangle to ...Closed
100%
Task Description

When rounding the fourth corner of a rectangle, with trim checked or unchecked, instead of the corner being trimmed to a radius, the rectangle itself disappears leaving only the corner with the rounded off portion intact.

 1197 QCAD/CAMBug ReportLow Small Polyline offset with 'round join' makes line segm ...Closed
100%
Task Description

When making an offset of a polyline with ‘round join’ enabled, and making a small offset of 0.0015 inches, no arcs are made, only coarsely interpolated line segments.
Further tests show that this is true until the offset is increased 0.040 inches; then the offset begins to create arcs.

The creation of arcs in a polyline offset with such small distances did work in QCAD 2.x.

 1240 QCAD/CAMBug ReportLow USB Flas Drive save makes the drive Read Only Closed
100%
Task Description

This problem is USB Flash drive related.

First of all, QCAD does not show the flash drive a drive where data can be stored, but it does when one wants to open a file.

If one then did open a file from the flash drive, saving it back tot he flash drive change the permission of the entire drive to read only and I could not manage to change that other than formatting the drive.

 1398 QCAD/CAMBug ReportLow Duplicate zoom buttons in toolbar and menu Closed
100%
Task Description

I am seeing duplicate zoom buttons in the View toolbar, and also under the View menu. Under Application Preferences→General→Tool Settings there are also multiple entries for these, with Shortcuts and Commands highlighted in red (means there are conflicts?). This is the QCAD/CAM version on Linux 32-bit Debian “testing” release. I also tried the same version on Windows 7 64-bit and am not seeing this issue. Screen shots attached.

 1418 QCAD/CAMFeature RequestLow Layerlist and hidden sublayer Closed
100%
Task Description

The layerlist shows at any operation all sublayer, even if they were previously hidden!

 1467 QCAD/CAMBug ReportLow Short leader will not render the arrow Closed
100%
Task Description

Hi,

I tried to add a leader and for some reason the arrow does not appear. I found out that this occurs when the line is short. To me, line is sufficiently long enough but somehow QCAD thinks it is too short.

Screenshot shows added leader.

Also when I try to change arrow: no to “yes”, while the dropdown shows yes, I am not able to select it. It just defaults to no.

Workaround:
Draw longer line.

 1483 QCAD/CAMBug ReportLow Draw -> Polyline -> Create from Segments deletes a segm ...Closed
100%
1 Task Description

With the attached DXF file, select Draw → Polyline → Create from Segments
(O, G) and click on the complex polyline inside the circle (eg on
the top left arc). Apolyline is created with a few segments,
and one or more segments are deleted!

Different segments are deleted depending on which segment is clicked.

 1512 QCAD/CAMBug ReportLow CTR command is not working Closed
100%
Task Description

1) Tool Circle WC
2) CTR circletangent2radius

This doesn’t work between two circles !
I can make a circle that touches a line and a circle.
But I can NOT make a third circle with a given radius that touches two other circles.

All the other commands in this menu are working properly, can someone help me out ?

 1538 QCAD/CAMBug ReportLow CAM not use the shortest way Closed
100%
Task Description

ich habe ein Linien Gitter in QCAD erstellt und dann mit CAM Export eine NC Datei erstellt.
Im CAM Simulator sieht man dass der GCODE Postprozessor nicht den kürzesten Weg verwendet.
Anbei folgende Dateien :
CAM_TEST_LINIEN.dxf, CAM_TEST_LINIEN.nc, CAM_TEST_LINIEN.log und eine Bilddatei CAM_TEST_LINIEN.png hier kann man sehen wie die Eistellungen für die GCODE Erstellung sind.

 1585 QCAD/CAMBug ReportLow hide/show layer delay Closed
100%
Task Description

Hi !
i’m trying the new qcad/cam 3.17.1 and i have a delay when i hide and show a layer..
(linux MINT 17.2 x64)

The function is working, but the layer will hide (and show) with a delay from click on the apposite button.

The qcad 3.16.7 DON’T have this problem.. when you click on button immediately the layer disappear/show..

 1593 QCAD/CAMBug ReportLow CAM > CAM Export: ZH in header always yields default va ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=74&t=4914

 1610 QCAD/CAMPerformance IssueLow Switching from one drawing to another slow Closed
100%
Task Description

When switching from one drawing to another, the 3D view is updated which can be slow, especially for drawings with many text entities.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=89&t=4945

Showing tasks 1751 - 1800 of 1848 Page 36 of 37<<First - 33 - 34 - 35 - 36 - 37 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing