QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatusProgress
 178 QCAD (main)Bug ReportMedium add layer from property editor got uncaught exception Closed
100%
Task Description
  1. new drawing
  2. draw line
  3. select it
  4. choose “+” in property editor to add a new layer → the layer dialog pops up
  5. press cancel
  6. move the mouse back into the drawing area
Uncaught exception at /home/martin/workspace/rsframework/scripts/Widgets/PropertyEditor/PropertyEditor.js:197: TypeError: Result of expression 'layer' [undefined] is not an object.
197	        pw.propertyChanged(layer.getName());
 
qsdb> .backtrace
#0  <anonymous>(false) at /home/martin/workspace/rsframework/scripts/Widgets/PropertyEditor/PropertyEditor.js:197
#1  <native>() at -1
#2  main() at scripts/autostart.js:501
#3  <global>() at scripts/autostart.js:520
 175 QCAD (main)Bug ReportMedium Trim.js: uncaught exception for ellipse / ellipse arcs Closed
100%
Task Description
  1. draw line as limiting entity
  2. draw ellipse and ellipse arc, both intersecting
  3. modify → trim
  4. select the diagonal line as limiting entity
  5. move around with the mouse over ellipse or ellipse arc → crash
Uncaught exception at scripts/Modify/Trim/Trim.js:267: TypeError: Result of expression
'trimmed1.trimStartPoint' [undefined] is not a function.
267	        trimmed1.trimStartPoint(is);
qsdb> .backtrace
#0  <anonymous>(op = RMixedOperation(0xc37b998), limitingEntity = RLineEntityPointer(0xc20c098),
limitingShape = RLine(RShape(address: "0xc217bd8"), startPoint: RVector(40, 36, 0) ,
endPoint:  RVector(-3, -3, 0) ) , limitingPos = RVector(2.81463, 1.47073, 0) ,
trimEntity = REllipseEntityPointer(0xc3775f8), trimPos = RVector(12.4488, 5.03537, 0) ,
trimBoth = false, preview = true) at scripts/Modify/Trim/Trim.js:267
#1  <anonymous>(preview = true) at scripts/Modify/Trim/Trim.js:167
#2  <anonymous>() at /home/martin/workspace/rsframework/scripts/Modify/../EAction.js:1150
#3  <anonymous>(event = REntityPickEvent(0xbfffd3c8), preview = true) at scripts/Modify/Trim/Trim.js:147
#4  <anonymous>(event = REntityPickEvent(0xbfffd3c8)) at /home/martin/workspace/rsframework/scripts/Modify/../EAction.js:1225
#5  <global>() at -1
 172 QCAD (main)Feature RequestMedium send to back / to front Closed
100%
Task Description

implement

 171 QCAD (main)Bug ReportMedium arc split wrong Closed
100%
Task Description
  • see attachment
 170 QCAD (main)Bug ReportMedium wrong scaling for ellipses / ellipse arcs Closed
100%
Task Description
  • see attachment
  • factor x/y: 0.5
  • green: original entities
  • red: properly scaled entities
 160 ECMAScriptBug ReportMedium SplitIntoEqualParts.js: Uncaught exception Closed
100%
Task Description
    for (var i = 0; i < this.parts; ++i) {
        var p1 = startPoint.operator_add(off.operator_multiply(i));
        var p2 = p1.operator_add(off);
        var line = new RLineEntity(doc, new RLineData(p1, p2));
=>      line.copyAttributesFrom(argLine);
        op.addObject(line, false);
Uncaught exception at scripts/Modify/SplitIntoEqualParts/SplitIntoEqualParts.js:174: Error: :-1:-1: REntity: Argument 0 is not of type REntity *REntity *.
<native>(RLineEntityPointer(0xb73b4c8)) at -1
<anonymous>(op = RAddObjectsOperation(0xb733790), argLine = RLineEntityPointer(0xb73b4c8)) at scripts/Modify/SplitIntoEqualParts/SplitIntoEqualParts.js:174
<anonymous>(op = RAddObjectsOperation(0xb733790)) at scripts/Modify/SplitIntoEqualParts/SplitIntoEqualParts.js:111
<anonymous>(true) at scripts/Modify/SplitIntoEqualParts/SplitIntoEqualParts.js:95
<anonymous>() at /home/martin/workspace/rsframework/scripts/Modify/../EAction.js:1150
<anonymous>() at scripts/Modify/SplitIntoEqualParts/SplitIntoEqualParts.js:73
<global>() at -1
174	        line.copyAttributesFrom(argLine);

qsdb> argLine
RLineEntityPointer(0xb73b4c8)
 158 QCAD (main)Bug ReportMedium polyline with segment radius mirrored wrong Closed
100%
Task Description
  • see attached drawing
 157 QCAD (main)Bug ReportMedium rotate causes uncaught exception Closed
100%
Task Description
  1. draw line
  2. Modify → Rotate
    • center point: line end point
    • delete original
    • angle 90°
Uncaught exception at scripts/Modify/Rotate/Rotate.js:117: Error: :-1:-1: Wrong number/types of arguments
for RDocumentInterface.applyOperation().
<native>(undefined) at -1
<anonymous>(event = RCoordinateEvent(0xbfffd478), preview = false) at scripts/Modify/Rotate/Rotate.js:117
<anonymous>(event = RCoordinateEvent(0xbfffd478)) at
/home/martin/workspace/rsframework/scripts/Modify/../EAction.js:1197
<global>() at -1
117	                di.applyOperation(this.getOperation(false));
 156 QCAD (main)Bug ReportMedium Isometric Projection fails for arc Closed
100%
Task Description
Uncaught exception at scripts/Modify/IsoProject/IsoProject.js:166:
TypeError: Result of expression 'shape.approximateWithLines' [undefined] is not a function.
166	        var pl = shape.approximateWithLines(this.segmentLength);
qsdb> shape
RArc(RShape(address: "0xc436c88"), center: RVector(11, 8, 0) , radius:  6.08276 , startAngle:  0 ,
endAngle:  6.28319 , startPoint:  RVector(17.0828, 8, 0) , endPoint:  RVector(17.0828, 8, 0) ,
reversed:  false )
 148 QCAD (main)Bug ReportMedium "inline" leads to linking error on Linux Closed
100%
Task Description

RPainterPath.h

    inline bool isEmpty() const;
g++ -rdynamic -Wl,-rpath,/home/martin/opt/QtSDK/Desktop/Qt/473/gcc/lib
-o ../../debug/qcad-bin debug/main.o
   -L/home/martin/opt/QtSDK/Desktop/Qt/473/gcc/lib
-L/usr/X11R6/lib -L/home/martin/workspace/rsframework/debug
-L/home/martin/workspace/rsframework/debug/opendesign
 -lecma -lecmaapi -ldwg -lpluginsqt -lgui -lentity -loperations -lspatialindexnavel
 -lgrid -lsnap -lcore -lstemmer -lmath -lrxslt -lrxml -ldxf -lModelerGeometry
 -lTD_BrepRenderer -lTD_Br -lTD_AcisBuilder -lTD_Db -lTD_DbRoot -lTD_Gs
 -lTD_SpatialIndex -lTD_Gi -lTD_Ge -lTD_Root -lFreeType -lTD_Alloc -lRecomputeDimBlock
 -lExFieldEvaluator -lQtWebKit -lQtScript -lQtScriptTools -lQtSvg -lQtSql -lQtXmlPatterns
 -lQtXml -lQtOpenGL -lQtGui -lQtNetwork -lQtCore -lGLU -lGL -lpthread 
/home/martin/workspace/rsframework/debug/libecmaapi.a(REcmaPainterPath.o): In function `REcmaPainterPath::isEmpty(QScriptContext*, QScriptEngine*)':
/home/martin/workspace/rsframework/src/scripting/ecmaapi/REcmaPainterPath.cpp:2078: undefined reference to `RPainterPath::isEmpty() const'
/home/martin/workspace/rsframework/debug/libgui.a(RGraphicsSceneQt.o): In function `RGraphicsSceneQt::endPath()':
/home/martin/workspace/rsframework/src/gui/RGraphicsSceneQt.cpp:71: undefined reference to `RPainterPath::isEmpty() const'
/home/martin/workspace/rsframework/src/gui/RGraphicsSceneQt.cpp:74: undefined reference to `RPainterPath::isEmpty() const'
/home/martin/workspace/rsframework/debug/libentity.a(RHatchData.o): In function `RHatchData::getBoundingBox() const':
/home/martin/workspace/rsframework/src/entity/RHatchData.cpp:104: undefined reference to `RPainterPath::isEmpty() const'
/home/martin/workspace/rsframework/debug/libentity.a(RHatchData.o): In function `RHatchData::getDistanceTo(RVector const&, bool, double, bool) const':
/home/martin/workspace/rsframework/src/entity/RHatchData.cpp:127: undefined reference to `RPainterPath::isEmpty() const'
/home/martin/workspace/rsframework/debug/libentity.a(RHatchData.o):/home/martin/workspace/rsframework/src/entity/RHatchData.cpp:134: more undefined references to `RPainterPath::isEmpty() const' follow
collect2: ld returned 1 exit status

temporary solution: changed method to non-line

 144 QCAD (main)Bug ReportMedium snap restriction buttons are not toggled Closed
100%
Task Description

the buttons works, but are not toggled (”restriction off” is always pushed)

 87 QCAD (main)Bug ReportMedium Advanced Selection hits 'debugger' statement Closed
100%
Task Description

Advanced selection dialog hits a debugger statement on line 1088.

  1. Selection- Advanced Selection
  2. Change first combo box to “Any”
 77 QCAD (main)Bug ReportMedium Linux: Printing crashes Closed
100%
Task Description

Printing segfaults under Linux after the printer dialog is shown.

 73 QCAD (main)Bug ReportMedium Uncaught exception: "cannot access member of deleted QO ...Closed
100%
Task Description

occurs sporadically, often when the application or a MDI child is closed, usually not reproducible.

  • 2011-05-11 15.19:32 unsaved drawing, after choosing “no” at the confirmation dialog
Uncaught exception at /home/martin/workspace/rsframework/scripts/Tools/PainterPathViewer/../../library.js:50:
Error: cannot access member `isNull' of deleted QObject
50	            (typeof(obj.isNull)=="function" && obj.isNull()===true));
 68 QCAD (main)Bug ReportMedium insert from library browser crashes Closed
100%
Task Description
  1. new file
  2. insert (drag-n-drop or insert button) from library browser → segfault
Thread [1] 12403 (Suspended : Signal : SIGSEGV:Segmentation fault)	
	RObject::getId() at RObject.h:92 0x8a11c82	
	RClipboardOperation::copy() at RClipboardOperation.cpp:66 0x8d4892a	
	RPasteOperation::apply() at RPasteOperation.cpp:30 0x8d4841a	
	RDocumentInterface::previewOperation() at RDocumentInterface.cpp:1,766 0x8de19bb	
	REcmaDocumentInterface::previewOperation() at REcmaDocumentInterface.cpp:4,711 0x889aaad	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xa83ced9f	
	0xb6a423e3	
	<...more frames...>	
 61 DocumentationBug ReportMedium QCAD 3 Manual Closed
100%
Task Description

Change the user manual directory / file names from ‘simpletextviewer’ to
‘qcad_user_manual’ and adjust the sources accordingly that the manual can be shown
in the help menu.

We can simply drop the contents of the manual that is checked in and replace
it with a simple note “No manual is available yet for this technology preview of QCAD 3”

 45 QCAD (main)Bug ReportMedium Hatch Polyline Closed
100%
Task Description
  1. open the attached drawing
  2. select the polyline
  3. fill it with hatch pattern “stars” → looks ok, the whole area is filled
  4. save the file
  5. re-open it
  6. there is a gap in the filling now, see attached screen shot
 43 QCAD (main)Bug ReportMedium Hatch ellipse Closed
100%
Task Description

cannot hatch single full ellipse

 41 QCAD (main)Bug ReportMedium dimensions: tolerance shown twice after block insert Closed
100%
Task Description
  • File “ExampleDrawings/data/dim_aligned.dwg”:
    • upper limit: 0.01, lower limit 0.02 → correctly shown
  • choose “Generate Example Drawings” → the element “aligned dimension” (with limits set) shows 0.010.01 now, since both label and tolerance limits are set (according to the property editor):
    • label: <>\S0.01^0.02;
    • upper limit: 0.01
  • same for lower limit
  • “Generate Example Drawings” inserts the drawings as blocks
 40 QCAD (main)Bug ReportMedium saving spline CP, 2deg, closed hits assert Closed
100%
Task Description
  1. new file
  2. draw spline CP, 2deg, closed
  3. save → crash
Debug:    "RDwgServices::printErrorStackTrace: General modeling failure" 
Warning:  RDwgExporter::exportEntity: Exception occured. Entity NOT saved: 
 RSplineEntity(REntity(RObject(id: 23, document: "0xb246720", address: "0xb915f00", undone: 0), type: 23, layerId: 21, blockId: 22, lineweight: -1, linetypeId: 0, color: RColor(ByLayer) , drawOrder:  0 , selectionStatus:  false ) 
controlPoints (6): 0: RVector(14, 21, 0) 1: RVector(41, 25, 0) 2: RVector(41, 9, 0) 3: RVector(28, 4, 0) 4: RVector(14, 21, 0) 5: RVector(41, 25, 0) 
fitPoints (0): 
knots (7): 0: -1, 1: 0, 2: 1, 3: 2, 4: 3, 5: 4, 6: 5, )
Fatal:    ASSERT: "false" in file RDwgExporter.cpp, line 1234
Thread [1] 2066 (Suspended : Signal : SIGABRT:Aborted)	
	__kernel_vsyscall() at 0xffffe424	
	raise() at 0xb4f037ff	
	abort() at 0xb4f05140	
	RMainWindow::messageHandler() at RMainWindow.cpp:63 0x8e025a6	
	qt_message_output() at 0xb5357f65	
	0xb53581ab	
	qFatal() at 0xb53582c9	
	qt_assert() at 0xb5358355	
	RDwgExporter::exportEntity() at RDwgExporter.cpp:1,234 0x8cb754f	
	RExporter::exportEntities() at RExporter.cpp:408 0x8de5c96	
	<...more frames...>	
 37 QCAD (main)Feature RequestMedium Generate Example Drawings Closed
100%
Task Description
  • a script would be great actually. then we can generate different drawings with different units / scales / paper settings
  • OdWriteEx from OpenDesign creates something similar: a bunch of rectangles, each with a text label and an entity inside, e.g. “Aligned Dimension” and below a rectangle with an aligned dimension inside
  • the example drawings should contain:
    • an instance of every supported entity type (line, arc, circle, all dimensions, block insert, text, hatch, solid fill, ...)
    • lines in all available widths
    • lines in all available types
    • lines in all available (fixed) colors and some custom colors
  • script should be able to generate example drawings for different:
    • units
    • drawing scales
    • paper sizes
    • paper settings (background color, multi page settings, etc.)
 31 QCAD (main)Bug ReportMedium Snap Coordinate / option toolbar: uncaught exception Closed
100%
Task Description
  • draw → line → snap coordinate
  • draw → line → snap polar coordinate
Uncaught exception at scripts/Snap/Coordinate/Coordinate.js:58: TypeError: Result of expression 'setButton' [undefined] is not an object.
58	    setButton.text = qsTr("Set");

problem: the option tool bar isn’t show at all

 25 QCAD (main)Feature RequestMedium Autosave Closed
100%
Task Description

Autosave

Make interval configurable
Enable / disable
Path (?)

 20 QCAD (main)Bug ReportMedium Changing drawing unit makes QCAD hangs Closed
100%
Task Description

Changing the unit of a drawing can make QCAD hangs

  • Mile: QCAD hangs in endless loop
  • Nanometer, Microinch: view turns white, at some levels of zoom, it turns gray
  • Foot, Yard: GraphicsView grid too small meshed
 14 QCAD (main)Feature RequestMedium File: Print Preview Closed
100%
Task Description

Open

  • re-enable auto fit
  • re-enable center

Postponed

  • option to not print empty pages

Done

  • PDF export
  • scale factor
  • position
  • paper size
  • paper orientation
  • toggle portrait / landscape in toolbar
  • choose paper format in toolbar
  • multiple pages with margin and stitch marks
  • zoom to all pages
  • color mode (color, gray scale, black white)
  • scale combo box in drawing preferences empty
 8 QCAD (main)Bug ReportMedium Text Dialog: custom text height broken Closed
100%
Task Description

Custom text height cannot be set (enter closes the dialog, tab does not activate the entered text height)

 6 QCAD (main)Performance IssueMedium Auto snap near splines Closed
100%
Task Description

Move cursor near spline, e.g. when drawing line with auto snap active.

 5 QCAD (main)Bug ReportMedium print preview: paper disappears on focus out / in Closed
100%
Task Description

when changing the window focus, the paper in the print preview disappears and doesn’t come back anymore

 4 BookBug ReportMedium Book "CAD Instruction" layout issues Closed
100%
1 Task Description

Post all kind of layout issues for the book “CAD Instruction” here, e.g. overlapping text.

 1783 QCAD (main)Bug ReportLow RArc::splitAt(): fails in some cases Closed
100%
Task Description

RArc::splitAt() works wrong in some cases.
To reproduce execute this script:

            var arc = new RArc(new RVector(0, 0), 100, Math.PI*2, Math.PI/2, true);
            var points = [];
            points.push(arc.getPointAtPercent(1/3));
            var arcs = arc.splitAt(points);
            if (arcs.length == 2) {
                qDebug("OK, arcs count:", arcs.length);
            } else {
                qDebug("FAILED, arcs count:", arcs.length);
            }

            arc.mirror(new RLine(0, 0, 0, 100));

            points = [];
            points.push(arc.getPointAtPercent(1/3));
            arcs = arc.splitAt(points);
            if (arcs.length == 2) {
                qDebug("OK, arcs count:", arcs.length);
            } else {
                qDebug("FAILED, arcs count:", arcs.length);
            }

The first case split in two arcs, but the second splits in one arc only.

I think the reason is the code in RArc::splitAt():

        ...
        if (RMath::getAngleDifference180(a1, a2))*radius()<0.001) {
            continue;
        }
        ...

The RMath::getAngleDifference180() return angle between -pi and pi so absolute value should be used.

 1782 QCAD (main)Bug ReportLow Successive middle mouse button zoom in/out: delay betwe ...Closed
100%
Task Description

I very much like the new middle mouse button zoom in/out and congratulate Andrew for implementing it so quickly but there’s an annoying delay that is necessary between successive zoom in/out actions. This is easily understood by comparing it to zooming in/out with the +/- keys. With the keyboard you can repeat zooms as quickly as the keyboard repeat rate allows; with the middle mouse button quick zooms are not possible.

 1780 QCAD (main)Bug ReportLow QCad quits when you double-click a text Closed
100%
Task Description

QCad quits when you double-click a text; What’s wrong, QCad or file?

 1779 QCAD (main)Feature RequestLow Layer list, block list, etc: add support for internatio ...Closed
100%
Task Description

The attached screenshot will make clear what the problem is:
“échelle” should be between “cotes” and “platines”, not at the bottom. “e” and “é” must be considered the same letter when ordering alphabetically.

 1776 QCAD (main)Bug ReportLow Edit > Application Preferences: Tool Settings: cannot c ...Closed
100%
Task Description

Multikey shortcuts are broken in Qt.
QCAD needs its own implementation of shortcut handling which also affects shortcut configuration.

 1775 QCAD (main)Bug ReportLow Viewports: images sometimes not clipped at viewport edg ...Closed
100%
Task Description

See also:
https://qcad.org/rsforum/viewtopic.php?f=89&t=5657

1772QCAD (main)Feature RequestLowGo back on right-click on shaded Tool buttonAssigned
0%
Task Description

Right-click on the tools on the left-hand side of the screen brings you back in the hierarchy.

However, that does not work if you right-click while hovering above a button that that is shaded (inactive).

 1770 WebsiteBug ReportLow qcad.org shop language Closed
100%
Task Description

FR - Ok,
DE - Ok,

EN - not OK. Main text is in english, menu is in german.

 1769 QCAD (main)Bug ReportLow QCAD Help link to "FAQ's (Online) is broken Closed
100%
Task Description

QCAD 3.20.1.3 help link to “FAQ‘s (Online)” is broken and leads to a 404 page.
(Menu → Help → FAQ‘s (Online))

 1768 QCAD (main)Bug ReportLow Draw > Polyline > Create From Segments: segments delete ...Closed
100%
1 Task Description

‘Create From Segments’ ‘OG’ includes and admits selection of segments on locked layers.

A)
-When selecting a segment on a not locked layer it can include segments on locked layers that connect to the string. (Assumed wrong)
-A copy of the segments on the locked layer(s) are included in the polyline. (Assumed wrong)
These segments are not removed from the locked layer(s) because of their locked nature. (Intended behaviour)
eg. ‘OG’ & selecting the arc at point A in the example file. The arc is on a not locked layer.

B)
-When selecting a segment on a locked layer it will fully remove segments that connect to the string on not locked layers. (Assumed very wrong)
-Connecting segments on the locked layer(s) will not be converted to a polyline because of their locked nature. (Intended behaviour)
eg. ‘OG’ & selecting the line at point B in the example file. The cyan lines are on a locked Layer.

Both A & B can be undone.

The example is a part of the ‘Skewing project’.

Regards
CVH

 1766 QCAD (main)Bug ReportLow Edit > Application Preferences: Tool Settings: cannot a ...Closed
100%
Task Description

I wanted to add a couple of toolbars to the Tool matrix via the Tool Settings application preferences but all options are greyed out (see attached screenshot). I tried with a new config file and the result is the same. Is this the expected behaviour?

 1764 QCAD (main)Feature RequestLow Zoom in with middle click Closed
100%
1 Task Description

I would suggest adding a feature Inkscape has, which is that a single middle click zooms in. This is not at the detriment of panning, since the mouse/pen (I use a Wacom tablet) doesn’t move. Right now middle click doesn’t do anything so I don’t think it should be a problem.

Another awesome and related Inkscape zooming feature is that Shift+middle click shifts to window zooming. But with the added bonus that you don’t lose the tool you’re in. Try it out on Inkscape if I’m not clear!

Cheers,
JFL

 1763 QCAD (main)Feature RequestLow Simple Modify Move function Closed
100%
Task Description

Moving things require an extra click on ‘Delete original’ and a click on ‘OK’

A simple Modify Move functionality will reduce mouseclicks for moving by 2 for every move that is made.

Regards

 1761 QCAD (main)Bug ReportLow Info Polyline area does not find polylines (II) Closed
100%
Task Description

Selecting Info // Polyline area
And hovering over a drawing with all kinds of entities.
Does not find any polyline on the drawing hovering over them.
Nor clicking on them.

Not a locked layer issue.
All are visible.

 1757 QCAD (main)Bug ReportLow Modify > Auto Trim: on polyline, followed by undo yield ...Closed
100%
Task Description

Breaking up self-intersecting Polys at segments crossing
can’t be done for the second segment.

Divide:
A new node is inserted and made start and end node.
For the second segment no division occurs or can be made.
Expected is that the segment the nearest to the selecting point is addressed.
Eg. the trim command.

Breakout gap:
- 1 Part fully trimmend of
- Can be undone

Auto trim:
(hint: do file-save first to revert)
- 1 Part fully trimmend of
- Undo will wipe the complete poly

In the file example 1.

Work-arround:
- Divide
- Insert node on the second segment not at the crossing
- Divide at that node
- Move new nodes to crossing

QCAD 3.20.1 Win7 32bit
Kind Regards

 1756 QCAD (main)Bug ReportLow Polyline area wrong if polyline contains arc segments Closed
100%
Task Description

The area of polylines with arcs can be incorrect.
With only line segments it is correct as far as I can check.
See <Poly-line Area.dxf> ; <Poly-arc Area.dxf>

It does not depend on the quadrant their in nor with what point the start point is.
It is related with the oriëntation.
Flipping or mirroring horizontally induce the error.

Modifications like flip, move & copy may induce another error that locks the oriëntation.
It is noticed that the oriëntation property in the editor does not change anymore when reversing.
Although locked the value of the area property switches between good and wrong.

The master poly in question is a part of an arc and a part of an ellipse exploded 1024/full.
These where recombined to one poly with ‘Create from selection’ and are closed.
Closed as per the last vertex does not point to the start point, logically closed I presume.
The purpose is to sum the error surface for the skewing math.
For now I will use my common sence to distinguish what value is the correct one.
Reversing while found faulty is the solution.

Version: 3.20.1.0 (3.20.1)
Internet: QCAD.org
Build Date: Apr 13 2018
Revision: dd51609
Qt Version: 5.5.1
Architecture: i386
Compiler: MSVC++ 10.0 (2010)
Win7 32bit

Regards

1755QCAD (main)Feature RequestLowSelecting standard rotation angles by mouse click for M...Assigned
0%
1 Task Description

This would be nice.
It will save a lot mouse - keypad changes for me.

1754QCAD (main)SuggestionLowWhen Selecting multiple blocks that contain the same at...Assigned
0%
Task Description

When selecting multiple blocks that contain the same attribute names, attribute properties appear with the values of the last selected block instead of “various”. I do not know if this is a “bug” or developer option, but “various” would be better in my opinion.

 1753 TranslationBug ReportLow View > Property Editor: entity types in property editor ...Closed
100%
Task Description

Translations in scripts/ts are not loaded (affects splash screen, property editor, default action, various standard messages, some context menus)

 1752 QCAD (main)Bug ReportLow Not selecting text with sub/superscript Closed
100%
Task Description

Found a strange behaviour with formatted text.

File attached.
‘Draw’-selecting only the yellow text with a little space arround it
- L>R or R>L ⇒ Yellow text not selected.

‘Draw’-selecting only the yellow text with a little space from R>L but crossing the text half way
- Yellow text Selected ⇒ Expected behaviour.

‘Draw’-selecting just including the mentioned little circles.
- Orange L>R or R>L ⇒ Normal texts selected ⇒ Expected behaviour
- Green L>R Yellow not R>L Yellow selected ⇒ Expected behaviour
- Magenta L>R or R>L ⇒ Yellow text not selected ??
- Red L>R or R>L ⇒ Yellow text not selected ??

Version: 3.20.1.0 (3.20.1)
Internet: QCAD.org
Build Date: Apr 13 2018
Revision: dd51609
Qt Version: 5.5.1
Architecture: i386
Compiler: MSVC++ 10.0 (2010)
Windows 7 32-bit

Kind Regards

1749QCAD (main)Feature RequestLowAdd support for non-uniform block scalingAssigned
0%
1 Task Description

Same txt as on the forum.
had a copy because i had to log in 3 times to remark my own post.

Blocks are no solution either.

see pdf
[attachment=0]Block test_1.pdf[/attachment]

Antartica is put in a block as segments.
Added a rounded corner as segments and as poly.
scaled X x0.5 Y x1 origin the center of the magenta circl.

The scaled version is all over the place.
Set them to color red, no use they stay black.

The reference of the block is 2000mm to the left because I tried it out far right of my design.
The cyan circle is about 400mm in diameter.

dxf part included
[attachment=1]Block test.dxf[/attachment]

Version: 3.20.1.0 (3.20.1)
Internet: QCAD.org
Build Date: Apr 13 2018
Revision: dd51609
Qt Version: 5.5.1
Architecture: i386
Compiler: MSVC++ 10.0 (2010)

CVH

Showing tasks 201 - 250 of 1783 Page 5 of 36<<First - 3 - 4 - 5 - 6 - 7 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing