QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

ID  descCategoryTask TypeSeveritySummaryStatusProgress
 1568 QCAD (main)Bug ReportLow Issues: Snaps, Trim, Green selection tool Closed
100%
Task Description

Hello,

There is some issues with the snap tool and the selection tool.The trim button only trims some lines but not all.

1. The snap tool does not let me snap to certain things when i select something. For example i will select a box and i will try to extend the corner to another entities corner but the snap is not there so its free and thus not accurate.

2. For some reason the selection tool does not allow me to select certain things. If i have two boxes overlapping and i use the selection tool (from right to left “green selection box”) it does not allow me to select what i want i have to actually click it. This is annoying when it comes to selecting specific things.

3. The trim tool does not work properly.If i want to trim the inside of a cross hair or such, it only allows me to trim the inside of one line and if i try to trim the other it deletes the complete line.

Please fix as soon as possible. Thanks

1567QCAD (main)Feature RequestLowAdd support for separate windowAssigned
0%
1 Task Description

Hi, for multi-screen hosts it would be very useful to have additional windows while running the single QCad instance. Other applications like Palemoon, Evolution, Gimp are providing that already.
That would help a lot when working on multiple files and copying blocks between.

 1566 QCAD (main)Bug ReportLow Block > Attributes > Synchronize Attributes: deleted bl ...Closed
100%
1 Task Description

Deleted (undone) block attributes are stored to DXF/DWG.

 1565 QCAD (main)Bug ReportLow Disappearing blocks. Closed
100%
Task Description

Blocks disappear (or their content does) after creating again with the same name. In attached file:

1) Created cirle
2) Select circle, BC, select center, name is ‘testblock’ 3) Repeat 2) – circle is now gone

 1564 QCAD/CAMBug ReportMedium QCAD/CAM: black main window or main window not painted  ...Closed
100%
Task Description

QCAD/CAM version 3.16.7.1 (snapshot release)

QCAD/CAM version 3.16.7.1 for Ubuntu Linux starts up with a totally black screen with only the title bar showing. By clicking around at the top of the screen I can get the menus to drop down and appear over the blank black screen. That is how I captured all the version information below. QCAD/CAM version: 3.15.5.0 for Ubuntu Linux starts with all the normal screen graphics appearing normally. I labeled this bug report as critical because QCAD/CAM is unusable on Ubuntu Linux, but for me it is not so critical since I can use the Windows version.

Versions
QCAD version: 3.16.7.1
Date: Mar 22 2017
Qt version: 5.8.0
Compiler version: gcc 4.8.1
Build Date: Mar 22 2017
Revision: 17a80fac27c3ae6aa68cd4ee15ffa4f3e2ab0a9a

Architecture: x86_64
OS: Linux
OS version: Unknown

Locale
QCAD locale: en
Name: en_US
Country: 225
Country name: United States
Language: 31
Language name: American English
Script: 7
Script name: Latin
Decimal point: 46
Negative sign: 45
Positive sign: 43
Text direction: 0
System codec: UTF-8

Arguments: /home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/qcad-bin

Plugins
Description=CAM tools.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadcamscripts.so
ID=CAM
License=Proprietary
Name=CAM
NamePostfix=/CAM
PurchaseURL=http://ribbonsoft.com/add-ons/qcadcam-purchase QtVersion=5.8.0
SplashOverride=:/scripts/Cam/splashscreen.png
SplashOverride@2x=:/scripts/Cam/splashscreen@2x.png
URL=http://ribbonsoft.com/add-ons/qcadcam Version=3.16.7.1

FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcaddwg.so
ID=DWG
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
SystemCodePage=0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1 (Teigha® 4.02.2.0)

Description=Import/export support for the DXF format. Based on dxflib.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcaddxf.so
ID=DXF
License=GPLv2+
Name=DXF
QtVersion=5.8.0
URL=http://www.qcad.org Version=3.16.7.1 (dxflib 3.12.2.0)

Description=OpenGL ES 3D display.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadgles3d.so
ID=GLES
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Description=Integrated help browser.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadhelp.so
ID=HELP
License=Proprietary
Name=QCAD Pro
QtVersion=5.8.0
URL=http://www.ribbonsoft.com Version=3.16.7.1

Description=Polygon clipping, boolean polygon operations, path offset.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadpolygon.so
ID=POLYGON
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Description=QCAD Professional tools.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadproscripts.so
ID=PROTOOLS
License=Proprietary
Name=QCAD Pro
NamePostfix= Professional
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Description=Polygon triangulation.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadtriangulation.so
ID=TRIANGULATION
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Environment
LC_TIME=en_US.UTF-8
DESKTOP_SESSION=default
SSH_AGENT_PID=1743
XMODIFIERS=@im=ibus
LOGNAME=dave
QT_ACCESSIBILITY=1
PAPERSIZE=letter
HOME=/home/dave
LC_NUMERIC=en_US.UTF-8
XDG_DATA_DIRS=/usr/share/default:/usr/share/gnome:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop
XDG_VTNR=2
SHELL=/bin/bash
XDG_SEAT=seat0
GIO_LAUNCHED_DESKTOP_FILE=/home/dave/Desktop/Ribbonsoft-qcad.desktop
WINDOWPATH=2
QT_IM_MODULE=ibus
XDG_SESSION_TYPE=x11
XDG_RUNTIME_DIR=/run/user/1000
LC_MEASUREMENT=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
XDG_CURRENT_DESKTOP=GNOME
UNICODEMAP_JP=cp932
DEFAULTS_PATH=/usr/share/gconf/default.default.path
LC_PAPER=en_US.UTF-8
XAUTHORITY=/run/user/1000/gdm/Xauthority
LC_ADDRESS=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
QT_STYLE_OVERRIDE=gtk
LC_NAME=en_US.UTF-8
GIO_LAUNCHED_DESKTOP_FILE_PID=13310
LC_MONETARY=en_US.UTF-8
XDG_SESSION_DESKTOP=default
GTK_MODULES=gail:atk-bridge
XDG_MENU_PREFIX=gnome-
XDG_SESSION_ID=1
QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
XDG_CONFIG_DIRS=/etc/xdg/xdg-default:/etc/xdg
DISPLAY=:1
LD_LIBRARY_PATH=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64
PWD=/home/dave
USER=dave
SHLVL=1
_=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/qcad-bin
MANDATORY_PATH=/usr/share/gconf/default.mandatory.path
LANG=en_US.UTF-8
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-S2ePMZG3dG,guid=e590a63ac7ca3b971f776cae58d663c0
GDMSESSION=default
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
SESSION_MANAGER=local/OPA:@/tmp/.ICE-unix/1681,unix/OPA:/tmp/.ICE-unix/1681
USERNAME=dave
PATH=/home/dave/bin:/home/dave/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin

 1563 QCAD (main)Bug ReportCritical Editing box and text insertion does not show fonts Closed
100%
Task Description

Editing box and text insertion does not show fonts installed on Linux Mint 18.1, but Linux on the virtual machine works. Versions 3.16.6 and 13.16.7 were tested. The only source shown in the list of options is “standart”.

 1562 QCAD (main)Bug ReportLow 3.16.7 MacOS 64bit Crashes on Launch Closed
100%
Task Description

Hi, I have just tried updating from 3.16.2 (working) to the latest version 3.16.7 on MacOS Lion 64bit, and the new version crashes immediately on launch.

Here is the Apple problem report:
Process: launchd [438]
Path: /Applications/QCAD_new_broken.app/Contents/MacOS/QCAD
Identifier: org.qcad
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: launchd [236]

Date/Time: 2017-03-22 08:28:00.043 +0000
OS Version: Mac OS X 10.7.5 (11G63)
Report Version: 9

Interval Since Last Report: 17907473 sec
Crashes Since Last Report: 173
Per-App Crashes Since Last Report: 6
Anonymous UUID: A36E8DD9-5A71-4361-9929-92E4633D8136

Crashed Thread: Unknown

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00007fff5fc01028

Backtrace not available

Unknown thread crashed with X86 Thread State (64-bit):

rax: 0x0000000000000055  rbx: 0x0000000000000000  rcx: 0x0000000000000000  rdx: 0x0000000000000000
rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x0000000000000000  rsp: 0x0000000000000000
 r8: 0x0000000000000000   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000000
r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x0000000000000000  r15: 0x0000000000000000
rip: 0x00007fff5fc01028  rfl: 0x0000000000010203  cr2: 0x00007fff5fc01028

Logical CPU: 1

Binary images description not available

External Modification Summary:

Calls made by other processes targeting this process:
  task_for_pid: 1
  thread_create: 0
  thread_set_state: 0
Calls made by this process:
  task_for_pid: 0
  thread_create: 0
  thread_set_state: 0
Calls made by all processes on this machine:
  task_for_pid: 498
  thread_create: 0
  thread_set_state: 0

Model: MacBookPro3,1, BootROM MBP31.0070.B07, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.16f11
Graphics: NVIDIA GeForce 8600M GT, GeForce 8600M GT, PCIe, 256 MB Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 667 MHz, 0x7F98000000000000, 0x4B494E4753544F4E20202020202020202020
Memory Module: BANK 1/DIMM1, 2 GB, DDR2 SDRAM, 667 MHz, 0x7F98000000000000, 0x4B494E4753544F4E20202020202020202020
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0×87), Atheros 5416: 2.1.14.9
Bluetooth: Version 4.0.8f17, 2 service, 11 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
PCI Card: pci168c,24, sppci_othernetwork, PCI Slot 5
Serial ATA Device: ST1000LM014-1EJ164, 1 TB
Parallel ATA Device: HL-DT-ST DVDRW GWA4080MA
USB Device: Built-in iSight, apple_vendor_id, 0×8502, 0xfd400000 / 3
USB Device: hub_device, 0×0424 (SMSC), 0×2514, 0xfd100000 / 2
USB Device: DataTraveler 2.0, 0×0951 (Kingston Technology Company), 0×1665, 0xfd130000 / 6
USB Device: Samsung M3 Portable, 0x04e8 (Samsung Electronics Co., Ltd.), 0x61b6, 0xfd120000 / 5
USB Device: iPod, apple_vendor_id, 0×1209, 0xfd140000 / 4
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0×8205, 0x1a100000 / 2
USB Device: USB Receiver, 0x046d (Logitech Inc.), 0xc52f, 0x1a200000 / 3
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x021b, 0x5d200000 / 3
USB Device: IR Receiver, apple_vendor_id, 0×8242, 0x5d100000 / 2

 1561 QCAD (main)Bug ReportLow Edit > Drawing Preferences: menu missing (macOS, French ...Closed
100%
Task Description

Qt menu heuristic causes Edit > Drawing Preferences to disappear with French locale under macOS.

Edit > Application Preferences and Help > About are moved to erroneous locations as well.

 1560 QCAD (main)Bug ReportHigh Main menu not selectable (Ubuntu 16.04, Unity) Closed
100%
Task Description

The main menu bar does not allow any selections, there is not even an underscored shortcut character shown.

 1559 QCAD (main)Bug ReportLow Font substitution in command line tools Closed
100%
Task Description

Font substitutions broken for many cases.
Font “Standard” can never be substituted.

 1558 QCAD (main)Bug ReportLow unlayed lines Closed
100%
1 Task Description

DWG archive opened by QCAD (15.X/16.X - Linux mint 18.1 and Windows 10) does not show traits that represent project windows, when the same file is opened by the dwg True view they appear, follows archive for evaluation.

 1557 QCAD (main)Bug ReportLow Zero length lines not shown Closed
100%
Task Description

Zero length lines are not shown in QCAD. For best compatibility these should be shown as dots.

 1556 QCAD (main)Bug ReportLow Linux lubuntu - menu doesn't work properly Closed
100%
Task Description

This is not the only menu that didn’t work properly: moving the mouse cursor on the lower arrow made the list moving up; but is impossible to make the list moving down when I put the mouse over the upper arrow.
The only workaround (time consuming but effective) is to select the first upper paper size: selecting again the menu I can see tha current selection in the second position: I select the one above it; and so on, until I find what I need.

1555QCAD (main)Feature RequestLowExport list of points.Assigned
0%
1 Task Description

Hello
It would be great when you can add a function to export a selected object as a list of points.
Is it possible to add?

Autodes DWG TrueView 2017 has this function and it is very useful.
Here you can see a screenshot of this function.

 1554 QCAD (main)Bug ReportLow Auto focus of options toolbar when entering numbers bro ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=32&t=4774

 1553 QCAD (main)Bug ReportLow Modify > Break out Manual: exception with circles Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=32&t=4776

1552QCAD (main)Feature RequestLowLayers: assign different color for printingAssigned
0%
Task Description

Original request:

https://www.qcad.org/rsforum/viewtopic.php?f=83&t=4768

 1551 QCAD (main)Bug ReportLow File > Bitmap Export: exception when image size too lar ...Closed
100%
Task Description

Hi friends,

I have this traceback with my Qcad from ppa for linux, to export in png image:
Warning: libpng warning: Image width is zero in IHDR
Warning: libpng warning: Image height is zero in IHDR
libpng error: Invalid IHDR data
Error: cannot save file: /home/patrinux/Bureau/IMAGE.png
Error: Unknown error
Debug: got transaction
Warning: RScriptHandlerEcma::eval: script engine exception: “Error: :-1:-1: Wrong number/types of arguments for RMainWindowQt.handleUserWarning().
<native>() at -1
<anonymous>() at scripts/File/BitmapExport/BitmapExport.js:56
<native>(RActionAdapter(0x26d1ea0)) at -1
<global>() at 1” Warning: “<anonymous>()@scripts/File/BitmapExport/BitmapExport.js:56” Debug: got transaction

Impossible to obtain an png image, and others too. I am on Linux Mint Serena 64B alias Ubuntu Xenial 16.04. Qcad last release:

Version :
3.16.4.4 (3.16.4.4)
Internet :
QCAD.org
Date de fabrication :
Jan 26 2017
Révision :

Qt Version :
4.8.7
Architecture :
x86_64
Compiler :
gcc 5.4.0

 1550 QCAD (main)Bug ReportLow Block references: mirrored block references in 3rd part ...Closed
100%
Task Description

Files imported from other CAD applications might contain blocks that are mirrored if the block reference uses an inverted extrusion direction.

1549QCAD (main)Feature RequestLowSeparate Coordinate Display from Drawing DimensionsAssigned
0%
Task Description

Source:
https://www.qcad.org/rsforum/viewtopic.php?f=31&t=4752

According to the changelog for version 3.9.3 the info tools and coordinate display are tied to the current drawing dimensions. For much of my use I prefer to have the dimensions format different. The main reason is that my customers want to see the format in fractions, but when I am drawing I’d rather see the decimal format to make sure what I am drawing is accurate. So I’d really be interested in seeing a separate full configuration of the display and info coordinates.

 1548 QCAD (main)Bug ReportLow Block > Attributes > Synchronize Attributes: exception Closed
100%
1 Task Description

Block attributes are not properly synchronized on QCad 3.16.5 after editing the block in the drawing, in Linux Mint 18.1 and in Windows 10; On Windows as less frequency, the error is intermittent, on Linux is constant. Attach the dxf to test.

 1547 QCAD (main)Bug ReportLow PDF won't print out properly Closed
100%
Task Description

Hi Andrew

I have attached a file which was drawn in QCAD, but for some reason when exported to PDF from QCAD it doesn’t print out properly,all I get is the dimensions only.

When printed direct from QCAD all is fine?

Regards

Clive

 1546 QCAD (main)Bug ReportLow 'Open file' dialog shows no files - although the direct ...Closed
100%
Task Description

I have many .dxf files created in QCad-2.2.2.0 (which I still use) all of which open in LibreCad without issues.

If I try to open a file in the version below (or an earlier fairly recent version) the file chooser dialog is empty.

Version: 3.16.5.0 (3.16.5)
Build Date: Feb 20 2017
Qt Version: 5.6.2
Architecture: x86_64
Compiler: gcc 5.4.0
OS: Mageia 6 x86_64 with plasma5 D.E

However if I copy a file name from the same directory using Dolphin file manager and paste it into the filename field in the chooser (which is showing no files) the file opens up correctly.

I reported this in Mageia bugzilla here against an earlier version but there was no response as I think the maintainer is MIA. https://bugs.mageia.org/show_bug.cgi?id=18816

Today I decided to try the latest version in the hope that this issue would be fixed (I am also a packager with Mageia) but it is still the same.

I will add the build log as an attachment in case you see something that may be specific to our configuration.

It would be good if we could resolve this before the imminent release of Mageia 6 ;)

Running from CLI I see these around the time I open the file chooser dialog:
——–snip——— 22:05:02: Debug: TransactionListenerPlugin::postInit
22:05:02: Debug: got transaction
22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:19: Debug: got transaction
22:05:47: Debug: got transaction
22:06:08: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:06:09: Debug: got transaction
———-snip——–

 1545 QCAD (main)Bug ReportLow File > Open: Crash on some Linux setups Closed
100%
Task Description

A curious fact is occurring here QCad 3.16.5 is aborting the opening of files in 90% of the attempts on a machine with native Linux Mint 18.1 and works normally in a virtual machine under Virtualbox in Windows 10, tests were done on the 3 machines (VM-Linux, Nat-Linux and Win 10) with QCad 3.15.5 and everything works normally. The two notebooks tested have Intel I-7 RAM = 8Gb Ram and 4 processors. Follow 02 files for evaluation.

 1544 QCAD (main)Bug ReportLow Crash when selecting spline Closed
100%
Task Description

This is an interesting bug on my machine. The attached file crashes on 3.15.5, works perfectly well on 3.11.0 and 3.7.5

To see the problem open the file and click on the upper spline. QCAD disappears.

dajo

 1543 QCAD (main)Bug ReportLow Input with dead-keys broken (Linux) Closed
100%
1 Task Description

Latin characters do not work in version 3.16.5 on Linux, such as ã, õ, é, à, the curious thing is that “ç-” works. If on your machine the Latin characters that do not work are not appearing follow a bitmap for visualization.

1542dwg2svgFeature RequestLowdwg2svg: add switch to show only given layer(s)Assigned
0%
Task Description

Implement a command line switch to only show a list of given layers for dwg2* command line tools.

1541QCAD (main)Feature RequestLowView > Zoom > Zoom In/Out: Make zoom factor configurabl...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=32&t=4729

 1540 QCAD (main)Bug ReportLow Draw > Line > Parallel: Changing back to Auto has no ef ...Closed
100%
Task Description

Draw > Line > Parallel
- switch type to Line, XLine or Ray
- switch back to Auto
- Parallel is always line segment

 1539 QCAD (main)Feature RequestLow One more "Offset" option: Infinitive Line ... Closed
100%
1 Task Description

hi,

I miss one Offset option to use an offset indirectly related to the used entity. Right now I have to work with further construction lines and trim, divide, delete etc. tools to archive what I need.
Basically an offset as a ray would be enough but unfortunately we have no control of the Ray orientation.
This said - it would be nice to have an infinitive line added to the “Offset Polyline Segment” option to be able to use an Offset as construction line which is not only reflecting the shape of the source.

 1538 QCAD/CAMBug ReportLow CAM not use the shortest way Closed
100%
Task Description

ich habe ein Linien Gitter in QCAD erstellt und dann mit CAM Export eine NC Datei erstellt.
Im CAM Simulator sieht man dass der GCODE Postprozessor nicht den kürzesten Weg verwendet.
Anbei folgende Dateien :
CAM_TEST_LINIEN.dxf, CAM_TEST_LINIEN.nc, CAM_TEST_LINIEN.log und eine Bilddatei CAM_TEST_LINIEN.png hier kann man sehen wie die Eistellungen für die GCODE Erstellung sind.

 1537 QCAD (main)Feature RequestLow Draw > Shape: Add option to fill shape (add solid fill) Closed
100%
Task Description

Add an option to create a solid fill hatch for shape tools.

 1536 QCAD (main)Bug ReportHigh Draw > Polyline > Delete Node(s): crash when deleting 2 ...Closed
100%
Task Description

QCAD crashes when you perform the following operations:

1. Create Polyline with just one segment.  
2. Delete the node with DELETE NODE(S) command.  
3. Press ESC several times.
(-> QCAD crashes..)
 1535 QCAD (main)Bug ReportLow File > Save: image references of deleted images remain  ...Closed
100%
1 Task Description

by inserting and deleting many figures in the drawing the references to these figures are not excluded from the dxf / dwg file structure, if you exclude a figure and include it again, the reference is duplicated, etc .. this causes an increase of the size of the files dwg / dxf.

 1534 QCAD (main)SuggestionLow Headless Styling Closed
100%
Task Description

Since the launcher batch no longer requests “-style plastique” QT wants to apply the native style of the desktop environment. This fails on a headless system (or where the current user has no graphical shell to connect to) with the message “Gtk-WARNING **: cannot open display: “. Fortunately, QT provides a workaround in addtion to the new “platform=offscreen” flag.

In the tools that set -no-gui, beforehand export these variables into the environment

export QT_STYLE_OVERRIDE=""
export QT_QPA_PLATFORM=offscreen
export DISPLAY=""

PS: QT-offscreen will not find fonts; unfortunately the workaround only allows for a single directory to search them (I need helvetica):

export QT_QPA_FONTDIR="/usr/local/share/fonts/type1"

Maybe that should get reported upstream, so that like LD_LIBRARY_PATH several directories could be specified.

 1533 QCAD (main)Bug ReportLow I can not print and I can not export to "pdf" file (Qca ...Closed
100%
Task Description

I can not print and I can not export to “pdf” file.
I use the latest professional version of Qcad with windows 10.
Thank you

 1532 QCAD (main)Bug ReportLow Selection Problem ? Closed
100%
Task Description

Please attached file. When dragging a selection window across only the cyan lines -I get only one line selected?

 1531 dwg2svgFeature RequestLow dwg2maptiles: add support for transparent background Closed
100%
Task Description

Trying to create map tiles using dwg2maptiles with a transparent background by adding the option-
-background=’#00FFFFFF’
-background=’transparent’

The output has transparent background but the PNGs get multiplied and scrambled and are not at all as expected.

Attached: original DWG file and an example of the error prone PNG.

 1530 QCAD (main)Bug ReportLow Draw > Circle > 3 Tangents: solutions not found Closed
100%
1 Task Description

Given is a drawing of two concentric arcs connected at the ends. (see attached drawing Circle_from_3_Tangents_1.png)

When I try to add a circle at one end by the “Circle from 3 Tangents”-tool, it does nothing.

I also tried it with another drawing (see attached drawing Circle_from_3_Tangents_2.png) - same negative result.

I then tried drawing Circle_from_3_Tangents_3.png. Here the tool only produces outside circles and misses the inside ones.

Hope you can confirm my findings.

 1529 QCAD (main)Bug ReportLow File > Save: error if dimension text size is zero Closed
100%
Task Description

The error shown in the attached figure (print sreen) appears when you try to create a library item from the selection. Versions 3.15.5 and 3.16.4 on Windows 10 and Linux Mint; Sometimes terminates the QCad program.

 1528 QCAD (main)Bug ReportLow Block attributes: relationship with block reference los ...Closed
100%
Task Description

The blocks that are included in drawings by version 3.16.4 do not obey the rule “select attributes along with block references” while in version 3.15.5 in the same drawings and for the same blocks the rule is obeyed.
Note: Blocks already included in the previous version will enforce this rule in the new version.

 1527 QCAD (main)SuggestionLow "Zeichnungseinheit konvertieren" translation missing .. ...Closed
100%
Task Description

... for the Option bar.

1526QCAD (main)SuggestionLowExporting block attributes to CSVAssigned
0%
1 Task Description

Two useful commands make it necessary to

1-”delete all the history of the command lines without terminating QCad” ; and

2-”export attributes to the CSV file as exported to the Blocks List”

 1525 QCAD (main)Bug ReportLow Block attributes: escaped unicode sequences in files no ...Closed
100%
1 Task Description

The characters in Portuguese such as “ç é â ... etc ...” are replaced by codes starting with version 3.16.x
Files created with versions of QCAD 3.15.x whose characters were correct in the Properties List when opened by QCAD 3.15.x appear in this strange way when opened in versions 3.16.x.
However, in the screen and in the extraction of the list of attributes the characters are correct.
Apparently the error only occurs in texts on the Block Properties List and Attributes.
However, you can use correctly the characters in a file created from version 3.16.x

Exemplo: “dormitory’ in portuguese is “dormitório” it’s appear like “DORMIT\U+00d3RIO” when file is opened on QCAD 3.16.x

 1524 QCAD (main)Bug ReportLow Command line: cannot enter @ sign in command line on Ge ...Closed
100%
Task Description

@ sign cannot be entered into command line on German keyboards on which Alt-Q has to be pressed to enter @.

This is a Qt/Linux bug which interprets Alt-Q as part of a shortcut starting with Q.

Workaround: change shortcut of Reset tool from QQ to something else, not starting with Q.

 1523 QCAD (main)Bug ReportLow Draw > Hatch > Hatch from Segments: fails for circle in ...Closed
100%
Task Description

- Draw circle inside other circle
- Draw > Hatch > Hatch from Segments
- Click both circles
- Right-click

 1522 QCAD (main)Bug ReportLow "Hatch from Segments" problem with polylines ... Closed
100%
Task Description

I tried to hatch an area and the Reference Manual said all entities can be used but it doesn’t works at my example. Did I missed something?

The test drawing shows at the top the goal with exploded polylines. At the bottom I have rectangles (Polylines, drawn with the Rectangle tool) what is unfortunately not working.

 1521 QCAD (main)Bug ReportLow Modify > Offset: fails in certain cases with short arcs Closed
100%
Task Description

Offset curve not trimmed / clipped correctly.

Offset distance: 2.5

 1520 QCAD (main)Bug ReportLow Modify > Rotate: rotating splines changes start/end tan ...Closed
100%
Task Description

- Create spline from fit points
- Rotate spline
- Spline shape changes due to erroneous start/end tangents

Similar problem when reversing spline from fit points.

 1519 QCAD (main)Bug ReportLow Ruler precision always zero Closed
100%
Task Description

Rulers show only whole numbers.

Showing tasks 201 - 250 of 1768 Page 5 of 36<<First - 3 - 4 - 5 - 6 - 7 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing