QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask Type  ascSeveritySummaryStatusProgress
 1076 QCAD/CAMBug ReportHigh Crash on Mac OS X when using internal Trackpad Closed
100%
1 Task Description

Hi,

I have just updated my Mac OS from 10.9.2 to 10.9.4. QCAD 3.6.2 seems to be working normally under the newest version of Mac OS, but has developed a very specific bug which leads to reproducible crashes when a text object is edited.

Steps to minimally reproduce:
1. Open QCAD
2. Create a text object
3. Place the text object on the canvas
4. double-click the text object and edit its contents
5. click OK to accept changes
6. repeat from step 4 three or four times.

After several attempts to edit a text object, QCAD will crash with EXC_BAD_ACCESS (SIGBUS) in thread 0 (QCoreApplication).
The crash can also be triggered by moving the text object around on the canvas (instead of editing its contents).
The bug does not require anything else (no other objects on the canvas, no particular font, occurs in both new and previously saved documents).

Apart from this bug, QCAD seems to work fine on OS X 10.9. The text editing crash did not occur before the latest OS update. No other applications on my system seem to be having any problems. If this problem can be fixed, I think QCAD will be quite usable on 10.9.

See also related bugs in:
 FS#1091 

 1135 QCAD (main)Bug ReportHigh Minimally reproducible segfault when moving a leader in ...Closed
100%
Task Description

Hi,

I have a nice minimally reproducible bug on QCAD v3.7.4 on Mac OS X 10.9.5 (Mavericks).
QCAD will segfault whenever I take the following steps:

1. Open a new document
2. Create a leader object (D,E) in the default ‘0’ layer. Leave its style and color defined by the layer, as per default.
3. Create a new layer, with a non-default line style or color. The line weight & layer name do not matter.
4. Select the leader object previously create
5. Open the property editor and assign the object to the new layer just created.
Every time, this will cause QCAD to segfault on my machine. The crash report is attached.

Another minimally reproducible path to the same error is to do the following:
1. Open a new document
2. Create a leader object (D,E) in the default ‘0’ layer. Give it a custom color and line style that over-ride the layer defaults.
3. Create a new layer, with a non-default line style or color. The line weight & layer name do not matter.
4. Select the leader object previously created.
5. Open the property editor and assign the object to the new layer just created.
6. Still in the property editor, switch the leader object’s color back to ‘By Layer’.
The same segfault will occur.

It seems that the crash is triggered by the action of changing a leader object’s color (and/or line style) in a manner that requires the object to check the containing layer’s default color and style. You can achieve this by either changing the object’s layer, or switching the color and style from being custom defined to ‘by layer’, as long as the selection requires the line’s appearance to change.

Any thoughts? My machine’s crash report is attached.

Dan

 1492 QCAD (main)Bug ReportHigh Crash when selecting polygon Closed
100%
Task Description

When trying to select the innermost square (created as a polygon) - Qcad immediately crashes.

Selection can be either a box select or by clicking on the polygon.

This happened with the latest (3v15.5.0) QCAD/CAM Pro on Linux
I have not attempted to verify problem on windows.

 1560 QCAD (main)Bug ReportHigh Main menu not selectable (Ubuntu 16.04, Unity) Closed
100%
Task Description

The main menu bar does not allow any selections, there is not even an underscored shortcut character shown.

 199 QCAD (main)Bug ReportMedium Print preview scaling distorts model view Closed
100%
Task Description

- Draw a rectangle, say 100 x 100 (I use mm unit, but does it matter?)
1
- Turn on print preview
- Turn off print preview
- OK
2
- Turn on print preview
- Set scale 1/10
- Lines are thicker now, this is good
- Turn off print previw
- Lines stay thick in model view, should that be so?
3
- Set layer 0 to use dash as line-style
- Turn on print preview
- Looks OK
- Set scale 1/10
- Dashes hardly visible, looks almost like a continuous line

In the end of 2,3 a way to reset line width display in model view is to cancel scaling in print preview, ie. turn on print preview, set scale 1:1. I suppose this is a regression since TP1: model view always is unscaled.

The line-width scaling is quite accurate now: Draw two lines 10 mm apart. Set line-width 0.5mm. Set scale 1:20 and the lines exactly touch.

 435 QCAD (main)Bug ReportMedium QCAD3 RC3 Windows XP - Stretch command does not appear  ...Closed
100%
Task Description

The modify tools → stretch command does not appear to function.

The two attachments contain the source drawing (blackburne_engine_breather_0210A.dxf) and five screen shots (qcad3_rc3_stretch.odt) showing the steps taken to replicate the problem.

I have also performed a similar exercise with a Linux trial version 3.0 RC2 (OpenSuse 11.4) with the same result.

Regards

 442 QCAD (main)Bug ReportMedium Library incompatible licence Closed
100%
Task Description

Reading  FS#441  I fired up the Library Browser, which works fine here, RC2 from tgz on Ubuntu 10.04, BTW.

The freedxf.com drawings “horseman” and two “women” claim to be “Creative Commons Attribution-NonCommercial-ShareAlike 3.0”. In my opinion, the “NonCommercial” clause does prohibit distribution in QCAD3, which is a commercial package. For a discussion see http://wiki.creativecommons.org/Defining_Noncommercial

 1294 dxflibBug ReportMedium Hatches scale differently now from earlier releases Closed
100%
Task Description

Something with hatching changed between 3.10 and 3.12; Changelog for 3.11.2 states: “Add support for hatch patterns defined per entity”. That may be?

Attached drawing from an older version; open in current and see a black box where there should be earth. Change scaling of hatch from 10 to 254 and it will be exactly the same it was when saving the file.

Curiously, that is like swapping inches and mm? Looking into prefs, there is a new drop down: “Messsytem für Linien und Schraffuren” and it read “imperial”; making it metric and bingo, my drawing looks as intended!

This is bad, because each drawing has to be changed! I changed the application default drawing setting to metric and the existing drawing still had imperial set…

Probably a heuristic was on order? If the drawing does not specify the new setting, and the drawing units is metric, use metric?

 92 QCAD (main)Bug ReportLow Scaled printing and line-widths Closed
100%
Task Description

When printing with a scale, eg. 1:10, line-widths are scaled too. They should not. 1) they become very faint in the printout, 2) line-width in CAD carries extra information (Andrew told me:)

 117 QCAD (main)Bug ReportLow Use APPID when handling extended entity data to prevent ...Closed
100%
Task Description

Rationale:

Let QCAD handle extended entity data, that is used in the industry to instruct postprocessing applications, e.g. the tooling of a mill or robot.

When I say group code or specs below, I refer to this document http://www.autodesk.com/techpubs/autocad/acad2000/dxf/extended_data_dxf_ab.htm

Current:

In the property editor I can add key value pairs to drawing entities. As in this script:

entity.setProperty(new RPropertyTypeId("MY_KEY"), "MY_VAL");
entity.setProperty(new RPropertyTypeId("MY_REAL"), 123);

In DXF this results in a group code “QCAD” followed by alternating keys and values as strings and typed positions respectively:

[…]
  0
LINE
[…]
1001
QCAD
1000
MY_KEY
1000
MY_VAL
1000
MY_REAL
1040
123.0
[…]

Expected:

From reading the specs, this looks perfectly valid. I’d say though, that QCAD is not right to expect any extended data to follow this pattern. The extended entity data, that I want to recreate eg, looks like this:

[…]
  0
LINE
[…]
1001
MY_DATA
1000
MY_FOO: some text
1000
MY_BAR: 1.250000
[…]

That is: a group code, followed by some string values. Notice that the (limited) typing facilities mentioned in the spec are not used, but the application relies on its own peculiar parsing. The same group code appears in the head of the document as an APPID:

[…]
  0
APPID
  2
MY_DATA
 70
     0
  0
[…]

Proposed:

I suggest, that QCAD uses APPIDs to group extended data. Otherwise data loss may occur. In order to not have to maintain a table of known APPIDs, that tells how to parse their extended data, I further suggest that QCAD not expect extended data to follow a “key value” pattern but an “APPID entries” pattern. Here too data would be lost, if there was an odd number of entries in the extended table and QCAD insisted on its own approach.

Within the specs, deep trees could be constructed with the use of the control string (code 1002, { and }), and the propertyEditor would become a nightmare;) So I propose, that QCAD might parse only extended data with its own APPID in key value pairs, and data with other APPIDs as just an ordered list of entries. (In ECMAscript an array will have to be used, as object properties do not keep sequence.)

 118 QCAD (main)Bug ReportLow addBoundary and hatchData fails silently Closed
100%
Task Description

In scripting hatchData.addBoundary can use any shape, but only some actually produce something useful, eg. this fails silently:

var hatch = new RHatchData(false, 200, 0, "ANSI31");
var polyline = new RPolyline(points, true);
hatch.addBoundary(polyline);

Shouldn’t an exception be thrown?

 122 QCAD (main)Bug ReportLow SVG of hatch with "hole" Closed
100%
Task Description

A hatch my have “holes”, if it eg. is made of two forms, an inner form, and and outer form, where the outer form is filled while the inner form appears like a window inside of the fill, that lets the background be seen.

QCAD exports such hatches as two SVG paths in one single entity. But the “hole” is lost in the process. I know of two workarounds, that preserve the original intention of the QCAD drawing, both get the same result most of the time, the second one looking more robust and easier to implement:

# draw the outer form clockwise, draw the inner form counterclockwise
# set the “fill-rule:evenodd” attribute on the fill definition of the entity

Drawing a star like in the SVG spec in QCAD actually produces the same picture – so that should be the way to go.

http://www.w3.org/TR/SVG/painting.html#FillRuleProperty

 190 QCAD (main)Bug ReportLow SVG PG export dimension labels alignment Closed
100%
Task Description

Dimension labels in QCAD are (always?) centered on the dimension line, while in exported SVGs the text starts from the center and extends into the writing direction. This can trivially be fixed by adding the attribute “text-anchor:middle” to the respective SVG “text” nodes.

 191 QCAD (main)Bug ReportLow SVG PG export text vertical and horizontal alignment Closed
100%
Task Description

QCAD offers horizontal and vertical alignment choices for text. This is not carried over to PG exported SVGs. Currently QCAD sets the “dy” attribute on text nodes in a way, such that any text in SVG will look like the QCAD vertical alignment was set to “Top” and the horizontal one to “Left”.

Naively one can just omit the “dy” attribute and in SVG this will look like the QCAD vertical alignment was set to “bottom”. At least for single line texts that should be good.

The horizontal alignments can be recreated in SVG with the “text-anchor” attribute for text nodes. The values “start”, “middle” and “end” correspond to the QCAD “left”, “center” and “right” choices.

 192 QCAD (main)Bug ReportLow SVG PG export stroke width should not scale Closed
100%
Task Description

When PG exporting to SVG, stroke-widths are scaled with the drawing, while they should not.

 193 QCAD (main)Bug ReportLow SVG PG export scale hatches Closed
100%
Task Description

The SVG PG exporter does not scale hatches.

 194 QCAD (main)Bug ReportLow SVG PG export scale text Closed
100%
Task Description

Text scaling in PG SVG exporter is missing just two small additions: These attributes are not taken care of by now:

font-size, dy

Just use the current value times scale: eg 2.5 * 0.1 to have a scale of 1:10. Looks good here.

 195 QCAD (main)Bug ReportLow SVG PG export scale points Closed
100%
Task Description

Points are not scaled when PG exported to SVG:

Points as crosses are created eg. like this:

d=m 2.5,3 1,0 M 3,2.5 l 0,1

and in SVG look fine like that (scale 1/10):

d=m 2.95,3 0.1,0 M 3,2.95 3,3.05

stroke-width should be left unchanged.

 198 QCAD (main)Bug ReportLow SVG PG export dimensions Closed
100%
Task Description

SVG PG exporter, scaled or unscaled, currently only exports the labels of dimensions. Missing are

ticks, arrows, and lines of the dimension.

It will not be as simple as inkscape does it, wrap it all in a <def>.

 200 QCAD (main)Bug ReportLow Patterned lines uncorrectly scaled in print preview Closed
100%
Task Description

In print preview lines are correctly scaled to stay the same width when printed, ie 0.25 or so mm thick. Print preview shows that very good.

But the round line-caps mess up the display, as in small scale the line-caps start to meet and make the line look like a continous one.

Print preview should not only correct line weight but also line patterns, so that the distance between dashes increase by scale.

 202 QCAD (main)Bug ReportLow SVG PG export font colors Closed
100%
Task Description

White text gets exported as white text, while it should be exported as black text. Just like it is with lines. Attached patch makes text rendering use the conversion function that is already in the code base.

 203 QCAD (main)Bug ReportLow Save font styles bold and italic Closed
100%
Task Description

Font styles “bold” and “italic” are not saved to file.

According to http://docs.autodesk.com/ACD/2011/DEU/filesDXF/WS1a9193826455f5ff18cb41610ec0a2e719-7a4d.htm it is saved in dxf as group code 1071 and according to http://www.autodesk.com/techpubs/autocad/dxf/dxf2002.pdf page 20 its type is “Extended data 32-bit signed long”.

 204 QCAD (main)Bug ReportLow SVG PG export font styles Closed
100%
Task Description

Patch to PG export font styles “bold” and “italic” to SVG. (This only works when a file with the right style is loaded into QCAD, as QCAD will yank such style information upon saving.)

 210 QCAD (main)Bug ReportLow Pasting a block form the library browser changes drawin ...Closed
100%
Task Description

I noticed like this:

in a block pasted from the library, text would be under differently coloured lines, although it should be above them, and this does not look nice.

Drawing order inside of a block should not be changed by a paste operation, not?

 217 QCAD (main)Bug ReportLow SVG export ignores exportPoints setting Closed
100%
Task Description

Both SvgExporters ignore the exportPoints setting. Attached patch takes care of that. To be applied from within the “scripts” directory.

Nitpicking in File/SvgExport/SvgExport.js, var properties is meant to be a plain Object instead of an Array, isn’t it?

 245 QCAD (main)Bug ReportLow select contour with no line brings up debugger Closed
100%
Task Description

Select → Contour (T, C) and click into empty space, will cause an exception, REntityPointer being a null pointer (0×0) and not false, undefined or something like that.

 248 QCAD (main)Bug ReportLow Drawing in print preview Closed
100%
Task Description

One can draw in print preview. If one does, QCAD starts acting confused, the model view gets restored with a fullbright white background.

Maybe best is to just disable all drawing and measuring in print preview?

 299 QCAD (main)Bug ReportLow Text of rotated dimensions in SVG PG export Closed
100%
Task Description

Sometimes the text of a dimension (that is in a block - just a suspicion of mine) will not get rotated. I do not know why this.text.getAngle() sometimes returns a wrong value, but there is a simple workaround: always rotate the text with the dimension:

--- SvgExporterPG-orig.js	2011-09-15 23:11:40.000000000 +0200
+++ SvgExporterPG.js	2011-10-07 13:07:03.715374911 +0200

@@ -428,9 +427,7 @@
         // dimension entity: export text:
         this.writeEntityComment(entity);
         this.text = entity.getTextData();
-//        var angle = this.text.getAngle();
-//        var offset = RVector.createPolar(this.text.getHeight()/2, angle + Math.PI/2);
-//        this.text.move(offset);
+        this.text.setAngle(entity.getAngle());
         this.textColor = entity.getColor();
         this.exportText();
         this.text = undefined;
 300 QCAD (main)Bug ReportLow Dashed lines in SVG PG export Closed
100%
Task Description

Chat from  FS#194  singled out, so that can be closed.

Dash patterns in BETA2 are very much out of proportion. BETA2 always PG exports 1:1 and only scales strokes so that in the final rendering they match what a technical drawing would show. As dash patterns depend on stroke, both current stroke and final scale have to be brought in accord.

The patch below also restores the alignment of dashes, so that dashed lines do not end in a gap, at least in most occasions.

--- SvgExporterPG-orig.js	2011-09-15 23:11:40.000000000 +0200
+++ SvgExporterPG.js	2011-10-07 13:28:04.085376719 +0200
@@ -384,32 +384,29 @@
         continuous = true;
     }
     if (!continuous) {
-        //p.scale(this.getPatternFactor());
-        p.scale(1/this.scale);
+        // dash and gap lengths are to be proportional to line weight
+        // beware: line weight unit is 100 times millimeters, convert to current unit
+        // beware: the viewer scales lengths differently from weight
+        p.scale(RUnit.convert(this.weight / 100.0, RS.Millimeter, this.svgUnit) / this.scale);
         var num = p.getNumDashes();
-        var str = "";
+        var str = [];
         for ( var i = 0; i < num; ++i) {
             var len = Math.abs(p.getDashLengthAt(i));
-            // see FS#192:
-            //len = this.convert(len);
-            str += "" + len;
-            if (i < num - 1) {
-                str += ",";
-            }
-        }
-        additionalStyles += "stroke-dasharray:" + str;
-        
-        // does more harm than good
-//        if (isShape(this.shape)) {
-//            var length = this.shape.getLength();
-//            if (isNaN(this.offset)) {
-//                this.offset = this.getPatternOffset(length, p);
-//            } else {
-//                var num = Math.ceil(this.offset / p.getPatternLength());
-        //                this.offset -= num * p.getPatternLength();
-        //            }
-        //            additionalStyles += ";stroke-dashoffset:" + this.offset;
-        //        }
+            str.push(len);
+        }
+        additionalStyles += "stroke-dasharray:" + str.join(",");
+
+        // center dash-array
+        if (isShape(this.shape) && isFinite(this.shape.getLength())) {
+            var length = this.shape.getLength();
+            if (isNaN(this.offset)) {
+                this.offset = -this.getPatternOffset(length, p);
+            } else {
+                var num = Math.ceil(this.offset / p.getPatternLength());
+                this.offset -= num * p.getPatternLength();
+            }
+            additionalStyles += ";stroke-dashoffset:" + this.offset;
+        }
     }
 314 QCAD (main)Bug ReportLow Polyline from segments puts result in layer 0 Closed
100%
Task Description

A polyline or polygon created from segments always ends up in layer 0, shouldn’t it stay in the same layer as the segments have been?

 317 QCAD (main)Bug ReportLow Debugger with -always-load-scripts Closed
100%
Task Description

Starting qcad Beta 3 with command line argument -always-load-scripts will bring up debugger:

Uncaught exception at /opt/qcad-3.0.0-beta3-prof-linux/scripts/library.js:2: RangeError: Maximum call stack size exceeded.
2 include(”sprintf.js”);

 318 QCAD (main)Bug ReportLow Text of dimensions label in SVG PG export  Closed
100%
Task Description

The labels of dimensions in PG exporter are moved half text-height. Thats a bit much, and actually, no such movement looks more true to the display of same in QCAD itself.

--- SvgExporterPG.js.orig	2011-10-15 18:57:29.994666881 +0200
+++ SvgExporterPG.js	2011-10-15 18:57:39.284666834 +0200
@@ -434,7 +434,7 @@
         //debugger;
         var angle = this.text.getAngle();
         //this.text.setAngle(entity.getAngle());
-        var offset = RVector.createPolar(this.text.getHeight()/2, angle + Math.PI/2);
+        var offset = RVector.createPolar(0, angle + Math.PI/2);
         this.text.move(offset);
         this.textColor = entity.getColor();
         this.exportText();
 362 QCAD (main)Bug ReportLow Regression in SvgExporterPG.prototype.exportEntity Closed
100%
Task Description

In RC1 text in PG SVG will be in the wrong location. The position passed from native code to the SvgExporterPG.prototype.exportEntity is wrong:

Instead of the actual place of the text it gets the position of the surrounding block entity, or, for text that is not in a block, “0,0,0”.

Dimension labels are not affected by this. Also HAlign and VAlign are not passed correctly for text in the model-view block.

 368 QCAD (main)Bug ReportLow Appearance preference Closed
100%
Task Description

RC1 is lazy in saving appearance to config. I noticed, because it always started with default window size. Maximizing was not carried over, also the panels were consistently reset.

Only when eg. dragging the handle to change cad-toolbar width not from preferences it would write an “appearance” section to the config file.

The appearance section should be written rather sooner than later.

 421 QCAD (main)Bug ReportLow Multiline Text in SVG Exporter PG Closed
100%
Task Description

Multiline text is in the wrong place. Please see patch below:

— SvgExporterPG.js~ 2011-11-04 22:08:57.000000000 +0100
+++ SvgExporterPG.js 2011-12-07 13:01:43.811533803 +0100
@@ -248,7 +248,8 @@

   this.writeStartElement("flowRoot"); // <flowRoot>
   this.writeFontAttributes();
   var bb = this.text.getBoundingBox();

- var pos = this.text.getPosition();
+ var pos = this.text.getPosition(); always (0,0) ?
+ var pos = bb.getCenter(); // still not right, but closer

   var x = this.convert(pos.x);
   var y = this.convert(pos.y);
   var a = 360 - RMath.rad2deg(this.text.getAngle());
 459 QCAD (main)Bug ReportLow Bitmap Export is Cropping a few pixels too many from bo ...Closed
100%
Task Description

When exporting bitmap images the crop is just a bit too tight, and is resulting in lost parts of the drawing. In QCAD2 there was a very small padding of pixels around the exported object that prevented that problem.

 476 QCAD (main)Bug ReportLow Stretching dimension Closed
100%
Task Description

Draw a horizontal dimension. Stretch (S S) it. The label remains in place. It should instead go to the new center. (Unless it was manually positioned perhaps...)

Workaround: Pick one extension and drop it to where it was, label gets centered.

 483 QCAD (main)Bug ReportLow Return value of autostart applications Closed
100%
Task Description

Whe qcad runs a script from the autostart command line argument, then, if this script ends with an error, the qcad main function should not return 0, but something different, because the return value of 0 is conventionally used to indicate successful operation.

I enter this as a bug, rather than a feature request, because this convention is so entrained (at least in *NIX land), that it breaks fundamental expecations on application behaviour.

 603 QCAD (main)Bug ReportLow SVG import straight path segments Closed
100%
Task Description

I noticed, that paths are not fully imported into QCAD. I rewrote case “m” of “SvgImporter” like below, that way also straight line segments are drawn correctly. Case “M” should be similar:

      case 'm':
          x = ox = coords[0];
          y = oy = coords[1];
          x0 = x;
          y0 = y;
          for (k=2; k<coords.length; k+=2) {
              x += coords[k+0];
              y += coords[k+1];
              this.importLine(ox, oy, x, y);
              ox = x;
              oy = y;
          }
          break;
 730 QCAD (main)Bug ReportLow Svg PG export splines broken Closed
100%
Task Description

With the 3.0.3 point release (latest available for Linux systems), SVG PG exporter fails to export splines:

Uncaught exception at /opt/qcad-3.0.3-prof-linux-x86/scripts/ImportExport/SvgExporter/SvgExporterPG.js:72: TypeError: Result of expression ‘splineSeg.getDegree’ [undefined] is not a function.
72 var degree = splineSeg.getDegree();

The objects returned from getBezierSegments() do not provide the methods of RSpline.

 818 QCAD (main)Bug ReportLow SVG Exporter crashes on polyline Closed
100%
Task Description

Attached sample drawing, that kills QCAD 3.1 beta when exporting to SVG.

The crash happens in line 38 of SvgExporterPG in function SvgExporterPG.prototype.exportPolyline

var pp = new RPainterPath(polyline.toPainterPath());
 969 QCAD (main)Bug ReportLow File - Bitmap export: exported bitmap file locked Closed
100%
Task Description

When I export a bitmap from qcad, windows picture preview will not show it, instead print the message: “the file is in use by another application”. Maybe the exporter does not close the file?

 1178 ECMAScriptBug ReportLow scripting definition point and vertical DIMs Closed
100%
Task Description

A regression? In my script I draw stacked dims (depth d):

    var c = RVector.getAverage(a, b); // Zentrum der Messung
    var dim = new RDimRotatedData();
    dim.setExtensionPoint1(a);
    dim.setExtensionPoint2(b);
    c.x = a.x + d * 50 + ( d > 0 ? 50 : -50 );
    dim.setDefinitionPoint(c);
    dim.setRotation(Math.PI / 2);

Curiosly, this would work in 3.7.5 but fail in 3.7.7: the DefinitionPoint would be ignored then, but only in vertical ones, not in horizontal ones!

More curiously still: The DIM gets drawn right as soon as I move the setRotation call before the setDefinitionPoint call!

PS: the debugger proved very helpful again :)

 1182 QCAD (main)Bug ReportLow Invisible dashed circles/splines Closed
100%
Task Description

Starting with 3.7.7 I noticed, that some parts in drawings are missing: affected are some circles and (some) closed splines. These were created with earlier releases of qcad3.

Attached a file that has two circles, only one of them showing at first (drawn in 3.8.0); set line-display “screen” (NL command) to see the other (drawn earlier). From the dxf serialization (dxflib or teigha does not matter) I do not see where that should stem from or how to fix this.

At zero degrees there is a little dot though, and also, only certain dashed line-types “hide” the (outer only) circle.

Filed under Ubuntu, not tested on windows etc.

1242QCAD (main)Bug ReportLowSVG import DPI box should use localized decimal separat...Assigned
0%
Task Description

I wanted to make it so, that SVG units translate 1:1 into CAD units; I use the German localized QCAD and entered 25,4 into the box with the wrong result, i.e. the same as 25; Entering 25.4 got me what I wanted: The question box needs the point and ignores the comma. Would be nice if it could use the localized separator.

 1320 QCAD (main)Bug ReportLow QFileDialog slow on network drives Closed
100%
Task Description

QFileDialog should use the DontUseCustomDirectoryIcons flag; not much may be lost, performance should increase orders of magnitude for most – https://codereview.qt-project.org/#/c/54983/

 1327 WebsiteBug ReportLow qcad.org vs. ribbonsoft.com Closed
100%
Task Description

In the head of the new task form there is a “search for existing…” link to ribbonsoft.com even though I am browsing flyspray on qcad.org; maybe this can be made a relative link?

 1508 QCAD (main)Bug ReportLow QCAD CE: Subscript and superscript formatting lost when ...Closed
100%
Task Description

When multiple superscripts or subscripts are used in a text field, re-opening the saved dxf file will fail to render all but the first super/subscript element. As per attached example. Bug occurs on all Mac OS X from Mavericks onward.

Minimal reproducible steps:
1. Open new document in QCAD
2. Add a text object
3. Make part of the text sub or super-script
4. Make another part of the text also sub/superscript, with at least one ‘normal’ character between the two sub/superscripts
5. Save file and close it. Don’t have to quit QCAD.
6. Reopen the file. Voila, all but the first sub/superscript element is broken.

Dan.

ps. QCAD is a pretty great piece of software, nice work all.

 1551 QCAD (main)Bug ReportLow File > Bitmap Export: exception when image size too lar ...Closed
100%
Task Description

Hi friends,

I have this traceback with my Qcad from ppa for linux, to export in png image:
Warning: libpng warning: Image width is zero in IHDR
Warning: libpng warning: Image height is zero in IHDR
libpng error: Invalid IHDR data
Error: cannot save file: /home/patrinux/Bureau/IMAGE.png
Error: Unknown error
Debug: got transaction
Warning: RScriptHandlerEcma::eval: script engine exception: “Error: :-1:-1: Wrong number/types of arguments for RMainWindowQt.handleUserWarning().
<native>() at -1
<anonymous>() at scripts/File/BitmapExport/BitmapExport.js:56
<native>(RActionAdapter(0x26d1ea0)) at -1
<global>() at 1” Warning: “<anonymous>()@scripts/File/BitmapExport/BitmapExport.js:56” Debug: got transaction

Impossible to obtain an png image, and others too. I am on Linux Mint Serena 64B alias Ubuntu Xenial 16.04. Qcad last release:

Version :
3.16.4.4 (3.16.4.4)
Internet :
QCAD.org
Date de fabrication :
Jan 26 2017
Révision :

Qt Version :
4.8.7
Architecture :
x86_64
Compiler :
gcc 5.4.0

 1568 QCAD (main)Bug ReportLow Issues: Snaps, Trim, Green selection tool Closed
100%
Task Description

Hello,

There is some issues with the snap tool and the selection tool.The trim button only trims some lines but not all.

1. The snap tool does not let me snap to certain things when i select something. For example i will select a box and i will try to extend the corner to another entities corner but the snap is not there so its free and thus not accurate.

2. For some reason the selection tool does not allow me to select certain things. If i have two boxes overlapping and i use the selection tool (from right to left “green selection box”) it does not allow me to select what i want i have to actually click it. This is annoying when it comes to selecting specific things.

3. The trim tool does not work properly.If i want to trim the inside of a cross hair or such, it only allows me to trim the inside of one line and if i try to trim the other it deletes the complete line.

Please fix as soon as possible. Thanks

Showing tasks 1 - 50 of 80 Page 1 of 21 - 2 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing