QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategory  ascTask TypeSeveritySummaryStatusProgress
1021dwg2pdfFeature RequestLowdwg2pdf: switch to set block to exportAssigned
0%
1 Task Description

Add a command line switch to dwg2pdf to export a given block instead of “*Model_Space”.

1700dwg2pdfFeature RequestLowdwg2pdf: output multiple layoutsAssigned
0%
Task Description

Add support to specify multiple blocks (layouts) to output (one per page).

1542dwg2svgFeature RequestLowdwg2svg: add switch to show only given layer(s)Assigned
0%
Task Description

Implement a command line switch to only show a list of given layers for dwg2* command line tools.

976dxflibBug ReportLowDXF import errors related to hatches, textsAssigned
0%
Task Description

See:
http://www.qcad.org/rsforum/posting.php?mode=reply&f=30&t=2677

1180dxflibBug ReportLowdxflib cannot open files with international characters ...Assigned
0%
3 Task Description

With dxflib, QCAD cannot open any file with Chinese file name or path name, it popups a “Important Error” dialog.
But the writing (”Save As” command) with Chinese file name or path name is of no problem.
Does it mean dxflib can only handle single byte characters file name/path name?
WinXP, QCAD 3.8.0

1203dxflibBug ReportLowImages not saved (dxflib)Assigned
0%
Task Description

I am doing a bit of landscaping and using a (big) ortophoto as one of my layers in order to sanity-check on the ground measurements.

The layer contains a point and the image and nothing else.

The image is a 8MB file: “PNG image data, 4200 x 2980, 8-bit/color RGB, non-interlaced” and it is scaled to 210 coordinate units (meter) horizontally in the drawing.

With approx 50% probability the image disappears during Save, as see for instance in this diff of the DXF file:

      @@ -158699,28 +153057,6 @@ AcDbXrecord
        90
       6
         0
      -IMAGEDEF
      -  5
      -A1
      -100
      -AcDbRasterImageDef
      - 90
      -0
      -  1
      -/critter/HTV10/Ortofoto/ortofoto201502f.png
      - 10
      -210.0
      - 20
      -149.0
      - 11
      -1.0
      - 21
      -1.0
      -280
      -1
      -281
      -0
      -  0
       ENDSEC
         0
       EOF

The point in the same layer does not similarly disappear, the bug only seems to affect images.

I have seen this bug from version 3.7.5.0 to git as of yesterday (63e06c778926a803bdfbffdf27b8c24d41511072).

I have not been able to correlate the bug with anything.

Looking closer at the DXF file (attached), there seems to be some residuce of attempts to insert images in protected/invisible layers, so this may be some kind of refcounting issue.

(Any chance of getting FreeBSD into the “Operating System” field ?)

1506dxflibFeature RequestLowwriteVPort parametersAssigned
0%
Task Description

Add parameters to the function DL_Dxf::writeVPort.
This way users will be able to specify the desired viewport.

Is the github the official repository? Are pull requests sent there accepted?

246QCAD (main)Bug ReportLowFoot drawing unit: value displayAssigned
0%
Task Description

Various issues for grid info, property editor, dimensions, etc.

269QCAD (main)Bug ReportLowInfo: area: display result in dimension display formatAssigned
0%
Task Description

Info: area: display result in dimension display format

See also:
http://www.ribbonsoft.com/rsforum/viewtopic.php?p=4810#4810

482QCAD (main)Bug ReportLowBlock with hatch, scaled with different X / Y factorsAssigned
0%
Task Description

Block with hatch scaled with factor in X different from factor in Y leads to problems if contour contains arcs (which cannot / are not scaled disproportionally).

498QCAD (main)Bug ReportLowissue importing from AutocadAssigned
0%
Task Description

There is an issue importing from Autocad:
lines and quotes (both arrows and text) appear too much big (see attachment).
I can fix quotes modifying dimensions in “current drawing preferences”, but lines are still too thick.
Autocad’s dxf are opened with right line thickness but wrong quotes.
Furthermore, Autocad opens Qcad’s dxf files showing wrong quotes.

523QCAD (main)Bug ReportLowSelection tool button in CAD tool bar shows line tools ...Assigned
0%
Task Description

The selection tool is not accessible:

Click on Selection Tool icon - left panel:

Left panel then shows line tool options.

Click “back” button at top of left panel:

Left panel then shows selection options.

Click an option icon:

Left panel then shows line tool options again.

584QCAD (main)Bug ReportLowLibrary Items können unbrauchbar gemacht werden durch l...Assigned
0%
Task Description

Nach einigen Überraschungen ....

Es ist möglich Layer in nicht eingefügten oder unsichtbar geschalteten Library Items unbemerkt zu löschen ....

Fallbeispiel 1:
Ich arbeite an einer Zeichnung die u.a. den Layer “Gelbe Linie” benutzt.
Ich füge ein Library Item ein was auch einen Layer “Gelbe Linie” hat.
Ich lösche - aus welchen Gründen auch immer - in der Zeichnung das Library Item weil ich es erst später wieder verwenden will.
In der Blocklist ist es natürlich immer noch verfügbar.
In der Zeichnung lösche ich den Layer “Gelbe Linie” da ich diesen nicht brauche brauche - habe aber natürlich nicht im Kopf welche Layer in meinen Blocks verwendet wurden.
Nach einiger Zeit will ich den Block (den aus der Library) wieder einfügen - dieser ist nun aber unbrauchbar da der Inhalt welcher auf dem Layer “gelbe Linie” war fehlt.
Das Library Item neu aus Library laden um das bereits existierende zu reparieren scheitert da das erste nicht überschrieben werden kann. Ich muss den ersten Block löschen um den neuen benutzen zu können.

Fallbeispiel 2:
Da das selbe (löschen der Layer) auch passieren kann bei unsichtbar geschalteten Blöcken kann es dazu führen das ich zig bereits positionierte Blöcke zerstöre und neu platzieren muss um meine Zeichnung zu reparieren.

Fallbeispiel 3:
Ich sehe in meiner Zeichnung einen Layer “Gelbe Linie”. Weiß nicht was das ist - schalte alle Layer unsichtbar außer “Gelbe Linie”. Klicke auf “Auto Zoom” um zu sehen was den auf “Gelbe Linie” ist. Finde nichts = also leer! Lösche Layer “Gelbe Linie”. Der Layer wurde aber von einem im Moment nicht verwendeten Library Block verwendet. Es gibt keinen Hinweis das ich damit ein Library Item zerstören könnte ....

Lange Rede kurzer Sinn: Wäre es machbar/sinnvoll Layer in Blöcken nur löschen zu können wenn ich mich im Edit Modus der Blöcke befinde?

585QCAD (main)Bug ReportLowCopy & Paste Vorschau Proportionen passen nicht ...Assigned
0%
Task Description

Kopiere ich Bemaßungen/Leader in die Zwischenablage und möchte diese dann wieder in die Zeichnung einfügen passen die Vorschau Proportionen nicht mit dem eingefügten Ergebnis überein. Eigentlich nur ein Schönheitsfehler aber es erschwert die korrekte Positionierung und die benutzung der Optionen wie skalieren, rotieren etc ...

641QCAD (main)Bug ReportLowNo warning is displayed when lengthen tool is used with...Assigned
0%
Task Description

Command ‘Lengthen LE’ will extend most arcs but not all (2 arcs in the attached drawing do not work)! There is no obvious reason for this from the users point of view.

645QCAD (main)Bug ReportLowInch - Layerdata / Linewight still in mm ...Assigned
0%
Task Description

Drawing Unit is in “Inch” but the Layer Data (Line wight) is in “mm” ....

I like it ;-) ... but maybe I’m the only one :-(

665QCAD (main)Bug ReportLowPossible printing error on Linux fedora 16?Assigned
0%
Task Description

On behalf of et76
Possible printing error using Linux 16 - needs further testing!
Please see topic: http://www.ribbonsoft.com/rsforum/viewtopic.php?f=12&t=2119

Au nom de et76
Erreur d’impression possible en utilisant Linux 16 - a besoin d’autres tests!
S’il vous plaît voir le sujet: http://www.ribbonsoft.com/rsforum/viewtopic.php?f=12&t=2119

689QCAD (main)Bug ReportLowGrid spacing info not shownAssigned
0%
Task Description

OpenSuSE 12.2: the grid info display is not displayed:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=2178&view=unread#unread

700QCAD (main)Bug ReportLowSaved 'hatched' block loses hatching when using isometr...Assigned
0%
Task Description

Hatched block loses hatching when using isometric projection tool:
See -http://www.qcad.org/rsforum/viewtopic.php?f=32&p=7063#p7063

When manipulating a saved hatched block with the isometric tool it loses the hatching unless the block is exploded.

Is this normal behaviour here? or a bug?

705QCAD (main)Bug ReportLowVerwaltung Library Resourcen und Favoriten ....Assigned
0%
Task Description

Ob dies ein Feature Request oder ein Bugreport ist weiß ich nicht ....

Hier meine Gedanken ....

In den Application Preferences kann ich mehrere Library Sources vorgeben. Ich habe eine auf dem HD und eine auf einen USB angegeben.

Wenn ich nun QCad auf der HD ausführe habe ich beide Ressourcen zur Verfügung. Schön! Natürlich habe ich auch im Library Browser meine Favoriten von beiden Ressourcen angegeben.

Wenn ich nun aber den USB entferne zeigt mir der Library Browser immer noch beide Resorcen als Name an - schalte ich nun um auf die USB Resource bekomme ich keinerlei Hinweis das diese momentan nicht zur Verfügung steht. Es passiert einfach NIX ;-) Es wäre schön wenn ich hier eine “Nicht verfügbar” Meldung bekommen würde.

Wenn ich nun meine Trotteligkeit bemerke und den USB wieder einstecke habe ich logischerweise wieder meine Library zur Verfügung ..... nur die auf den USB Stick verweisenden Favoriten sind auf Nimmerwiedersehen verschwunden. Die auf dem HD bleiben erhalten!

OK - um es ganz rund zu machen ein anderes Szenarios in “Steno”:
QCad Start vom USB - > Library Favoriten anlegen auf USB Library - > QCad schließen - > USB entfernen → QCad auf HD starten - > Library Favoriten auf USB sind verschwunden - > QCad HD schließen - > USB einstecken und QCad von USB starten = Favoriten auf USB bleiben verloren!

Wäre es hier nicht möglich die Favoriten Information dem USB mit auf dem Weg zu geben? Wenn ich eine Favoriten Auswahl auf dem USB nicht kontrollieren kann macht diese Möglichkeit kaum Sinn.

714QCAD (main)Bug ReportLowIsometric view tool bar doesn`t remain ' docked'.Assigned
0%
Task Description

Win 7 - 64
Isometric view tool bar doesn`t remain ' docked’ when re-opening QCAD.

721QCAD (main)Bug ReportLowVertical dimensions imported as horizontal dimensionsAssigned
0%
Task Description

Vertical dimensions created with 3rd party applications are sometimes imported as horizontal dimensions with length 0. Changing the angle in the property editor fixes the problem.
Problem occurs in QCAD 2.2 and QCAD 3.0.

729QCAD (main)Bug ReportLowPreferences not stored on some installationsAssigned
0%
Task Description

Preferences not stored on some installations

See:
http://www.qcad.org/rsforum/viewtopic.php?f=33&t=2269&view=unread#unread

733QCAD (main)Bug ReportLowQCAD Trial: batch tool dwg2bmp produces no outputAssigned
0%
Task Description

Some users are experiencing problems with dwg2bmp.

See forum at:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=2272&view=unread#unread

735QCAD (main)Bug ReportLowAngle dimensioningAssigned
0%
Task Description

See http://www.qcad.org/rsforum/viewtopic.php?f=11&t=2274&view=unread#unread

736QCAD (main)Bug ReportLowsnap tool menu is shown before specifiv tool menuAssigned
0%
Task Description

When creating a new file, selecting the e. g. line tool at first opens the linemenu and the snap tool menu as expected. After clicking on the back button twice (going back to the main menu) and selecting the e. g. circle menu, the snap tool menu is shown instead of the circle menu. Instead the circle menu is shown after pressing the back button again.

This only happens when clicking on the back button, but with any tool menu seleected. Pressing escape to go back does not show this problem.

QCAD is running on Mac OS Mountain Lion.

753QCAD (main)Bug ReportLowPaste Preview confusing ....Assigned
0%
Task Description

If I paste something from the clipboard to a drawing the scales of dims are wrong in the preview.

It is difficult to place it right with a confusing preview of that what I have to place ... ;-)

754QCAD (main)Bug ReportLowAdding or removing additional viewports - gives unwante...Assigned
0%
Task Description

Windows 7-64
3.0.7
When adding or removing additional viewports,an extra unnecessary window of the viewport is created.

756QCAD (main)Bug ReportLowDisplay problem in the Text "Character Map" ...Assigned
0%
1 Task Description

XP/32

Go to:
Text → Special Characters → Others → “Character Map” pops up.
Adjust Zoom to 100% = display problem (not enough space for the single character.

772QCAD (main)Bug ReportLowIsometric grid: toggle buttons not updatedAssigned
0%
Task Description

- Switch isometric grid off
- Switch isometric grid on using drawing preferences
- Tool buttons don’t reflect correct status

794QCAD (main)Bug ReportLowApplying Solid grid lines - not workingAssigned
50%
Task Description

Windows
3.0.8
Application preferences > Graphics View > Appearance - Solid grid lines doesn’t change anything?

864QCAD (main)Bug ReportLowTemplate Preview/Info doesn't shows the sheet orientati...Assigned
0%
Task Description

“Create New Drawing from Template” Browser can’t readout the Page orientation ...

879QCAD (main)Bug ReportLowAutosave function not working if file is opened directl...Assigned
0%
Task Description

If a file is opened by clicking on it in an open ZIP archive, autosave will not work.

Linux Mint -64

Autosave function not working, error warning given instead!

893QCAD (main)Bug ReportLowLibrary Browser - Edit Library Item - opens drawings al...Assigned
0%
Task Description

Library Browser - Edit Library Item - opens drawings always with grid.

- If I switch between opened drawings back and forth the grid will disappear ....
- If I switch the grid button between visible (it is already visible!) and invisible the grid is gone ....

Just Cosmetic ... ;-)

948QCAD (main)Bug ReportLowmainwindow example segfaultsAssigned
0%
Task Description

As far as I can tell, it never worked.

#0  0x0000000000490527 in QFormInternal::domPropertyToVariant ()
No symbol table info available.
#1  0x000000000042aea9 in QFormInternal::QAbstractFormBuilder::toVariant ()
No symbol table info available.
#2  0x00000000004498a6 in QFormInternal::QFormBuilder::applyProperties ()
No symbol table info available.
#3  0x000000000042475f in QFormInternal::FormBuilderPrivate::applyProperties ()
No symbol table info available.
#4  0x000000000042e83b in QFormInternal::QAbstractFormBuilder::create ()
No symbol table info available.
#5  0x00000000004493c0 in QFormInternal::QFormBuilder::create ()
No symbol table info available.
#6  0x000000000042182e in QFormInternal::FormBuilderPrivate::create ()
No symbol table info available.
#7  0x000000000042fa37 in QFormInternal::QAbstractFormBuilder::create ()
No symbol table info available.
#8  0x00000000004225a2 in QFormInternal::FormBuilderPrivate::create ()
No symbol table info available.
#9  0x0000000815eed3d7 in QFormInternal::QAbstractFormBuilder::load ()
   from /usr/home/ice/w/qcad/qcad/plugins/script/libqtscript_uitools.so.1.0.0
No symbol table info available.
#10 0x0000000815ededad in QUiLoader::load () from /usr/home/ice/w/qcad/qcad/plugins/script/libqtscript_uitools.so.1.0.0
No symbol table info available.
#11 0x0000000815eda326 in qtscript_QUiLoader_prototype_call (context=0x813262240)
    at ../../generated_cpp/com_trolltech_qt_uitools/qtscript_QUiLoader.cpp:282
        _q_arg0 = (QIODevice *) 0x813fe5610
        _q_arg1 = (QWidget *) 0x813ffdcd0
        _q_result = (QWidget *) 0x8006e2c00
        _id = <value optimized out>
        _q_self = (QUiLoader *) 0x813f08d40
#12 0x0000000805fc9f78 in QScript::FunctionWrapper::proxyCall () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#13 0x0000000805ee418f in QTJSC::NativeFuncWrapper::operator() () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#14 0x0000000805eb93ee in QTJSC::Interpreter::privateExecute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#15 0x0000000805ec1ccd in QTJSC::Interpreter::execute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#16 0x0000000805ec1ff9 in QTJSC::Interpreter::execute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#17 0x0000000805fa9743 in QScriptEnginePrivate::evaluateHelper () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#18 0x0000000805faabc6 in QScriptEngine::evaluate () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#19 0x0000000800ac5aae in RScriptHandlerEcma::eval (this=0x811f435e0, script=<value optimized out>, 
    fileName=<value optimized out>) at RScriptHandlerEcma.cpp:855
        err = {d_ptr = {d = 0x7fffffffcf50}}
#20 0x0000000800ac65c5 in RScriptHandlerEcma::doScript (this=0x811f435e0, scriptFile=@0x7fffffffd2f0, 
    arguments=<value optimized out>) at RScriptHandlerEcma.cpp:851
        fi = {d_ptr = {d = 0x813f94700}}
        globalObject = {d_ptr = {d = 0x813ff1240}}
        contents = {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 3936}, alloc = 0, size = 0, 
    data = 0x809bb387a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, 
  static shared_empty = {ref = {_q_value = 19}, alloc = 0, size = 0, data = 0x809bb389a, clean = 0, simpletext = 0, 
    righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0x811c11800, static codecForCStrings = 0x0}
#21 0x0000000000417d13 in MainWindow (this=0x7fffffffd4b0, parent=<value optimized out>) at MainWindow.cpp:99
No locals.
#22 0x0000000000416ad9 in main (argc=1, argv=<value optimized out>) at main.cpp:35
        app = <value optimized out>
        window = {<QMainWindow> = {<QWidget> = {<QObject> = {_vptr$QObject = 0x4992b0, static staticMetaObject = {d = {
            superdata = 0x0, stringdata = 0x809933ae0 "QObject", data = 0x809933b80, extradata = 0x809ba94c0}}, 
        static staticMetaObjectExtraData = {objects = 0x0, 
          static_metacall = 0x80985cd80 <QObject::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, d_ptr = {
          d = 0x811d28600}, static staticQtMetaObject = {d = {superdata = 0x0, stringdata = 0x80993cc40 "Qt", 
            data = 0x809940560, extradata = 0x0}}}, <QPaintDevice> = {_vptr$QPaintDevice = 0x499478, painters = 0}, 
      static staticMetaObject = {d = {superdata = 0x809ba94e0, stringdata = 0x808e66be0 "QWidget", data = 0x808e670c0, 
          extradata = 0x809282360}}, static staticMetaObjectExtraData = {objects = 0x0, 
        static_metacall = 0x8087899a0 <QWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, 
      data = 0x811d28748}, static staticMetaObject = {d = {superdata = 0x809282380, stringdata = 0x808ec04c0 "QMainWindow", 
        data = 0x808ec0660, extradata = 0x8092abc60}}, static staticMetaObjectExtraData = {objects = 0x8092d1880, 
      static_metacall = 0x808e5aaf0 <QMainWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}}, 
  documentInterface = 0x811d31600}
        ret = <value optimized out>
980QCAD (main)Bug ReportLowIsometric Projection / blocks / wrong layer are used in...Assigned
0%
Task Description

Isometric Projection used on a selection which contains blocks will mix up the layer affiliations.
No blocks - no problems ;-)

1008QCAD (main)Bug ReportLowDXF (dxflib) compat issuesAssigned
0%
Task Description

Git head as well as 3.4.5 (trial), both with dxflib 3.3.4.0.

Start up QCAD, (with existing or new configuration, doesn’t seem to matter), “Save as” the completely empty drawing, choose “R15 (dxflib)” on Pro (only this one is available on community), save drawing.

Fire up AutoCAD 2000, try to load the empty drawing just saved.

Result:

DXF read error
Error in APPID Table
DXF read error on line 941.
Invalid or incomplete DXF input -- drawing discarded.

Problem not present when a completely empty drawing saved using Teigha in R15 format is opened (ie. it just results in an empty drawing in AutoCAD 2000). Problem is also not present when saving an existing drawing with Pro (trial) with Teigha and opening it in AutoCAD 2000. Problem does present when trying to open a dxflib-saved drawing in AutoCAD 2000.

Empty drawings created with both dxflib 3.3.4.0 in QCAD Pro 3.4.5 trial and Teigha whatever in QCAD Pro trial 3.4.5 are attached. (Community Git 135fd0 is identical to Pro - same dxflib version.)

1042QCAD (main)Bug ReportVery LowPreferences dialogs: help button shown in dialog headerAssigned
0%
Task Description

See:
http://www.qcad.org/rsforum/viewtopic.php?f=33&t=2887&view=unread#unread

1087QCAD (main)Bug ReportLowRuler ticks are not corresponding to the grid pointsAssigned
0%
Task Description

Ruler ticks are not corresponding to the grid points,
Ruler will completely disappear at a certain zoom level,

Settings:
Drawing unit: inch,
Grid settings: Grid 1, Meta Grid 12,
Dim Label Format: “Engineering, 0’-0.0”

see topic below:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=3014

1214QCAD (main)Bug ReportLowArray of blocks -> Clipboard -> "flip pasted entities" ...Assigned
0%
1 Task Description

Case:

Select a block array,
put it with “Copy with reference” or “Cut with reference” into the clipboard,
choose a reference point which isn’t in the center of the array,
use the paste tool / with option “flip pasted entities”

If I flip only in horizontal or vertical direction the preview box will double in size and I can’t place the entities precisely regarding to the reference point.
If I try to flip in both directions at the same time - you can’t see this effect.

1223QCAD (main)Bug ReportVery LowText: formatting with subscript and font sizeAssigned
0%
Task Description

- enter the text A1 and format the “1” as subscript and with a different font size.
When you click OK, it will be something like: AH3.571431;
I have to manually edit it (source tab) to AH3.57143;S^1;

1242QCAD (main)Bug ReportLowSVG import DPI box should use localized decimal separat...Assigned
0%
Task Description

I wanted to make it so, that SVG units translate 1:1 into CAD units; I use the German localized QCAD and entered 25,4 into the box with the wrong result, i.e. the same as 25; Entering 25.4 got me what I wanted: The question box needs the point and ignores the comma. Would be nice if it could use the localized separator.

1339QCAD (main)Bug ReportLowLibrary Browser unstoppableAssigned
0%
Task Description

Hi,

Even with the Application Preference, Library Browser, NO Update on Start up,
the Libray Browser scans the directory, a proces that can’t be stopped or closed.

1424QCAD (main)Bug ReportVery LowEdit > Undo: hatches not selectedAssigned
0%
Task Description

If a hatch is selected, then rotated or scaled and this is undone afterwards, the hatch is not selected anymore.

1427QCAD (main)Bug ReportLowInfo Tool / Polylinie Area (II)/ Preview brokenAssigned
0%
Task Description

Print “Command Line” and as “Add measurement to drawing” works as expected.

1443QCAD (main)Bug ReportVery LowView > Status Bar remains uncheckedAssigned
0%
Task Description

Status Bar menu remains unchecked even it is toggled on or off

1445QCAD (main)Bug ReportLowSwitching off grid scaling can break rulersAssigned
0%
Task Description

See also:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=4314

1460QCAD (main)Bug ReportVery LowTwo Display Environment --> Problems with Toolboxes and...Assigned
0%
1 Task Description

Hello,

I’m unsing a two display environment and got all Tools and Widgets placed on the second display.
See qcad1.png

There are two problems:

1.) When I open another application on second display, three toolboxes stay on top, the others are behind new application.
See qcad2.png

2.) When I minimize Qcad only the mainwindow will be minimuzed, all the toolboxes and widgets stay on second display also with problem 1.
See qcad3.png

Whould be great, when this issues will be fixed :-)

Thank you very much
Andreas

P.S.: Hope described well, if not, please drop me a reply...

1462QCAD (main)Bug ReportLowMac Trackpad zoom gesture not working as expectedAssigned
0%
1 Task Description

Hi,

I am using mac version and I have annoying issue with trackpad.
I use qcad primary with my trackpad and under application preferences (Graphics View/Navigation), my setting is as follows.
Mouse wheel / two finger swipe: Scroll (Trackpad...
Enable pan gesture : unticked (found that enabling this often goes into pan mode when I am just moving my pointer around)
Limit zoom and scroll to prevent overflows : ticked (hoping that this would prevent weird zooming issue. I will describe what I am experiencing later this page)
Reverse mouse wheel direction for zoom :unticked
Mouse wheel zoom factor: 1.02

Things work as expected:

  • panning with two finger swipe
  • and the rest

Issue I am experiencing:

Often, when I am zooming in and out with two finger gestures, the view suddenly sets to some weird state and my drawing goes off the ruler.
The mouse point remains where it is.

Workaround:
Reset viewpoint with autozoom and navigate around.

Expected zoom behaviour:
I expect viewpoint to zoom in / out at where my mouse pointer is or at least the centre of current view point.

1518QCAD (main)Bug ReportVery LowLandscape/Portrait gets confused for custom page sizeAssigned
0%
Task Description

Hello

In the Print Preview or Drawing Preferences / Page Settings if I select a Custom size, then landscape/portrait does not really make sense.

For instance, at work we have a laser cutter which uses a printer driver. The bed of the laser is 600 wide by 300 high. When I wanted to cut
something, I created a custom page size of 600×300 and selected Landscape (because it is wider than high)

Strangely, back in the Print Preview, the page is now sized opposite with regards to Portrait / Landscape mode, which was confusing somewhat.

(see pictures attached)

I think that for ‘Custom’ page size in Drawing Preferences, the option of Portrait or Landscape should probably be ghosted

Then, I think that for Portrait / Landscape mode in the Print Preview, it should display the shape most appropriate, rather than just assuming that the document fits the norm:

  1. Taller than Wide for Portrait mode
  2. Wider than Tall for Landscape mode
Showing tasks 1 - 50 of 360 Page 1 of 81 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing