QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategory  ascTask TypeSeveritySummaryStatusProgress
1749QCAD (main)Feature RequestLowAdd support for non-uniform block scalingAssigned
0%
1 Task Description

Same txt as on the forum.
had a copy because i had to log in 3 times to remark my own post.

Blocks are no solution either.

see pdf
[attachment=0]Block test_1.pdf[/attachment]

Antartica is put in a block as segments.
Added a rounded corner as segments and as poly.
scaled X x0.5 Y x1 origin the center of the magenta circl.

The scaled version is all over the place.
Set them to color red, no use they stay black.

The reference of the block is 2000mm to the left because I tried it out far right of my design.
The cyan circle is about 400mm in diameter.

dxf part included
[attachment=1]Block test.dxf[/attachment]

Version: 3.20.1.0 (3.20.1)
Internet: QCAD.org
Build Date: Apr 13 2018
Revision: dd51609
Qt Version: 5.5.1
Architecture: i386
Compiler: MSVC++ 10.0 (2010)

CVH

1754QCAD (main)SuggestionLowWhen Selecting multiple blocks that contain the same at...Assigned
0%
Task Description

When selecting multiple blocks that contain the same attribute names, attribute properties appear with the values of the last selected block instead of “various”. I do not know if this is a “bug” or developer option, but “various” would be better in my opinion.

1755QCAD (main)Feature RequestLowSelecting standard rotation angles by mouse click for M...Assigned
0%
1 Task Description

This would be nice.
It will save a lot mouse - keypad changes for me.

1760QCAD (main)Bug ReportVery LowSelf-crossing polylines can't be cut twice at segment c...Assigned
0%
Task Description

Re-entering dividing problem from  FS#1757 

Divide the poly selecting near segment 1 at the segment crossing.
> A new node is inserted on the crossing and made start and end node.
Divide the poly again selecting near segment 2 at the segment crossing.
> no division appears to be done.

One can’t divide the second segment at the crossing

Presumed intended behaviour like  FS#1750 

Regards

1765QCAD (main)Bug ReportVery LowErrors with polyline offsetAssigned
0%
1 Task Description

Win 7 32 bit QCAD 3.20.1

Ofsset of a base-line with arcs results in massive ammount of errors.
Most of them occur as a cluster of very tiny segments and are part of the offset. (zoom far in at the red circles)
Mostly they occur where the offsetted arcs should merely be trimmend pairwise.
Some occur as detached entities or as detached strings of entities very near the offset (strings not documented).
Spooks occur at opposite site when base-line is not closed.
360° curls can occur with R = Offset.
Null-entities may occur (not documented, hard to find and not able to copy).

The base-line is checked and sound and has mixed tangentially or not tangentially connected arcs.
Offsetting the mother base-line of the base in the file has similar effect but not all and/or different ones.
Also encountered with offseting polys from fonts.
Used to define pocket paths for CNC.
Detected because the CNC driver will not accept Self-crossers, Null-entities or open ends depending on the settings.

Work arround is to explode and select small entities but this does not solves the issues.
1) Choosing the tolerance large enough will detect small segments that should stay.
2) Recombining will generate new ones at the place where the main segments remain crossed.
Cleaning up the paths is a daunting process with some thousand segments for several offsets.

I assume this has an infuence on the CAM part of QCAD too unless the offset method is different.

1772QCAD (main)Feature RequestLowGo back on right-click on shaded Tool buttonAssigned
0%
Task Description

Right-click on the tools on the left-hand side of the screen brings you back in the hierarchy.

However, that does not work if you right-click while hovering above a button that that is shaded (inactive).

1785QCAD (main)Bug ReportLowTemplate / Viewport scale issueAssigned
0%
Task Description

Given: Template with prepared Paper Space Frame/Titleblock scale = 1:1.
Drawing 1:1
First Viewport / scale 1:1 / inserted in Paper Space = everything fine,
Second Viewport / scale 0.02 will scale the Paper respective to the new Viewport scale but the Frame/Titleblock isn’t scaled.

1788QCAD (main)Feature RequestVery LowAllow snapping to reference point of a block referenceAssigned
0%
Task Description

I know this was reported and fixed before ...

https://www.qcad.org/bugtracker/index.php?do=details&task_id=843

... but it looks like we have the issue now back with some kind of variation.

If I use the test drawing which I posted in 2013 ( FS#843 ) it works still as expected after it was fixed.

If I create a new block it won’t work in a new drawing nor in the old test drawing - no chance to snap to the Block Reference.

Edit: New Test drawing:

1789QCAD (main)Feature RequestLowApplication Preferences / General / Performance :0Assigned
0%
1 Task Description

Hi Andrew,

we know that you need to have always software performance in your mind to decide which features / tools can / should be implemented and on which way.

I really appreciate your effort to find the best middle way between software features and performance but I think also it’s a tough call to appraise worldwide the overall customer equipment to make the software workable to the best for everybody. That isn’t possible without compromise.

Maybe it would make sense to think about a new dialog in the “Application Preferences” to let the user decide what kind of feature are absolutely needed regarding to his/her work-task / equipment. I don’t mean that you need to cover every single thing but the main “performance jeopardy’s” should be covered with an on/off switch.

Yes I know - that isn’t done in 5 minutes but I think that can make your life easier in the long run and will cover even more customer.

Just my two cents. ;)

1793QCAD (main)Bug ReportLowRuler functionality is compromised by Auto Grid settingAssigned
0%
1 Task Description

Regarding to an observation by the forum member Horst1803
http://www.qcad.org/rsforum/viewtopic.php?f=92&t=5725

The ruler functionality is compromised by Graphics View / Grid settings.
To show the full Ruler functionality “Automatic scale grid” has to be activated. I think that is not intended behavior.

Case: Appearance / Show rulers = activated

Application Preferences / Graphics View / Grid

on - Automatically scale grid
on - Automatically scale meta grid
off - Solid grid lines
= Rulers visible
= Graduation visible
= Labels visible

off - Automatically scale grid
on - Automatically scale meta grid
off - Solid grid lines
= Rulers visible
= Graduation invisible
= Labels invisible

1796QCAD (main)Bug ReportLowFile > Open Recent: crash when file is in Google Drive ...Assigned
0%
Task Description

When a file is opened from “File→Open Recent” on QCad Pro it gives a 100% repeatable crash if the file is on a folder synchronized with Google Drive. If the file is opened using “File→Open” instead it works as expected. See attached crash-log.

OSX specific. Does not happen on Linux with synchronized Google Drive folder

System: OSX 10.13.6

QCad version:

Version: 3.21.2.0 (3.21.2)
Build Date: Jul 9 2018
Revision: f9cea14
Qt Version: 5.10.0
Architecture: x86_64
Compiler: Clang 8.0.0

1797QCAD (main)Bug ReportMediumQCAD3 ini file being over-written with default keyboard...Assigned
0%
Task Description

In 3.21.1, and 3.21.2 a change to a shortcut looses all previous shortcut changes.
This does not become apparent in the current session; a modified shortcut works fine together with all the previous modifications, until you close QCAD.
But-
When you re-open QCAD, the only customised shortcut available is the last one that was changed, every other customised keyboard shortcut has gone back to default.

Windows 10 64 , Gigabyte laptop i7 processor

1798QCAD (main)Bug ReportLowDrawing Preferences / General / Linetype / Scale of lin...Assigned
0%
Task Description

“Drawing Preferences / General / Linetype / Scale of linetypes matches the scale of each viewport” is checked by default for new drawings, however the option is not applied until you open the “Drawing Preferences / General / Linetype” screen and click OK – no need to change anything, just opening the screen and clicking OK is sufficient.

1324QCAD/CAMSuggestionVery LowConfusing Copy / Move optionAssigned
0%
Task Description

Hi,

Using the Copy and Move command the [ ] Use current layer and attributes’ is confusing.

Perhaps [ ] change copy /moved set to current layers and attributes. is more suitable.

1369QCAD/CAMBug ReportVery Lowqcad-bin is trying to access non-existent /home/andrewAssigned
0%
Task Description

I experience long start delays. I’ve trace the problem to the fact that I have autofs automounting my home directories. However, an strace of qcad-bin shows the following:

execve("/opt/ribbonsoft/qcad/qcad-3.12.6/qcad-bin", ["/opt/ribbonsoft/qcad/qcad-3.12.6"...], [/* 87 vars */]) = 0
brk(NULL)                               = 0x1eca000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd6194ad000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib", 0x7fff4722f250) = -1 ENOENT (No such file or directory)

Since there is no “andrew” user here, I have to wait for automount to timeout which takes about 2m and is rather annoying.

513TranslationBug ReportLowTranslation errors (German, French, Italian, Spanish, P...Assigned
0%
Task Description

If you spot an error in the translated user interface of QCAD, please add a comment to this task.
Thank you for your help!

Wenn Sie einen Fehler in der übersetzten Benutzeroberfläche von QCAD erkennen, fügen Sie bitte einen Kommentar zu diesem Report hinzu.
Vielen Dank für Ihre Hilfe!

Si vous constatez une erreur dans l’interface utilisateur traduite de QCAD, s’il vous plaît ajouter un commentaire à ce rapport.
Merci pour votre aide!

Si usted encuentra un error en la interfaz de usuario traducida de QCAD, por favor, añadir un comentario a este informe.
Gracias por tu ayuda!

Se você encontrar um erro na interface do usuário traduzidos do QCAD, por favor, adicione um comentário a este relatório.
Obrigado por sua ajuda!

Showing tasks 351 - 366 of 366 Page 8 of 8<<First - 4 - 5 - 6 - 7 - 8

Available keyboard shortcuts

Tasklist

Task Details

Task Editing