QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeverity  descSummaryStatusProgress
733QCAD (main)Bug ReportLowQCAD Trial: batch tool dwg2bmp produces no outputAssigned
0%
Task Description

Some users are experiencing problems with dwg2bmp.

See forum at:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=2272&view=unread#unread

735QCAD (main)Bug ReportLowAngle dimensioningAssigned
0%
Task Description

See http://www.qcad.org/rsforum/viewtopic.php?f=11&t=2274&view=unread#unread

736QCAD (main)Bug ReportLowsnap tool menu is shown before specifiv tool menuAssigned
0%
Task Description

When creating a new file, selecting the e. g. line tool at first opens the linemenu and the snap tool menu as expected. After clicking on the back button twice (going back to the main menu) and selecting the e. g. circle menu, the snap tool menu is shown instead of the circle menu. Instead the circle menu is shown after pressing the back button again.

This only happens when clicking on the back button, but with any tool menu seleected. Pressing escape to go back does not show this problem.

QCAD is running on Mac OS Mountain Lion.

753QCAD (main)Bug ReportLowPaste Preview confusing ....Assigned
0%
Task Description

If I paste something from the clipboard to a drawing the scales of dims are wrong in the preview.

It is difficult to place it right with a confusing preview of that what I have to place ... ;-)

754QCAD (main)Bug ReportLowAdding or removing additional viewports - gives unwante...Assigned
0%
Task Description

Windows 7-64
3.0.7
When adding or removing additional viewports,an extra unnecessary window of the viewport is created.

756QCAD (main)Bug ReportLowDisplay problem in the Text "Character Map" ...Assigned
0%
1 Task Description

XP/32

Go to:
Text → Special Characters → Others → “Character Map” pops up.
Adjust Zoom to 100% = display problem (not enough space for the single character.

772QCAD (main)Bug ReportLowIsometric grid: toggle buttons not updatedAssigned
0%
Task Description

- Switch isometric grid off
- Switch isometric grid on using drawing preferences
- Tool buttons don’t reflect correct status

794QCAD (main)Bug ReportLowApplying Solid grid lines - not workingAssigned
50%
Task Description

Windows
3.0.8
Application preferences > Graphics View > Appearance - Solid grid lines doesn’t change anything?

864QCAD (main)Bug ReportLowTemplate Preview/Info doesn't shows the sheet orientati...Assigned
0%
Task Description

“Create New Drawing from Template” Browser can’t readout the Page orientation ...

879QCAD (main)Bug ReportLowAutosave function not working if file is opened directl...Assigned
0%
Task Description

If a file is opened by clicking on it in an open ZIP archive, autosave will not work.

Linux Mint -64

Autosave function not working, error warning given instead!

893QCAD (main)Bug ReportLowLibrary Browser - Edit Library Item - opens drawings al...Assigned
0%
Task Description

Library Browser - Edit Library Item - opens drawings always with grid.

- If I switch between opened drawings back and forth the grid will disappear ....
- If I switch the grid button between visible (it is already visible!) and invisible the grid is gone ....

Just Cosmetic ... ;-)

948QCAD (main)Bug ReportLowmainwindow example segfaultsAssigned
0%
Task Description

As far as I can tell, it never worked.

#0  0x0000000000490527 in QFormInternal::domPropertyToVariant ()
No symbol table info available.
#1  0x000000000042aea9 in QFormInternal::QAbstractFormBuilder::toVariant ()
No symbol table info available.
#2  0x00000000004498a6 in QFormInternal::QFormBuilder::applyProperties ()
No symbol table info available.
#3  0x000000000042475f in QFormInternal::FormBuilderPrivate::applyProperties ()
No symbol table info available.
#4  0x000000000042e83b in QFormInternal::QAbstractFormBuilder::create ()
No symbol table info available.
#5  0x00000000004493c0 in QFormInternal::QFormBuilder::create ()
No symbol table info available.
#6  0x000000000042182e in QFormInternal::FormBuilderPrivate::create ()
No symbol table info available.
#7  0x000000000042fa37 in QFormInternal::QAbstractFormBuilder::create ()
No symbol table info available.
#8  0x00000000004225a2 in QFormInternal::FormBuilderPrivate::create ()
No symbol table info available.
#9  0x0000000815eed3d7 in QFormInternal::QAbstractFormBuilder::load ()
   from /usr/home/ice/w/qcad/qcad/plugins/script/libqtscript_uitools.so.1.0.0
No symbol table info available.
#10 0x0000000815ededad in QUiLoader::load () from /usr/home/ice/w/qcad/qcad/plugins/script/libqtscript_uitools.so.1.0.0
No symbol table info available.
#11 0x0000000815eda326 in qtscript_QUiLoader_prototype_call (context=0x813262240)
    at ../../generated_cpp/com_trolltech_qt_uitools/qtscript_QUiLoader.cpp:282
        _q_arg0 = (QIODevice *) 0x813fe5610
        _q_arg1 = (QWidget *) 0x813ffdcd0
        _q_result = (QWidget *) 0x8006e2c00
        _id = <value optimized out>
        _q_self = (QUiLoader *) 0x813f08d40
#12 0x0000000805fc9f78 in QScript::FunctionWrapper::proxyCall () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#13 0x0000000805ee418f in QTJSC::NativeFuncWrapper::operator() () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#14 0x0000000805eb93ee in QTJSC::Interpreter::privateExecute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#15 0x0000000805ec1ccd in QTJSC::Interpreter::execute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#16 0x0000000805ec1ff9 in QTJSC::Interpreter::execute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#17 0x0000000805fa9743 in QScriptEnginePrivate::evaluateHelper () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#18 0x0000000805faabc6 in QScriptEngine::evaluate () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#19 0x0000000800ac5aae in RScriptHandlerEcma::eval (this=0x811f435e0, script=<value optimized out>, 
    fileName=<value optimized out>) at RScriptHandlerEcma.cpp:855
        err = {d_ptr = {d = 0x7fffffffcf50}}
#20 0x0000000800ac65c5 in RScriptHandlerEcma::doScript (this=0x811f435e0, scriptFile=@0x7fffffffd2f0, 
    arguments=<value optimized out>) at RScriptHandlerEcma.cpp:851
        fi = {d_ptr = {d = 0x813f94700}}
        globalObject = {d_ptr = {d = 0x813ff1240}}
        contents = {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 3936}, alloc = 0, size = 0, 
    data = 0x809bb387a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, 
  static shared_empty = {ref = {_q_value = 19}, alloc = 0, size = 0, data = 0x809bb389a, clean = 0, simpletext = 0, 
    righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0x811c11800, static codecForCStrings = 0x0}
#21 0x0000000000417d13 in MainWindow (this=0x7fffffffd4b0, parent=<value optimized out>) at MainWindow.cpp:99
No locals.
#22 0x0000000000416ad9 in main (argc=1, argv=<value optimized out>) at main.cpp:35
        app = <value optimized out>
        window = {<QMainWindow> = {<QWidget> = {<QObject> = {_vptr$QObject = 0x4992b0, static staticMetaObject = {d = {
            superdata = 0x0, stringdata = 0x809933ae0 "QObject", data = 0x809933b80, extradata = 0x809ba94c0}}, 
        static staticMetaObjectExtraData = {objects = 0x0, 
          static_metacall = 0x80985cd80 <QObject::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, d_ptr = {
          d = 0x811d28600}, static staticQtMetaObject = {d = {superdata = 0x0, stringdata = 0x80993cc40 "Qt", 
            data = 0x809940560, extradata = 0x0}}}, <QPaintDevice> = {_vptr$QPaintDevice = 0x499478, painters = 0}, 
      static staticMetaObject = {d = {superdata = 0x809ba94e0, stringdata = 0x808e66be0 "QWidget", data = 0x808e670c0, 
          extradata = 0x809282360}}, static staticMetaObjectExtraData = {objects = 0x0, 
        static_metacall = 0x8087899a0 <QWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, 
      data = 0x811d28748}, static staticMetaObject = {d = {superdata = 0x809282380, stringdata = 0x808ec04c0 "QMainWindow", 
        data = 0x808ec0660, extradata = 0x8092abc60}}, static staticMetaObjectExtraData = {objects = 0x8092d1880, 
      static_metacall = 0x808e5aaf0 <QMainWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}}, 
  documentInterface = 0x811d31600}
        ret = <value optimized out>
976dxflibBug ReportLowDXF import errors related to hatches, textsAssigned
0%
Task Description

See:
http://www.qcad.org/rsforum/posting.php?mode=reply&f=30&t=2677

980QCAD (main)Bug ReportLowIsometric Projection / blocks / wrong layer are used in...Assigned
0%
Task Description

Isometric Projection used on a selection which contains blocks will mix up the layer affiliations.
No blocks - no problems ;-)

1008QCAD (main)Bug ReportLowDXF (dxflib) compat issuesAssigned
0%
Task Description

Git head as well as 3.4.5 (trial), both with dxflib 3.3.4.0.

Start up QCAD, (with existing or new configuration, doesn’t seem to matter), “Save as” the completely empty drawing, choose “R15 (dxflib)” on Pro (only this one is available on community), save drawing.

Fire up AutoCAD 2000, try to load the empty drawing just saved.

Result:

DXF read error
Error in APPID Table
DXF read error on line 941.
Invalid or incomplete DXF input -- drawing discarded.

Problem not present when a completely empty drawing saved using Teigha in R15 format is opened (ie. it just results in an empty drawing in AutoCAD 2000). Problem is also not present when saving an existing drawing with Pro (trial) with Teigha and opening it in AutoCAD 2000. Problem does present when trying to open a dxflib-saved drawing in AutoCAD 2000.

Empty drawings created with both dxflib 3.3.4.0 in QCAD Pro 3.4.5 trial and Teigha whatever in QCAD Pro trial 3.4.5 are attached. (Community Git 135fd0 is identical to Pro - same dxflib version.)

1087QCAD (main)Bug ReportLowRuler ticks are not corresponding to the grid pointsAssigned
0%
Task Description

Ruler ticks are not corresponding to the grid points,
Ruler will completely disappear at a certain zoom level,

Settings:
Drawing unit: inch,
Grid settings: Grid 1, Meta Grid 12,
Dim Label Format: “Engineering, 0’-0.0”

see topic below:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=3014

1203dxflibBug ReportLowImages not saved (dxflib)Assigned
0%
Task Description

I am doing a bit of landscaping and using a (big) ortophoto as one of my layers in order to sanity-check on the ground measurements.

The layer contains a point and the image and nothing else.

The image is a 8MB file: “PNG image data, 4200 x 2980, 8-bit/color RGB, non-interlaced” and it is scaled to 210 coordinate units (meter) horizontally in the drawing.

With approx 50% probability the image disappears during Save, as see for instance in this diff of the DXF file:

      @@ -158699,28 +153057,6 @@ AcDbXrecord
        90
       6
         0
      -IMAGEDEF
      -  5
      -A1
      -100
      -AcDbRasterImageDef
      - 90
      -0
      -  1
      -/critter/HTV10/Ortofoto/ortofoto201502f.png
      - 10
      -210.0
      - 20
      -149.0
      - 11
      -1.0
      - 21
      -1.0
      -280
      -1
      -281
      -0
      -  0
       ENDSEC
         0
       EOF

The point in the same layer does not similarly disappear, the bug only seems to affect images.

I have seen this bug from version 3.7.5.0 to git as of yesterday (63e06c778926a803bdfbffdf27b8c24d41511072).

I have not been able to correlate the bug with anything.

Looking closer at the DXF file (attached), there seems to be some residuce of attempts to insert images in protected/invisible layers, so this may be some kind of refcounting issue.

(Any chance of getting FreeBSD into the “Operating System” field ?)

1214QCAD (main)Bug ReportLowArray of blocks -> Clipboard -> "flip pasted entities" ...Assigned
0%
1 Task Description

Case:

Select a block array,
put it with “Copy with reference” or “Cut with reference” into the clipboard,
choose a reference point which isn’t in the center of the array,
use the paste tool / with option “flip pasted entities”

If I flip only in horizontal or vertical direction the preview box will double in size and I can’t place the entities precisely regarding to the reference point.
If I try to flip in both directions at the same time - you can’t see this effect.

1242QCAD (main)Bug ReportLowSVG import DPI box should use localized decimal separat...Assigned
0%
Task Description

I wanted to make it so, that SVG units translate 1:1 into CAD units; I use the German localized QCAD and entered 25,4 into the box with the wrong result, i.e. the same as 25; Entering 25.4 got me what I wanted: The question box needs the point and ignores the comma. Would be nice if it could use the localized separator.

1339QCAD (main)Bug ReportLowLibrary Browser unstoppableAssigned
0%
Task Description

Hi,

Even with the Application Preference, Library Browser, NO Update on Start up,
the Libray Browser scans the directory, a proces that can’t be stopped or closed.

1427QCAD (main)Bug ReportLowInfo Tool / Polylinie Area (II)/ Preview brokenAssigned
0%
Task Description

Print “Command Line” and as “Add measurement to drawing” works as expected.

1445QCAD (main)Bug ReportLowSwitching off grid scaling can break rulersAssigned
0%
Task Description

See also:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=4314

1462QCAD (main)Bug ReportLowMac Trackpad zoom gesture not working as expectedAssigned
0%
1 Task Description

Hi,

I am using mac version and I have annoying issue with trackpad.
I use qcad primary with my trackpad and under application preferences (Graphics View/Navigation), my setting is as follows.
Mouse wheel / two finger swipe: Scroll (Trackpad...
Enable pan gesture : unticked (found that enabling this often goes into pan mode when I am just moving my pointer around)
Limit zoom and scroll to prevent overflows : ticked (hoping that this would prevent weird zooming issue. I will describe what I am experiencing later this page)
Reverse mouse wheel direction for zoom :unticked
Mouse wheel zoom factor: 1.02

Things work as expected:

  • panning with two finger swipe
  • and the rest

Issue I am experiencing:

Often, when I am zooming in and out with two finger gestures, the view suddenly sets to some weird state and my drawing goes off the ruler.
The mouse point remains where it is.

Workaround:
Reset viewpoint with autozoom and navigate around.

Expected zoom behaviour:
I expect viewpoint to zoom in / out at where my mouse pointer is or at least the centre of current view point.

1818DocumentationBug ReportLowQCAD Reference Manual / Paste along Entity ...Assigned
0%
Task Description

... describes basically the “Paste” tool and not the “Paste along Entity” tool.

991QCAD (main)Feature RequestVery LowAdd warning when overwriting custom propertyAssigned
0%
Task Description

Property Editor - Geometry - Custom - Add Custom Property

If I use an identical Name accidentally again in the Custom Property dialog - it will overwrite the first value with the same name without any warnings.

1426QCAD (main)Feature RequestVery LowLoad drawings that were open when closing QCAD on start...Assigned
0%
Task Description

See also:
http://www.qcad.org/rsforum/viewtopic.php?f=31&t=4249

1626QCAD (main)Feature RequestVery Low'Clip to Circle' toolAssigned
0%
1 Task Description

Hi Andrew,

Would it be possible to have a clip to circle tool also please?

Regards

Clive

1649QCAD (main)Feature RequestVery LowAdd configuarable format options for saving blocks to l...Assigned
0%
Task Description

Add configuarable format options in application preferences for saving blocks to library to either dxf or dwg.

1788QCAD (main)Feature RequestVery LowNew snap: reference points of a block referencesAssigned
0%
Task Description

I know this was reported and fixed before ...

https://www.qcad.org/bugtracker/index.php?do=details&task_id=843

... but it looks like we have the issue now back with some kind of variation.

If I use the test drawing which I posted in 2013 ( FS#843 ) it works still as expected after it was fixed.

If I create a new block it won’t work in a new drawing nor in the old test drawing - no chance to snap to the Block Reference.

Edit: New Test drawing:

1443QCAD (main)Bug ReportVery LowView > Status Bar remains uncheckedAssigned
0%
Task Description

Status Bar menu remains unchecked even it is toggled on or off

1691QCAD (main)Bug ReportVery LowIssue with Layouts after "File-Revert"Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Liux Mint

Case:
1. Open some saved drawing with viewport entities on layout block (paper space). Print Preview mode is “On” automatically.
2. After “File-Revert” drawing is reopened on layout block (paper space), but now Print Previw mode is “Off” .

For example can try on “flange.dxf”

1719QCAD (main)Bug ReportVery LowUndo on converted drawing leads to wrong label position...Assigned
0%
Task Description

Drawing converted from inch to mm - undo leads to wrong dim label position. I can fix that with “Reset Label position” but it would be nice if QCAD could to that in first place.

1760QCAD (main)Bug ReportVery LowSelf-crossing polylines can't be cut twice at segment c...Assigned
0%
Task Description

Re-entering dividing problem from  FS#1757 

Divide the poly selecting near segment 1 at the segment crossing.
> A new node is inserted on the crossing and made start and end node.
Divide the poly again selecting near segment 2 at the segment crossing.
> no division appears to be done.

One can’t divide the second segment at the crossing

Presumed intended behaviour like  FS#1750 

Regards

1765QCAD (main)Bug ReportVery LowErrors with polyline offsetAssigned
0%
1 Task Description

Win 7 32 bit QCAD 3.20.1

Ofsset of a base-line with arcs results in massive ammount of errors.
Most of them occur as a cluster of very tiny segments and are part of the offset. (zoom far in at the red circles)
Mostly they occur where the offsetted arcs should merely be trimmend pairwise.
Some occur as detached entities or as detached strings of entities very near the offset (strings not documented).
Spooks occur at opposite site when base-line is not closed.
360° curls can occur with R = Offset.
Null-entities may occur (not documented, hard to find and not able to copy).

The base-line is checked and sound and has mixed tangentially or not tangentially connected arcs.
Offsetting the mother base-line of the base in the file has similar effect but not all and/or different ones.
Also encountered with offseting polys from fonts.
Used to define pocket paths for CNC.
Detected because the CNC driver will not accept Self-crossers, Null-entities or open ends depending on the settings.

Work arround is to explode and select small entities but this does not solves the issues.
1) Choosing the tolerance large enough will detect small segments that should stay.
2) Recombining will generate new ones at the place where the main segments remain crossed.
Cleaning up the paths is a daunting process with some thousand segments for several offsets.

I assume this has an infuence on the CAM part of QCAD too unless the offset method is different.

Showing tasks 301 - 334 of 334 Page 7 of 7<<First - 3 - 4 - 5 - 6 - 7

Available keyboard shortcuts

Tasklist

Task Details

Task Editing