QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatusProgress
 520 QCAD (main)Bug ReportMedium move entity from command line is broken on ubuntu 64 bi ...Closed
100%
Task Description

when I try to move an entity via the command line using the mv command the entity does not move to the specified position. it works if i use the mouse. this was fine in rc2 and rc3 ubuntu 64 bit and windows 64 bit machines.

 1205 QCAD (main)Bug ReportLow Phantom period printed on PDF when attribute is empty Closed
100%
Task Description

I have some blocks with multiple attribute lines to name equipment represented by the block. When an attribute is left empty and printed to paper (and/or SVG) the print out is as expected. Alternatively when I print to PDF QCAD (Qt) seems to put a phantom period (.) where the attribute is.

This is prevalent on Windows 8.1 and Fedora 21.

 925 QCAD (main)Bug ReportLow Attribute definitions duplicated when loaded from DWG Closed
100%
Task Description

Title says it all. Cannot get QCAD to synchronise attributes on Fedora 19 box with QCAD 3.2.2 installed as the machine hangs (a single core of CPU maxed out). This is not present on my Windows machine (Windwows 7).

I can provide a sample file privately if needed.

Kurt

500QCAD (main)Feature RequestLowAutohide Side PanelAssigned
0%
1 Task Description

it would be ideal to be able to have the option to autohide the side panel to increase the visible drawing space when working on a small screen.

 430 QCAD (main)Bug ReportLow ISO Projection of a symmetrical ellipse fails  Closed
100%
Task Description

I am trying to perform an iso projection of an ellipse that represents a circle of radius 10. I get the debugger launch with the following error.

Uncaught exception at /home/kurtforrester/opt/qcad-3.0.0-rc2-trial-linux/scripts/ShapeAlgorithms.js:434: ReferenceError: Can’t find variable: getCenter
434 var arc = new RArc(getCenter(),

 378 QCAD (main)Bug ReportLow Poor performance when trying to move multiple entities Closed
100%
Task Description

I have a dwg file and find the performance very poor when trying to move an entity. QCAD3 beta 3 appears incapable of performing the necessary calculations for the “Auto Snap” when trying to select the reference point (the mouse pointer does not track the path). If Auto Snap is turned off there is no performance issue.

I can provide a problem file (via email) but am unable to upload it to the internet as it is a proprietary drawing.


Showing tasks 1 - 6 of 6 Page 1 of 1

Available keyboard shortcuts

Tasklist

Task Details

Task Editing