QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask Type  descSeveritySummaryStatusProgress
1746QCAD (main)Bug ReportLowIncorrect file extension handling in Export BitmapAssigned
0%
Task Description

A file with name of 1234.56.78.0001.00 Something blah blah.dxf will not export to bitmap correctly. The save dialog will suggest filename of 1234.56.78.0001.jpg instead, truncating everything after last dot.

This bug existed in older versions too because of incorrect handling of file names. As a result, at some point File.getSaveFileName incorrectly truncates the extension (which is empty at the time) and replaces it with jpg. Appending a null extension fixes this, though obviously it’s not a correct fix.

Here is a temporary workaround in File.js:

File.getInitialSaveAsPath = function(filePath, extension) {
    var ret = "";

    var fi;

    if (isNull(filePath) || filePath.length === 0) {
        var mdiChild = EAction.getMdiChild();
        var fn;
        if (!isNull(mdiChild)) {
            fn = stripDirtyFlag(EAction.getMdiChild().windowTitle)
        }
        else {
            fn = "File";
        }

        fi = new QFileInfo(QDir.homePath());
        ret = fi.absoluteFilePath() + QDir.separator + fn + "." + extension + ".nothing"; // Workaround here
    } else {
        fi = new QFileInfo(filePath);
        ret = fi.path() + QDir.separator + fi.completeBaseName() + "." + extension + ".nothing"; // Workaround here
    }
    return ret;
};

1042QCAD (main)Bug ReportVery LowPreferences dialogs: help button shown in dialog headerAssigned
0%
Task Description

See:
http://www.qcad.org/rsforum/viewtopic.php?f=33&t=2887&view=unread#unread

1223QCAD (main)Bug ReportVery LowText: formatting with subscript and font sizeAssigned
0%
Task Description

- enter the text A1 and format the “1” as subscript and with a different font size.
When you click OK, it will be something like: AH3.571431;
I have to manually edit it (source tab) to AH3.57143;S^1;

1369QCAD/CAMBug ReportVery Lowqcad-bin is trying to access non-existent /home/andrewAssigned
0%
Task Description

I experience long start delays. I’ve trace the problem to the fact that I have autofs automounting my home directories. However, an strace of qcad-bin shows the following:

execve("/opt/ribbonsoft/qcad/qcad-3.12.6/qcad-bin", ["/opt/ribbonsoft/qcad/qcad-3.12.6"...], [/* 87 vars */]) = 0
brk(NULL)                               = 0x1eca000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd6194ad000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib", 0x7fff4722f250) = -1 ENOENT (No such file or directory)

Since there is no “andrew” user here, I have to wait for automount to timeout which takes about 2m and is rather annoying.

1424QCAD (main)Bug ReportVery LowEdit > Undo: hatches not selectedAssigned
0%
Task Description

If a hatch is selected, then rotated or scaled and this is undone afterwards, the hatch is not selected anymore.

1443QCAD (main)Bug ReportVery LowView > Status Bar remains uncheckedAssigned
0%
Task Description

Status Bar menu remains unchecked even it is toggled on or off

1460QCAD (main)Bug ReportVery LowTwo Display Environment --> Problems with Toolboxes and...Assigned
0%
1 Task Description

Hello,

I’m unsing a two display environment and got all Tools and Widgets placed on the second display.
See qcad1.png

There are two problems:

1.) When I open another application on second display, three toolboxes stay on top, the others are behind new application.
See qcad2.png

2.) When I minimize Qcad only the mainwindow will be minimuzed, all the toolboxes and widgets stay on second display also with problem 1.
See qcad3.png

Whould be great, when this issues will be fixed :-)

Thank you very much
Andreas

P.S.: Hope described well, if not, please drop me a reply...

1518QCAD (main)Bug ReportVery LowLandscape/Portrait gets confused for custom page sizeAssigned
0%
Task Description

Hello

In the Print Preview or Drawing Preferences / Page Settings if I select a Custom size, then landscape/portrait does not really make sense.

For instance, at work we have a laser cutter which uses a printer driver. The bed of the laser is 600 wide by 300 high. When I wanted to cut
something, I created a custom page size of 600×300 and selected Landscape (because it is wider than high)

Strangely, back in the Print Preview, the page is now sized opposite with regards to Portrait / Landscape mode, which was confusing somewhat.

(see pictures attached)

I think that for ‘Custom’ page size in Drawing Preferences, the option of Portrait or Landscape should probably be ghosted

Then, I think that for Portrait / Landscape mode in the Print Preview, it should display the shape most appropriate, rather than just assuming that the document fits the norm:

  1. Taller than Wide for Portrait mode
  2. Wider than Tall for Landscape mode
1587QCAD (main)Bug ReportVery LowPDF export created with wrong date timeAssigned
0%
Task Description

Hi guys,

when I export my dxf drawing to pdf, the pdf properties shows wrong “created date”. I am in UTC+2, the date shows 2 hours less.
I exported the pdf at 12:24, the attached ps shows 10:24.

BR,
Soma

1660QCAD (main)Bug ReportVery LowViewport in Model Space ...Assigned
0%
Task Description

... I have the feeling that wasn’t the idea. I’m correct?

Case:
in Model Space, launch Add Viewport, determine the Viewport rectangle - when done QCAD will switch to a Layout Block.
Now in Layout Block, don’t(!) place the Viewport, switch back to Model Space and the Viewport is still attached to the Mouse pointer and you can place it in your Model Space. The source of the Viewport will then disappear.

1691QCAD (main)Bug ReportVery LowIssue with Layouts after "File-Revert"Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Liux Mint

Case:
1. Open some saved drawing with viewport entities on layout block (paper space). Print Preview mode is “On” automatically.
2. After “File-Revert” drawing is reopened on layout block (paper space), but now Print Previw mode is “Off” .

For example can try on “flange.dxf”

1692QCAD (main)Bug ReportVery LowIssue with Layouts. "Viewport" enteties are not highlig...Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Linux Mint

Case:
1. Open some drawing with viewport entities on layout block (paper scace). Print Preview mode is “On” automatically.
2. Switch to “Black/White Mode” from toolbar and move cursor on “Viewport” enteties. This entitie is not highlighted. With other enteties all works as expected.
In “Full Color Mode” and “Grayscale Mode” no problems.

For example can try on “flange.dxf”

1719QCAD (main)Bug ReportVery LowUndo on converted drawing leads to wrong label position...Assigned
0%
Task Description

Drawing converted from inch to mm - undo leads to wrong dim label position. I can fix that with “Reset Label position” but it would be nice if QCAD could to that in first place.

1743QCAD (main)Bug ReportVery LowAutozoom does not work when text contains superscriptAssigned
0%
Task Description

Hi,

I have a drawing where I use text with superscript. In this case when I use autozoom, it does not work as I expect. It includes the 0,0 coordinates too. The problem also occures when I export the drawing into svg.

I attached an example, just use the autozoom.

Thanks,
Soma


Showing tasks 351 - 364 of 364 Page 8 of 8<<First - 4 - 5 - 6 - 7 - 8

Available keyboard shortcuts

Tasklist

Task Details

Task Editing