QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatus  descProgress
 366 QCAD (main)Feature RequestLow Draw circles tangent to other entities Closed
2 Task Description

Hi Andrew

It would be useful to have an option in the Circle tools to be able to draw a circle tangent to other entities such as lines/circles etc.



 1682 QCAD (main)Bug ReportLow Draw > Text: line spacing factor < 0.25 or > 4.0 causes ...Closed
Task Description

See also:

 1405 QCAD (main)Bug ReportLow Draw > Text: exception when assigning custom color Closed
Task Description

See also:

 1734 QCAD (main)Bug ReportLow Draw > Text: Color changes for CAD font texts ignored Closed
Task Description

Create text using “standard” font with color change (e.g. one letter in the middle red).

 1448 QCAD (main)Bug ReportLow Draw > Shape > Rectangle with Size: polygon option not  ...Closed
Task Description

See also:

 1381 QCAD (main)Bug ReportLow Draw > Polyline > Simplify: changing tolerance has no e ...Closed
Task Description

Tolerance input field in simplify tool has no effect.

 1333 QCAD (main)Bug ReportLow Draw > Polyline > Partial Polyline Along Selection Closed
Task Description

Exception in RPolyline::getLengthTo if no segment is found while setting start / end point.

 1458 QCAD (main)Bug ReportLow Draw > Polyline > From Segments: empty polyline created ...Closed
Task Description

- Create four arc segments representing a full circle
- Create polyline from segments

Empty polyline is created (caused by simplification).

 1536 QCAD (main)Bug ReportHigh Draw > Polyline > Delete Node(s): crash when deleting 2 ...Closed
Task Description

QCAD crashes when you perform the following operations:

1. Create Polyline with just one segment.  
2. Delete the node with DELETE NODE(S) command.  
3. Press ESC several times.
(-> QCAD crashes..)
 1758 QCAD (main)Bug ReportHigh Draw > Polyline > Create from Selected Entities: crash  ...Closed
Task Description

(Re-)combining polys touching at node with ‘create from selected’ leads to application crash.

QCAD 3.20.1 Win7 32bit

In the file example 2.

 1239 QCAD (main)Bug ReportLow Draw > Polyline > Create from Segments: fails with arc  ...Closed
Task Description

In some cases, loose arc segments result in errors.

 1121 QCAD (main)Bug ReportMedium Draw > Polyline > Append Node(s) broken Closed
Task Description

Selecting the polyline is not possible.
Possibly related to update of DrawPolyline tool.

 1028 QCAD (main)Bug ReportLow Draw > Line > Rectangle with Size: options toolbar layo ...Closed
Task Description

... just cosmetic!

Rectangle with size: The option box “Reference Point” is a bit to small to show the whole text of the chosen option.

English / German = same behavior.

 1540 QCAD (main)Bug ReportLow Draw > Line > Parallel: Changing back to Auto has no ef ...Closed
Task Description

Draw > Line > Parallel
- switch type to Line, XLine or Ray
- switch back to Auto
- Parallel is always line segment

 1736 QCAD (main)Bug ReportMedium Draw > Image: broken Closed
Task Description

Draw > Image broken due to UI file resource not being found.

 1309 QCAD (main)Bug ReportLow Draw > Hatch: cannot create hatch from boundary in bloc ...Closed
Task Description

- Draw boundary (e.g. rectangle)
- Create block from boundary
- Select block reference
- Draw > Hatch

 1408 QCAD (main)Bug ReportLow Draw > Hatch: arc boundaries rendering errors Closed
Task Description

Hatch boundaries containing arcs with large radii are rendered imprecisely.
See also:

 1523 QCAD (main)Bug ReportLow Draw > Hatch > Hatch from Segments: fails for circle in ...Closed
Task Description

- Draw circle inside other circle
- Draw > Hatch > Hatch from Segments
- Click both circles
- Right-click

 1496 QCAD (main)Bug ReportLow Draw > Circle > Center, Point: coordinate input interpr ...Closed
Task Description

I started a drawing with a circle, center at 0,150 and gave 0,0 as coordinate for a point on the circle and got visually nothing.
After some head scratching and trying to find some error like locked layer, drawing color the same as background color and such, I found at the location of the center (0,150) a circle with radius 0.

I made the following trials, every time starting with a new drawing, entering everything with the keyboard.

Center point on result


0,150 0,0 circle radius 0 at 0,150
0,150 50,50 circle radius 50 at 0,150 (should be a radius of 111.8 from 0,150 to 50,50)
0,150 0,50 circle radius 50 at 0,150
0,150 50,0 circle radius 0 at 0,150

It seems I always get a circle with the radius of the y-part of the coordinate.

Used version of Qcad is:
QCAD version:
Date: Aug 19 2016
Qt version: 5.5.1
Compiler version: MSVC++ 12.0 (2013)
Build Date: Aug 19 2016
Revision: 15ef1a13237ff8355ff590fd2e16570ef9de82a0

 1530 QCAD (main)Bug ReportLow Draw > Circle > 3 Tangents: solutions not found Closed
1 Task Description

Given is a drawing of two concentric arcs connected at the ends. (see attached drawing Circle_from_3_Tangents_1.png)

When I try to add a circle at one end by the “Circle from 3 Tangents”-tool, it does nothing.

I also tried it with another drawing (see attached drawing Circle_from_3_Tangents_2.png) - same negative result.

I then tried drawing Circle_from_3_Tangents_3.png. Here the tool only produces outside circles and misses the inside ones.

Hope you can confirm my findings.

 1326 QCAD (main)Bug ReportLow Draw > Circle > 2 Tangents and Radius: not all solution ...Closed
Task Description

If I try to draw a circle between two little circles with a radius (e.g.) of 3000 the tool shows me only two possibility’s - but there are much more. If I make a counter test with the tool “2 Tangents with Point” all possibility’s are correct shown.

first pic “2 Tangents with Point” correct,

second pic “2 Tangents + Radius” incorrect,

 1476 QCAD (main)Bug ReportLow Draw > Circle > 2 Tangents and Radius: exception with a ...Closed
Task Description

Draw > Circle > 2 Tangents and Radius
Choose two arcs or two circles as tangential entities.

 1483 QCAD/CAMBug ReportLow Draw -> Polyline -> Create from Segments deletes a segm ...Closed
1 Task Description

With the attached DXF file, select Draw → Polyline → Create from Segments
(O, G) and click on the complex polyline inside the circle (eg on
the top left arc). Apolyline is created with a few segments,
and one or more segments are deleted!

Different segments are deleted depending on which segment is clicked.

 740 QCAD (main)Bug ReportLow Draw - Arc - Two Points and Radius: wrong console outpu ...Closed
Task Description

XP/32 QCAD 3.0.5

... after picking the first Point a wrong message appears what says:
“Warning: The two points are identical”

 1456 QCAD (main)Bug ReportLow Drag and drop: requires two clicks with auto snap Closed
Task Description

Drag and drop requires two clicks with auto snap if grid snap and free snap are disabled for auto snap.
- Edit > Application Preferences > Snap > Auto Snap: disable grid and free
- Drag an entity and try to position it
- First click does nothing, second click positions entity

 453 QCAD (main)Bug ReportLow Draft mode: GUI action state not updated when switching ...Closed
Task Description
  1. create two new drawings
  2. switch to tab 1
  3. enable draft mode
  4. switch to tab 2

⇒ draft mode button / menu still on (should be off)

 1163 ECMAScriptBug ReportMedium DoveTail-script crashes QCAD Closed
Task Description


I just installed QCAD v3.7.5 and it works like a charm.

Then I installed the DoveTail-script (http://www.qcad.org/rsforum/download/file.php?id=623) and after that QCAD won’t start anymore.

This is the output on the command line in Linux:

Debug: RDwgPlugin::init
Debug: RDxfPlugin::init
Debug: RHelpPlugin::init
Debug: RProScriptsPlugin::init
Debug: loading patterns from file: “/opt/qcad-3.7.5-pro-linux-x86_64/linetypes/metric/qcadiso.lin”
Debug: shape found: “ZIG”
Debug: shape found: “BAT”
Debug: shape found: “TRACK1”
Debug: shape found: “BOX”
Debug: shape found: “CIRC1”
Debug: shape found: “RIGHT_ARROW”
Debug: loading patterns from file: “/opt/qcad-3.7.5-pro-linux-x86_64/linetypes/imperial/qcad.lin”
Debug: TIMER: 67 ms - “loading add-ons”
Warning: RScriptHandlerEcma::eval: script engine exception: “TypeError: Result of expression ‘action.addToWidget’ [undefined] is not a function.”
Warning: “<anonymous>()@/opt/qcad-3.7.5-pro-linux-x86_64/scripts/File/../EAction.js:1180”
Warning: At least one uncaught exception:
Warning: “<anonymous>()@/opt/qcad-3.7.5-pro-linux-x86_64/scripts/File/../EAction.js:1180”
Debug: “<global>() at -1”

Don’t know whether that is a bug in the script or in QCAD, so I am reporting it here.


 460 QCAD (main)Bug ReportLow doubleclick/select truetype font problems Closed
Task Description

truetype fonts are more difficult to use than regular fonts. The do not select easily.

 60 QCAD (main)Bug ReportLow double free detection after exit (Ubuntu) Closed
Task Description
  • File → Quit right after start.
  • Ubuntu 10.10
  • Linux martin-VirtualBox 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 19:00:26 UTC 2011 i686 GNU/Linux
Debug:    autostart.js: main(): end. 
*** glibc detected *** release/qcad: double free or corruption (out): 0x0b18d7d0 ***
======= Backtrace: =========
======= Memory map: ========
00110000-003b1000 r-xp 00000000 08:01 152383     /home/martin/opt/qcad_3_0_tp1/release/libQtScript.so.4.7.3
003b1000-003bc000 rw-p 002a0000 08:01 152383     /home/martin/opt/qcad_3_0_tp1/release/libQtScript.so.4.7.3
003bc000-003cc000 rw-p 00000000 00:00 0 
003cc000-003e1000 r-xp 00000000 08:01 134689     /lib/libpthread-2.12.1.so
003e1000-003e2000 ---p 00015000 08:01 134689     /lib/libpthread-2.12.1.so
003e2000-003e3000 r--p 00015000 08:01 134689     /lib/libpthread-2.12.1.so
003e3000-003e4000 rw-p 00016000 08:01 134689     /lib/libpthread-2.12.1.so
003e4000-003e6000 rw-p 00000000 00:00 0 
003e6000-0040a000 r-xp 00000000 08:01 131677     /lib/libm-2.12.1.so
0040a000-0040b000 r--p 00023000 08:01 131677     /lib/libm-2.12.1.so
0040b000-0040c000 rw-p 00024000 08:01 131677     /lib/libm-2.12.1.so
0040c000-00426000 r-xp 00000000 08:01 131308     /lib/libgcc_s.so.1
00426000-00427000 r--p 00019000 08:01 131308     /lib/libgcc_s.so.1
00427000-00428000 rw-p 0001a000 08:01 131308     /lib/libgcc_s.so.1
00428000-0042a000 r-xp 00000000 08:01 131676     /lib/libdl-2.12.1.so
0042a000-0042b000 r--p 00001000 08:01 131676     /lib/libdl-2.12.1.so
0042b000-0042c000 rw-p 00002000 08:01 131676     /lib/libdl-2.12.1.so
0042c000-00434000 r-xp 00000000 08:01 658308     /usr/lib/libXrender.so.1.3.0
00434000-00435000 r--p 00007000 08:01 658308     /usr/lib/libXrender.so.1.3.0
00435000-00436000 rw-p 00008000 08:01 658308     /usr/lib/libXrender.so.1.3.0
00437000-0052a000 r-xp 00000000 08:01 149112     /home/martin/opt/qcad_3_0_tp1/release/libQtOpenGL.so.4.7.3
0052a000-00531000 rw-p 000f2000 08:01 149112     /home/martin/opt/qcad_3_0_tp1/release/libQtOpenGL.so.4.7.3
00531000-00544000 r-xp 00000000 08:01 131423     /lib/libz.so.
00544000-00545000 r--p 00012000 08:01 131423     /lib/libz.so.
00545000-00546000 rw-p 00013000 08:01 131423     /lib/libz.so.
00546000-00574000 r-xp 00000000 08:01 658548     /usr/lib/libfontconfig.so.1.4.4
00574000-00575000 r--p 0002d000 08:01 658548     /usr/lib/libfontconfig.so.1.4.4
00575000-00576000 rw-p 0002e000 08:01 658548     /usr/lib/libfontconfig.so.1.4.4
00576000-00579000 r-xp 00000000 08:01 656212     /usr/lib/libgthread-2.0.so.0.2600.1
00579000-0057a000 r--p 00003000 08:01 656212     /usr/lib/libgthread-2.0.so.0.2600.1
0057a000-0057b000 rw-p 00004000 08:01 656212     /usr/lib/libgthread-2.0.so.0.2600.1
0057b000-0057d000 r-xp 00000000 08:01 658282     /usr/lib/libXdamage.so.1.1.0
0057d000-0057e000 r--p 00001000 08:01 658282     /usr/lib/libXdamage.so.1.1.0
0057e000-0057f000 rw-p 00002000 08:01 658282     /usr/lib/libXdamage.so.1.1.0
00582000-005db000 r-xp 00000000 08:01 149090     /home/martin/opt/qcad_3_0_tp1/release/libQtSvg.so.4.7.3
005db000-005dd000 rw-p 00059000 08:01 149090     /home/martin/opt/qcad_3_0_tp1/release/libQtSvg.so.4.7.3
005dd000-005eb000 r-xp 00000000 08:01 658286     /usr/lib/libXext.so.6.4.0
005eb000-005ec000 r--p 0000d000 08:01 658286     /usr/lib/libXext.so.6.4.0
005ec000-005ed000 rw-p 0000e000 08:01 658286     /usr/lib/libXext.so.6.4.0
005ed000-005ef000 r-xp 00000000 08:01 658273     /usr/lib/libXau.so.6.0.0
005ef000-005f0000 r--p 00001000 08:01 658273     /usr/lib/libXau.so.6.0.0
005f0000-005f1000 rw-p 00002000 08:01 658273     /usr/lib/libXau.so.6.0.0
005f1000-0073b000 r-xp 00000000 08:01 149100     /home/martin/opt/qcad_3_0_tp1/release/libQtNetwork.so.4.7.3
0073b000-0073f000 rw-p 0014a000 08:01 149100     /home/martin/opt/qcad_3_0_tp1/release/libQtNetwork.so.4.7.3
0073f000-00746000 r-xp 00000000 08:01 135002     /lib/librt-2.12.1.so
00746000-00747000 r--p 00006000 08:01 135002     /lib/librt-2.12.1.so
00747000-00748000 rw-p 00007000 08:01 135002     /lib/librt-2.12.1.so
00748000-0076b000 r-xp 00000000 08:01 131378     /lib/libpng12.so.0.44.0
0076b000-0076c000 r--p 00022000 08:01 131378     /lib/libpng12.so.0.44.0
0076c000-0076d000 rw-p 00023000 08:01 131378     /lib/libpng12.so.0.44.0
0076d000-00774000 r-xp 00000000 08:01 658265     /usr/lib/libSM.so.6.0.1
00774000-00775000 r--p 00006000 08:01 658265     /usr/lib/libSM.so.6.0.1
00775000-00776000 rw-p 00007000 08:01 658265     /usr/lib/libSM.so.6.0.1
00776000-0078b000 r-xp 00000000 08:01 658244     /usr/lib/libICE.so.6.3.0
0078b000-0078c000 r--p 00014000 08:01 658244     /usr/lib/libICE.so.6.3.0
0078c000-0078d000 rw-p 00015000 08:01 658244     /usr/lib/libICE.so.6.3.0
0078d000-0078f000 rw-p 00000000 00:00 0 
0078f000-00791000 r-xp 00000000 08:01 666313     /usr/lib/gconv/UTF-16.so
00791000-00792000 r--p 00001000 08:01 666313     /usr/lib/gconv/UTF-16.so
00792000-00793000 rw-p 00002000 08:01 666313     /usr/lib/gconv/UTF-16.so
00793000-00852000 r-xp 00000000 08:01 152327     /home/martin/opt/qcad_3_0_tp1/release/libQtScriptTools.so.4.7.3
00852000-00857000 rw-p 000bf000 08:01 152327     /home/martin/opt/qcad_3_0_tp1/release/libQtScriptTools.so.4.7.3
00857000-008b2000 r-xp 00000000 08:01 149107     /home/martin/opt/qcad_3_0_tp1/release/libphonon.so.4.4.0
008b2000-008b4000 rw-p 0005b000 08:01 149107     /home/martin/opt/qcad_3_0_tp1/release/libphonon.so.4.4.0
008b4000-008b8000 r-xp 00000000 08:01 658288     /usr/lib/libXfixes.so.3.1.0
008b8000-008b9000 r--p 00003000 08:01 658288     /usr/lib/libXfixes.so.3.1.0
008b9000-008ba000 rw-p 00004000 08:01 658288     /usr/lib/libXfixes.so.3.1.0
008bb000-008bc000 r-xp 00000000 00:00 0          [vdso]
008bc000-00929000 r-xp 00000000 08:01 658235     /usr/lib/libGLU.so.1.3.070900
00929000-0092a000 ---p 0006d000 08:01 658235     /usr/lib/libGLU.so.1.3.070900
0092a000-0092b000 r--p 0006d000 08:01 658235     /usr/lib/libGLU.so.1.3.070900
0092b000-0092c000 rw-p 0006e000 08:01 658235     /usr/lib/libGLU.so.1.3.070900
0092c000-0099e000 r-xp 00000000 08:01 655834     /usr/lib/libfreetype.so.6.6.0
0099e000-009a2000 r--p 00071000 08:01 655834     /usr/lib/libfreetype.so.6.6.0
009a2000-009a3000 rw-p 00075000 08:01 655834     /usr/lib/libfreetype.so.6.6.0
009a3000-009a7000 r-xp 00000000 08:01 658324     /usr/lib/libXxf86vm.so.1.0.0
009a7000-009a8000 r--p 00003000 08:01 658324     /usr/lib/libXxf86vm.so.1.0.0
009a8000-009a9000 rw-p 00004000 08:01 658324     /usr/lib/libXxf86vm.so.1.0.0
009aa000-009f0000 r-xp 00000000 08:01 662734     /usr/lib/mesa/libGL.so.1.2
009f0000-009f1000 ---p 00046000 08:01 662734     /usr/lib/mesa/libGL.so.1.2
009f1000-009f6000 r--p 00046000 08:01 662734     /usr/lib/mesa/libGL.so.1.2
009f6000-009fb000 rwxp 0004b000 08:01 662734     /usr/lib/mesa/libGL.so.1.2
009fb000-009fd000 rwxp 00000000 00:00 0 
009fd000-00adc000 r-xp 00000000 08:01 659125     /usr/lib/libstdc++.so.6.0.14./qcad: line 2:  1970 Aborted                 release/qcad
 429 QCAD (main)Bug ReportLow Dotted/dashed lines show as solid lines. Closed
Task Description

The red and green lines on the attached drawing, created in 3.0 RC3 under WinXP SP3, don’t show as dashed lines. I have verified this under Linux version 3.0RC2. Opening the file in Qcad under WinXP or Linux ver shows dashed lines.

 1257 QCAD (main)Bug ReportLow Documentation Error for Angle Bisector (L, B) Closed
Task Description

Documentation for “Angle Bisector (L, B)” The labels for illustrations of number of bisectors are upside down and reversed.

 1314 dxflibBug ReportVery Low DL_Attributes::isInPaperSpace should be const Closed
Task Description

Only getter that’s missing it in dl_attributes.h

 1142 QCAD/CAMFeature RequestLow Distance Entry in "Feet and Inches" Closed
1 Task Description

I use architectural units everyday in QCAD and would appreciate being able to enter feet and inches from the “command line” for convenience and accuracy.

I have been entering “calculations” to arrive at the distance values (i.e. 10*12+6.125 = 10’-6 1/8”), but this method is time consuming and prone to input error.

I would like to see Acad’s architectural distance method implemented in QCAD. This entry method would replace the “calculated” entry with (as an example): 10’6-1/8.

Command Line: Next point: 10’6-1/8
The <’> mark triggers a 12 times multiplier for the proceeding number,
the next number is the whole inches and
the ↔ is a separator that adds the fraction to the whole inches before it.

Thanks for considering this feature request. I’m certain that many QCAD users in the Architectural, Mechanical, Electrical and Construction professions wold appreciate this convenience (especially those moving past Acad).

 252 QCAD (main)Bug ReportMedium Displayed line thickness too thick. Closed
Task Description

This manifestation happened after I had loaded an existing drawing, made modifications, then used print preview and adjusted the scale to fit the paper.

The file was closed. Upon reopening lines designated as .25mm were unusually thick such that two lines 2mm apart appeared as one solid line. Placing the cursor over the line showed it was comprised of two lines.

Changing the properties of a line to make it thinner did not help with one exception and that was to set the line thickness to default, when the two lines became visible.

 1065 QCAD (main)Bug ReportLow Display artifact with Ray/XLine Closed
Task Description

Git d0eaf0, Linux/FreeBSD, Qt 4.8

Start up QCAD, *do not pan or change zoom level*. Draw a Ray or an XLine so that it (its extension, in case of Ray) goes through (0,0) and is 45 degrees (ie. draw y = x).

In this case and this case only, the Ray/XLine will be reduced to a line segment exactly between its start- and end points. It seems that this is only a visual artifact: if you pan or zoom now, the segment will be restored to what it’s supposed to be.

If you change zoom/pan back to what it was at startup, the artifact re-manifests itself.

Some flashes indicate that there are some other positions, not just the initial view, that also bring this up (ie. if you pan to a specific position, artifact appears again; it’s probably deterministic, too, but I can’t seem to be able to stop at that exact point while panning so I could count or something).

 1565 QCAD (main)Bug ReportLow Disappearing blocks. Closed
Task Description

Blocks disappear (or their content does) after creating again with the same name. In attached file:

1) Created cirle
2) Select circle, BC, select center, name is ‘testblock’ 3) Repeat 2) – circle is now gone

 231 QCAD (main)Feature RequestLow Disable grid snap for auto snapping Closed
2 Task Description

Disable grid snap for auto snapping or otherwise configurable auto snap.

 942 QCAD (main)Feature RequestLow Dirty flag (star) in MDI tab invisible when too many ta ...Closed
Task Description

A window with a drawing that has unsafed changes gets an asterisk appended to its name in the tab title. When there too many tabs the title gets shortened and the star cannot be seen then.

It was nice, when the star remained visible, after or in front of the ellipses.

Also it was nice, when the “windows” menu would mark files with changes in the same way.

 1401 QCAD (main)Bug ReportLow Direct distance entry broken Closed
Task Description

See also:

 115 QCAD (main)Bug ReportLow DiningTable.js: segfault in RMathLineEdit::isValid() Closed
Task Description
  1. drag-n-drop script “DiningTable” to the drawing, place it somewhere
  2. right-click to finish the action
  3. drag-n-drop script “DiningTable” to the drawing again
Thread [1] 29561 (Suspended : Signal : SIGSEGV:Segmentation fault)	
	RMathLineEdit::isValid() at RMathLineEdit.h:44 0x8a011a9	
	REcmaMathLineEdit::isValid() at REcmaMathLineEdit.cpp:599 0x8a0021a	
	QScriptValue::call() at 0xb6bd2e67	
	REcmaShellActionAdapter::beginEvent() at REcmaShellActionAdapter.cpp:149 0x8bbd222	
	RDocumentInterface::setCurrentAction() at RDocumentInterface.cpp:287 0x8e0906a	
	RScriptHandlerEcma::createActionDocumentLevel() at RScriptHandlerEcma.cpp:780 0x876bd16	
	RGuiAction::slotTrigger() at RGuiAction.cpp:598 0x8e25bd7	
	RGuiAction::qt_metacall() at moc_RGuiAction.cpp:86 0x8e6ee19	
	QMetaObject::metacall() at 0xb5478c83	
	QMetaObject::metacall() at 0xb5478c83	
	QMetaObject::activate() at 0xb5489134	
	RGraphicsViewQt::drop() at moc_RGraphicsViewQt.cpp:107 0x8d34d2e	
	RGraphicsViewQt::dropEvent() at RGraphicsViewQt.cpp:997 0x8d28698	
	QWidget::event() at 0xb58daaf6	
	RGraphicsViewQt::event() at RGraphicsViewQt.cpp:808 0x8d27dec	
	QApplicationPrivate::notify_helper() at 0xb5871d7c	
	QApplication::notify() at 0xb58777e4	
	QCoreApplication::notifyInternal() at 0xb547215b	
	QCoreApplicationPrivate::sendThroughApplicationEventFilters() at 0xb54724ea	
	QApplicationPrivate::notify_helper() at 0xb5871cf3	
	QApplication::notify() at 0xb58772c4	
	QCoreApplication::notifyInternal() at 0xb547215b	
	QApplicationPrivate::sendMouseEvent() at 0xb5875152	
	QApplication::x11ProcessEvent() at 0xb5905d26	
	g_main_context_dispatch() at 0xb4af3509	
	g_main_context_iteration() at 0xb4af3fce	
	QEventDispatcherGlib::processEvents() at 0xb54a2741	
	QEventLoop::processEvents() at 0xb547131d	
	QEventLoop::exec() at 0xb54715aa	
	QDrag::exec() at 0xb5889fed	
	QDrag::exec() at 0xb588a084	
	qtscript_QDrag_prototype_call() at 0xafe620df	
	QScriptValue::call() at 0xb6bd2e67	
	REcmaShellListView::mouseMoveEvent() at REcmaShellListView.cpp:337 0x8c0bd06	
	QWidget::event() at 0xb58da661	
	QFrame::event() at 0xb5d0c663	
	QAbstractScrollArea::viewportEvent() at 0xb5dabe02	
	QAbstractItemView::viewportEvent() at 0xb5e65d65	
	QCoreApplicationPrivate::sendThroughObjectEventFilters() at 0xb54725a1	
	QApplicationPrivate::notify_helper() at 0xb5871d53	
	QApplication::notify() at 0xb58772c4	
	QCoreApplication::notifyInternal() at 0xb547215b	
	QApplicationPrivate::sendMouseEvent() at 0xb5875152	
	QApplication::x11ProcessEvent() at 0xb5905d26	
	g_main_context_dispatch() at 0xb4af3509	
	g_main_context_iteration() at 0xb4af3fce	
	QEventDispatcherGlib::processEvents() at 0xb54a2741	
	QEventLoop::processEvents() at 0xb547131d	
	QEventLoop::exec() at 0xb54715aa	
	QCoreApplication::exec() at 0xb5473701	
	qtscript_QCoreApplication_static_call() at 0xb0a9c4b7	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:683 0x876b4de	
	RScriptHandler::init() at RScriptHandler.cpp:31 0x8e512fe	
	main() at main.cpp:152 0x876585e	
 41 QCAD (main)Bug ReportMedium dimensions: tolerance shown twice after block insert Closed
Task Description
  • File “ExampleDrawings/data/dim_aligned.dwg”:
    • upper limit: 0.01, lower limit 0.02 → correctly shown
  • choose “Generate Example Drawings” → the element “aligned dimension” (with limits set) shows 0.010.01 now, since both label and tolerance limits are set (according to the property editor):
    • label: <>\S0.01^0.02;
    • upper limit: 0.01
  • same for lower limit
  • “Generate Example Drawings” inserts the drawings as blocks
 1484 QCAD (main)Feature RequestLow Dimensions: optionally use comma instead of dot Closed
1 Task Description

Use comma to display dimension labels.

 1116 QCAD (main)Bug ReportLow Dimensions: linear factor reset to drawing default Closed
Task Description

Linear factor of dimensions is reset to drawing default (DIMLFAC) if set to 1, even if drawing default is not 1 on saving.

 348 QCAD (main)Feature RequestLow Dimensions: Inch / Architectural: supporess 0 feet Closed
Task Description

Dimensions: Inch / Architectural: supporess 0 feet

 1677 QCAD (main)Bug ReportLow Dimension: Scale option grayed out in model space Closed
Task Description

... impossible to chose a scale in the DIM option bar.

 242 QCAD (main)Bug ReportLow Dimension: no feet displayed in architectural format Closed
Task Description

Dimension: no feet displayed in architectural format

(e.g. 79 19/32 instead 72 7 19/32)


 379 QCAD (main)Bug ReportLow Dimension: move label when label is beside dimension li ...Closed
Task Description

Dimension: moving label when label is beside dimension line not possible with drag and drop.

 1417 QCAD (main)Bug ReportVery Low Dimension: missing tolerance icons in options toolbar Closed
Task Description

e.g. Dimension > Horizontal: tolerance inputs should have an icon next to them.

 1416 QCAD (main)Bug ReportLow Dimension value for drawing unit feet Closed
Task Description

If the drawing unit is set to ‘feet’ and the dimension format is ‘architectural’ or ‘engineering’, the drawing unit should be implicitly regarded as inch for the purpose of calculating dimension values. Since QCAD uses the drawing unit, the dimension values are off by a factor of 12 when importing drawings from other products.

 1672 QCAD (main)Bug ReportLow Dimension tool displays wrong meassurement Closed
Task Description

Settings are:
General: Drawing Unit
Drawing Unit: Foot
Paper Unit: Inch
Measurement System: Imperial

Dimension Settings: Architectural


I draw a horizontal line 12 units (foot) long,
Use then the Horizontal DIM tool and it will display a measurement of 1’ = false,

I draw a horizontal line of 2 units (foot)long,
Use then the Horizontal DIM tool and it will display a measurement of 2” = false,

I assume the input for the line length is handled from the DIM tool as inch and not as feet.

Showing tasks 1401 - 1450 of 1763 Page 29 of 36<<First - 27 - 28 - 29 - 30 - 31 - Last >>

Available keyboard shortcuts


Task Details

Task Editing