Qt4 support in community edition after release version 3

Do you have a question you want to ask an existing QCAD user about QCAD and what you can do with it? Do you want to know if a particular feature exists? This is the place to ask.

Moderator: andrew

Qt4 support in community edition after release version 3

Postby nagmat84 » Fri Feb 11, 2011 12:34 pm

Currently Qt4 is only supported by the recent professional edition. The community edition is much older (still version 2.0) and based on Qt3. Therefore the available community edition is unusable on most Linux distros as most of them have switched to Qt4 a long time ago. (Even with Qt3 legacy support enabled within the Qt4 libraries, the community edition does not work, because the Qt3 legacy support lacks a lot of features of the real Qt3 library)

Are there any plans to publish a more up-to-date community edition (based on Qt4, for example QCad 2.2 or even 3.0) after the professional edition has moved on towards version 3?

Matthias
nagmat84
Registered Member
 
Posts: 1
Joined: Fri Feb 11, 2011 12:05 pm

Postby andrew » Fri Feb 11, 2011 1:13 pm

We haven't decided about the future of the QCAD Community Edition yet.
User avatar
andrew
Site Admin
 
Posts: 2600
Joined: Fri Mar 30, 2007 6:07 am


Return to Pre-sales Questions

Who is online

Users browsing this forum: No registered users and 1 guest