QCAD Plugins: Using different compiler / Qt version

Discussion forum for contributors and developers who are using the QCAD version 3 ECMAScript development platform or the C++ plugin interface or who are otherwise looking to contribute to QCAD (translations, documentation, etc).

Moderator: andrew

QCAD Plugins: Using different compiler / Qt version

Postby andrew » Mon May 19, 2014 9:30 am

From a QCAD user:
Do we need to build our C++ plugins using the same version of QT and compiler (mvc10 in this case) as you built qcad with?
User avatar
andrew
Site Admin
 
Posts: 2586
Joined: Fri Mar 30, 2007 6:07 am

Re: QCAD Plugins: Using different compiler / Qt version

Postby andrew » Mon May 19, 2014 9:33 am

You can find some information about mixing Qt versions at:
http://qt-project.org/doc/qt-4.8/deploy ... ugins.html

MinGW has some information about mixing compilers:
http://www.mingw.org/wiki/MSVC_and_MinGW_DLLs

Using the same compiler and Qt version is certainly the preferred option if you have a choice.
User avatar
andrew
Site Admin
 
Posts: 2586
Joined: Fri Mar 30, 2007 6:07 am

Re: QCAD Plugins: Using different compiler / Qt version

Postby andrew » Wed Aug 27, 2014 9:32 am

Note: I've split your last post about making classes scriptable into a new thread at:
viewtopic.php?f=30&t=3022
User avatar
andrew
Site Admin
 
Posts: 2586
Joined: Fri Mar 30, 2007 6:07 am


Return to QCAD 3 Developers and Contributors

Who is online

Users browsing this forum: No registered users and 2 guests