Empty file after editing a drawing

If you are having problems with QCAD version 3, post here. Please report bugs here.

Moderator: andrew

Empty file after editing a drawing

Postby J-J » Thu Mar 08, 2012 11:13 pm

I was editing, "cleaning" an old drawing, removing unused blocks and empty layers, but when I wanted to save the work I got a warning "null object ID" and my file was lost (0 kb), there was no way to save it, the only way to exit the loop is to discard changes on closing. I have had this problem before with previous releases...
User avatar
J-J
Moderator
 
Posts: 173
Joined: Tue Mar 24, 2009 9:48 pm

Postby andrew » Fri Mar 09, 2012 8:57 am

Most likely, it has nothing to do with the cleaning up but with something in the original file that was loaded. I.e. QCAD 3 would not have been able to save the original file directly after loading either.

I was finally able to get a hold of a file with that problem. If you do have another such original file that can be used to reproduce the problem, I would highly appreciate if you could send it to me via e-mail. Thanks.


PS: For the time being, please use "Save As.." instead of "Save" and always choose a new name.

Good practice for file management of a project called "MyProject" (applies for any software):
- Create directory "MyProject"
- Copy / create your file in that directory, e.g. "MyDocument000"
- After every significant change, save as new number, e.g. "MyDocument001", "MyDocument002", ...

This protects you not only from software malfunctions but also provides a persistent undo and a history of the file in case a wrong decision s made at one point or something is deleted and then later needed again, etc.

Alternatively, a version control system can be used of course.
User avatar
andrew
Site Admin
 
Posts: 2527
Joined: Fri Mar 30, 2007 6:07 am

load and save problem

Postby J-J » Fri Mar 09, 2012 11:04 am

You are right, I had a backup of the original file created with ver 2.2.2.0 and trying "load" and "save as" without any changes to the drawing, produces the same error message. I am mailing the file "14mx_112s_68-6219.dxf", as it is before cleaning up. Thanks for your help.
User avatar
J-J
Moderator
 
Posts: 173
Joined: Tue Mar 24, 2009 9:48 pm


Return to QCAD 3 Troubleshooting and Problems

Who is online

Users browsing this forum: No registered users and 2 guests