Draw Hatch

Use this forum to ask questions about how to do things in QCAD 2.1/2.2.

Moderator: andrew

Draw Hatch

Postby RayArdia » Sun Jan 31, 2010 10:54 am

Using QCAD Prof 2.2.2.0-1 on Ubuntu 9.04 Jaunty. Hatch patterns located in /home/usr/qcad-2.2.2.0-1-prof.linux.x86/library/patterns. When I navigate to any pattern eg 'sand' the selection displays as QAD - [sand.dxf].
When I try to insert a hatch into a properly 'closed' area eg a rectangle or a circle I follow the sequence from the manual:-
...
Launch the hatching action.
Select the contour(s) you want to fill. Note that islands inside contours will get hatched if they are not selected (Figure 46) ...

Problem Once 'Draw-Hatch is selected it isn't possible to select the contours I am forced to close the Hatch window and then do the selection. Is the Manual wrong or am I just being stupid?
...
Click the right arrow button in the CAD toolbar to continue.
Problem No 'right arrow'.
...
A dialog for the hatch options is displayed (Figure 47). Choose a hatch pattern, scale factor and a rotation angle for the hatch pattern. If you want to fill the object with a solid color instead of a pattern, check the checkbox "Solid Fill".
Click 'OK' to proceed
When the Hatch dialog appears (whether before or after selecting the required contour) I can select 'Solid Fill',( though my choice of solid fill colour is White only), and can solid fill the selection by clicking OK.
However when I try to use a hatch pattern (solid fill unselected) the selection menu won't do anything except turn the hatch selection box blue.
No Preview appears and no hatch pattern appears on my drawing.
I have checked Edit-Application Preferences-Paths and the path above is there.
Despite reading every post which mentions 'hatch problems', and the relevant Manual pages many times I am still completely baffled! I know I must be doing something wrong but can't fathom just what that 'something' is.
Help please!
RayArdia
Full Member
 
Posts: 70
Joined: Mon Aug 11, 2008 6:57 pm
Location: NW Spain

Re: Draw Hatch

Postby andrew » Sun Jan 31, 2010 11:32 am

RayArdia wrote:Using QCAD Prof 2.2.2.0-1 on Ubuntu 9.04 Jaunty. Hatch patterns located in /home/usr/qcad-2.2.2.0-1-prof.linux.x86/library/patterns.


Most likely you mean /home/usr/qcad-2.2.2.0-1-prof.linux.x86/patterns, that's where all hatch patterns should be installed.

Try selecting the contour first, then choose "Draw - Hatch".

RayArdia wrote:When the Hatch dialog appears (whether before or after selecting the required contour) I can select 'Solid Fill',( though my choice of solid fill colour is White only),


The color of the solid fill is the current pen color. This can be any color, by default it is the color of the current layer. To create a green solid fill, create a layer with color green, make sure the layer is active and then create the hatch.

RayArdia wrote:and can solid fill the selection by clicking OK.
However when I try to use a hatch pattern (solid fill unselected) the selection menu won't do anything except turn the hatch selection box blue.
No Preview appears and no hatch pattern appears on my drawing.


Most likely you have (accidentally?) activated draft mode. Draft mode is a faster display mode that does not show hatch patterns and simplifies other complex entities. To disable draft mode, choose menu "View" - "Draft" again.

See also FAQ at:
http://www.ribbonsoft.com/qcad_doc_faq.html#10
User avatar
andrew
Site Admin
 
Posts: 2544
Joined: Fri Mar 30, 2007 6:07 am

Re: Draw Hatch

Postby RayArdia » Sun Jan 31, 2010 2:50 pm

andrew wrote:
RayArdia wrote:Using QCAD Prof 2.2.2.0-1 on Ubuntu 9.04 Jaunty. Hatch patterns located in /home/usr/qcad-2.2.2.0-1-prof.linux.x86/library/patterns.


Most likely you mean /home/usr/qcad-2.2.2.0-1-prof.linux.x86/patterns, that's where all hatch patterns should be installed.
That was the problem! Patterns, Part Library, Misc and Templates were all sub-directories of Library. Now corrected
Try selecting the contour first, then choose "Draw - Hatch".
That's the only way I can do it. Why does the Manual say that you do it the other way round?
RayArdia wrote:When the Hatch dialog appears (whether before or after selecting the required contour) I can select 'Solid Fill',( though my choice of solid fill colour is White only),


The color of the solid fill is the current pen color. This can be any color, by default it is the color of the current layer. To create a green solid fill, create a layer with color green, make sure the layer is active and then create the hatch.
Now understood, thanks.
RayArdia wrote:

Most likely you have (accidentally?) activated draft mode. Draft mode is a faster display mode that does not show hatch patterns and simplifies other complex entities. To disable draft mode, choose menu "View" - "Draft" again.
No, checked that, wasn't in Draft mode.
See also FAQ at:
http://www.ribbonsoft.com/qcad_doc_faq.html#10


All now seems OK Solved! Many thanks
RayArdia
Full Member
 
Posts: 70
Joined: Mon Aug 11, 2008 6:57 pm
Location: NW Spain


Return to QCAD 2.1/2.2 'How Do I' Questions

Who is online

Users browsing this forum: No registered users and 1 guest

cron