(RESOLVED) Installation in Ubuntu 8.10

Use this forum to ask questions about how to do things in the QCAD Community Edition.

Moderator: andrew

(RESOLVED) Installation in Ubuntu 8.10

Postby K31TH » Tue Apr 28, 2009 9:48 am

I've used the Add/Remove Applications function to install Qcad but it did not run when clicking on the desktop icon.

In Terminal if I cd /usr/bin and ./qcad it complained about a missing library...

libqtlibqt-mt.so.3

Then I discovered the ldd command so typing ldd qcad gives me

keith@keith-desktop:/usr/bin$ ldd qcad
linux-gate.so.1 => (0xb80d2000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb807b000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb805b000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb8034000)
libz.so.1 => /usr/lib/libz.so.1 (0xb801e000)
libSM.so.6 => /usr/lib/libSM.so.6 (0xb8015000)
libICE.so.6 => /usr/lib/libICE.so.6 (0xb7ffd000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7ff9000)
libqt-mt.so.3 => not found
libXext.so.6 => /usr/lib/libXext.so.6 (0xb75f4000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb7505000)
libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb74ec000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb73fe000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb73d8000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb73c9000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb726a000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb71f4000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb71cd000)
/lib/ld-linux.so.2 (0xb80b8000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb71c3000)
libstdc++-libc6.2-2.so.3 => not found
libXau.so.6 => /usr/lib/libXau.so.6 (0xb7176000)
libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb7173000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb715a000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7155000)

I'm sure I should not really do this sort of thing but I end up getting hold of what 'might' be the missing libraries by downloading bits of cruft from the internet. Having got them I put them in /usr/lib and now when I type ldd qcad I get...

keith@keith-desktop:/usr/bin$ ldd qcad
linux-gate.so.1 => (0xb80d2000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb807b000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb805b000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb8034000)
libz.so.1 => /usr/lib/libz.so.1 (0xb801e000)
libSM.so.6 => /usr/lib/libSM.so.6 (0xb8015000)
libICE.so.6 => /usr/lib/libICE.so.6 (0xb7ffd000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7ff9000)
libqt-mt.so.3 => /usr/lib/libqt-mt.so.3 (0xb7604000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb75f4000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb7505000)
libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb74ec000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb73fe000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb73d8000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb73c9000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb726a000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb71f4000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb71cd000)
/lib/ld-linux.so.2 (0xb80b8000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb71c3000)
libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0xb717a000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb7176000)
libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb7173000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb715a000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7155000)

I wouldn't be sure how 'robust' that report is in terms of indicating that I have put the right things in?

Anyway, now when I type ./qcad [or sudo ./qcad] I get

keith@keith-desktop:/usr/bin$ ./qcad
./qcad: symbol lookup error: ./qcad: undefined symbol: _ZN7QString4nullE
keith@keith-desktop:/usr/bin$

Is this still due to having possibly incorrect library files or have I moved one step closer to getting the program up and running. If so, or otherwise, what should I try next.

If it is of any assistance then...

keith@keith-desktop:/usr/bin$ file ./qcad
./qcad: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.8, dynamically linked (uses shared libs), stripped

keith@keith-desktop:/usr/bin$ uname -a
Linux keith-desktop 2.6.27-11-generic #1 SMP Wed Apr 1 20:57:48 UTC 2009 i686 GNU/Linux

If you need more information then please ask.

Thanks
K31TH
Registered Member
 
Posts: 2
Joined: Tue Apr 28, 2009 9:28 am

Fixed......

Postby K31TH » Tue Apr 28, 2009 7:03 pm

I went and deleted the two lib files I had ripped off from the web and did a 'proper' search for an rpm containing libqt-mt.so.3 Then I downloaded the package into Ubuntus Archive manager and hunted through it, they lived under usr/lib and came as a couple of symbolic links and the lib file itself. I extracted them to a temporary directory and then moved them into /usr/lib and changed permissions to root

lrwxrwxrwx 1 root root 17 2009-04-28 18:43 libqt-mt.so.3 -> libqt-mt.so.3.3.8
lrwxrwxrwx 1 root root 17 2009-04-28 18:43 libqt-mt.so.3.3 -> libqt-mt.so.3.3.8
-rwxr-xr-x 1 root root 8709732 2009-04-28 18:43 libqt-mt.so.3.3.8

My previous libqt-mt.so.3 actually came from somewhere that said 'use this but rename it to.... libqt-mt.so.3' That was 11MB big. Yes, I know... I'm some sort of stupid.

Before I went on a hunt for libstdc++-libc6.2-2.so.3 I tried an ldd ./qcad and got

keith@keith-desktop:/usr/bin$ ldd ./qcad
linux-gate.so.1 => (0xb807e000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb8027000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb8007000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb7fe0000)
libz.so.1 => /usr/lib/libz.so.1 (0xb7fca000)
libSM.so.6 => /usr/lib/libSM.so.6 (0xb7fc1000)
libICE.so.6 => /usr/lib/libICE.so.6 (0xb7fa9000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7fa5000)
libqt-mt.so.3 => /usr/lib/libqt-mt.so.3 (0xb7752000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb7742000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb7653000)
libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb763a000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb754c000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7526000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7517000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb73b8000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7342000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb731b000)
/lib/ld-linux.so.2 (0xb8064000)
libmng.so.1 => /usr/lib/libmng.so.1 (0xb72ad000)
libXi.so.6 => /usr/lib/libXi.so.6 (0xb72a3000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb7298000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb7291000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb7288000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb7285000)
libXft.so.2 => /usr/lib/libXft.so.2 (0xb7271000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb726d000)
libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb726a000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb7251000)
liblcms.so.1 => /usr/lib/liblcms.so.1 (0xb721c000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb7217000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7211000)

Which did not complain about libstdc++-libc6.2-2.so.3 being not there. So I tried ./qcad and the program comes up. It also works from the desktop so.... Problem Solved

Thanks
K31TH
Registered Member
 
Posts: 2
Joined: Tue Apr 28, 2009 9:28 am


Return to QCAD Community 'How Do I' Questions

Who is online

Users browsing this forum: No registered users and 0 guests