Qcad 2.2.1 pro qcadscripting module build problem

Post your question about installing or upgrading to QCAD 2.1/2.2. Be sure to search, and check the docs before you post!

Moderator: andrew

Qcad 2.2.1 pro qcadscripting module build problem

Postby ckomurlu » Mon Jun 29, 2009 12:04 pm

Hi,
I'm trying to build QCAD 2.2.1's qcadscripting module. I do qmake with no problem. Then at make command, I get the error report given below:
Code: Select all
In file included from src/qsa/qs_scripter.cpp:25:
src/qsa/qs_scripter.h:29:27: error: qsinterpreter.h: No such file or directory
src/qsa/qs_scripter.h:30:29: error: qsobjectfactory.h: No such file or directory
src/qsa/qs_scripter.h:31:34: error: qsinputdialogfactory.h: No such file or directory
src/qsa/qs_scripter.h:32:27: error: qsutilfactory.h: No such file or directory
src/qsa/qs_scripter.h:33:23: error: qsproject.h: No such file or directory
src/qsa/qs_scripter.h:34:25: error: qsworkbench.h: No such file or directory
In file included from src/qsa/qs_scripter.cpp:25:


I've checked Qt library which I've used in Qcad build, I couldn't find qsinterpreter.h.
I'd built Qt 4.4.3 statically, on Ubuntu 9.04.
I have built other qcad modules with no problem, and run Qcad.

Any suggestion?

Best regards,
Caner Kömürlü
R&D Office
Bilko Co.
ckomurlu
Junior Member
 
Posts: 11
Joined: Thu May 07, 2009 12:27 pm

Postby andrew » Mon Jun 29, 2009 2:15 pm

The QCAD Scripting module requires QSA (Qt Script for Applications) from TrollTech (Nokia).

Note that QSA is being replaced with QtScript starting with Qt 4.5 / QCAD 3. Please contact TrollTech / Nokia to find out how to get hold of QSA is that is still possible. Note that you can also compile the QCAD Libraries and QCAD without QSA.
User avatar
andrew
Site Admin
 
Posts: 2745
Joined: Fri Mar 30, 2007 6:07 am

Postby janif » Tue Jun 30, 2009 9:16 am

andrew wrote:Note that QSA is being replaced with QtScript starting with Qt 4.5 / QCAD 3.


May I ask why yet another scripting system? Why not a lisp interpreter prefereably compatible with a (the?) major cad vendor?
janif
Junior Member
 
Posts: 23
Joined: Sat Jan 19, 2008 7:28 pm

Postby andrew » Tue Jun 30, 2009 11:08 am

janif: Please note that QCAD was never intended to be a clone of any other CAD application. We aim to offer a CAD solution that works also for people who are not used to autocad.

The decision to use QtScript as main scripting solution for QCAD was based on a couple of things:

- QtScript (read ECMAScript/JavaScript) is far more popular among the average computer user than Lisp, Lua or most other script languages.
- QCAD is based on Qt and QtScript obviously has excellent Qt support
- Personally, I'd consider "var a=1; a=a+2;" more readable and intuitive than "(setq a 1) (+ a 2)", but this might be a question of personal taste, what I'm used to and how my brain works.

Having said that, QCAD 3 is designed in a way that allows multiple script engines to be present and Lisp support is not at all impossible at one point in the future.
User avatar
andrew
Site Admin
 
Posts: 2745
Joined: Fri Mar 30, 2007 6:07 am

Postby ckomurlu » Tue Jun 30, 2009 11:52 am

Hi,
I have downloaded QSA from trolltech. By the way, I really can't figure out why it's excluded from the whole package.
I have built it and obtained a lib file copied in lib/ directory of all other Qt libs inside Qt home directory.
I retried to built qcadscripting module. It was OK, I obtained libqcadscripting.a
Well, I have rebuilt all qcad modules, and run ./qcad. Nevertheless, I cannot see Scripts menu in the menu bar, which is supposed to be there like it is in the qcad 2.2.2-1 demo version.

I've been looking for an option or a parameter in Makefile of qcad, or build_qcad.sh. What do I forget?

Best regards,
Caner Kömürlü
R&D Office
Bilko Co.
ckomurlu
Junior Member
 
Posts: 11
Joined: Thu May 07, 2009 12:27 pm

Postby andrew » Tue Jun 30, 2009 7:16 pm

Have a look at mkspecs/defs.pro

Make sure that:
CONFIG += rs_scripting
is not commented out.
User avatar
andrew
Site Admin
 
Posts: 2745
Joined: Fri Mar 30, 2007 6:07 am


Return to QCAD 2.1/2.2 Installation and Upgrades

Who is online

Users browsing this forum: No registered users and 0 guests