Strange behavior during hatching

If you are having problems with QCAD 2.1/2.2, post here. Please report bugs here.

Moderator: andrew

Strange behavior during hatching

Postby J-J » Thu Dec 02, 2010 9:31 pm

Hello,
I created a hatch area using the method described in the manual, i.e. copying the contour to a specific layer...The hatching parameters are scale:1, angle 180.
I do obtain hatches, but curiously three hatch lines cross the boundary. I get the same effect if I change the hatch direction to 90. However, if I specify a direction off by 1 degree (89 or 179), then the whole hatch area is correct. I also tried moving sligtly the hatching contour off from its position, hatching comes out correct then, even at directions 90 and 180. Any clues?
JJ
User avatar
J-J
Moderator
 
Posts: 167
Joined: Tue Mar 24, 2009 9:48 pm

Postby klavs » Sat Dec 04, 2010 6:22 am

I don't recognize such problems.My hatches align up perfectly.

I create a new layer (called hatches or something) and mark that.
I then trace (using 2point line) the lines I want to hatch - so I have a closed "box".

I disable all layers- except the hatch layer - and verify I have the complete, closed box - with no lines being too long or short.

Then it works perfectly.

You could publish your dxf file - then perhaps someone could have a look and see (if you have your hatch lines on a seperate layer it's easier to spot.
klavs
Junior Member
 
Posts: 20
Joined: Tue Nov 30, 2010 5:36 pm

Postby J-J » Sat Dec 04, 2010 11:43 am

Thanks for the reply. I do exactly the same as far as layer organization and generally it works. In fact, if my boundary had not been right, hatching would not have worked at all. It's just that on this occurrence, I have a couple lines that cross the boundary. I believe it is not possible to add an image on the forum, so I don't know where I could publish the view.
User avatar
J-J
Moderator
 
Posts: 167
Joined: Tue Mar 24, 2009 9:48 pm


Return to QCAD 2.1/2.2 Troubleshooting and Problems

Who is online

Users browsing this forum: No registered users and 2 guests