2.2.2 on Slackware 64 bit. What to do?

Post your question about installing or upgrading to QCAD 2.1/2.2. Be sure to search, and check the docs before you post!

Moderator: andrew

2.2.2 on Slackware 64 bit. What to do?

Postby catkin » Mon Jun 27, 2011 5:36 pm

Hello :)

I tried the community edition and liked it so much I bought 2.2.2 but it is a 32 bit app so will not run. That leaves a few options and I would like advice on the pros and cons.
  • Install Alien Bob's multilib so the 32 bit QCad will run. I am reluctant to go through this non-trivial exercise because I don't need to run any other 32 bit apps.
  • Get the 2.2.2 source (how?) and compile 2.2.2 as a 64 bit app. A road seldom (ever?) travelled so likely troublesome. Both QT3 and QT4 are installed so the build could be with either. Most of the online pages about building QCad are about building with QT4; they don't inspire much confidence of success but at least there is some info available.
  • Download QCad 3TP and hope for the best. Is it a 64 bit package anyway? I'm a new naive user with simple drawing intentions so a TP might be good enough.
  • Switch to LibreCAD (am I allowed to mention that here?). The build instructions are only for Ubuntu and Debian so that would be another lonely untravelled road.

Best

Charles
catkin
Newbie Member
 
Posts: 3
Joined: Mon Jun 27, 2011 5:13 pm

Postby andrew » Mon Jun 27, 2011 6:27 pm

Most decent Linux distributions have one or more compatibility package(s) you can install to run 32bit apps.

E.g. ia32-libs, ia32-libs-gtk, ...
Not sure if Slackware has something like that, but worth a try.

QCAD Professional 2.2.2 sources are not available.

QCAD 3 TP1 is not yet usable or complete (hence 'technology preview').

We've had some disappointing results with QCAD 3 64bit (see http://www.ribbonsoft.com/qcad3.html), so if you plan on using QCAD and don't absolutely need 64bit, I'd recommend to go with a 32bit Linux distribution.

Projects like Librecad (QCAD forks) pop up every now and then and usually disappear again once the person behind it has no longer the time to keep it up.
User avatar
andrew
Site Admin
 
Posts: 2370
Joined: Fri Mar 30, 2007 6:07 am

Postby catkin » Mon Jun 27, 2011 6:48 pm

Thanks Andrew :-)

That helps reduce the options.

Slackware64 has the compatibility libs installation procedure linked in the OP.

Best

Charles
catkin
Newbie Member
 
Posts: 3
Joined: Mon Jun 27, 2011 5:13 pm

Postby catkin » Tue Jun 28, 2011 9:33 am

The chosen solution was none of the above; it was to run QCad in a VirtualBox virtual machine running Ubuntu 8.04 32 bit.
catkin
Newbie Member
 
Posts: 3
Joined: Mon Jun 27, 2011 5:13 pm


Return to QCAD 2.1/2.2 Installation and Upgrades

Who is online

Users browsing this forum: No registered users and 1 guest