Flyspray:: Flyspray::QCAD Bugtracker: Recently opened tasks https://www.qcad.org/bugtracker/ 2019-07-17T10:37:57Z FS#1920: Edit > Application Preferences: Add preference to disable dark mode 2019-07-17T10:37:57Z 2019-07-17T10:37:57Z

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=89&t=6447

Andrew https://www.qcad.org/bugtracker/:1920
FS#1919: Wrong order XY(Z) for Ordinate Dimension in property editor 2019-07-09T11:51:22Z 2019-07-09T11:51:22Z

Win7pro Qcad Pro 3.22.1.2

In property editor
properties of an Ordinate Dimension

Without Show Z
DefPoint is displayed in order YX?

With Show Z
Origin is displayed in order XZY?
DefPoint is displayed in order YZX?
LeaderEndPoint is displayed in order ZXY?

Regards

CVH https://www.qcad.org/bugtracker/:1919
FS#1918: Splines whit control points of order 1 and 4 not selected with partially selecting cursor R>L draw 2019-07-06T19:41:18Z 2019-07-06T13:31:55Z

Set up a spline with control points let’s say of the order 3.
Clone it 3 times with some offset in x&y.
Edit the degree property and set 1ste to 1, 2nd to 2, aso
Draw select partially from right to left.
Those of the order 1 and 4 aren’t selected.

Regards

CVH https://www.qcad.org/bugtracker/:1918
FS#1917: Automatic labels with static information of the drawing 2019-07-05T10:23:20Z 2019-07-05T10:23:20Z

I would like static information of the drawing (like scale, creation-date, modified-date, revision etc) to be available as automatic labels to be placed in the drawing (with selectable style, font etc)

This would greatly simplify the creatin of title sections in the drawing and making sure it is consistent with the actual drawing and not requiring manual “synchronization”.

Johan Persson https://www.qcad.org/bugtracker/:1917
FS#1916: Moving an object in an angled viewport with mouse does not compensate for angle 2019-07-05T10:15:43Z 2019-07-05T10:12:03Z

To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport to 90 degrees
4. Place view-port in paper space
5. Select the view-port in paper-space by clicking it
6. Try to move the object itself in the view-port (by clicking the “top” dot) to the right by moving the mouse to the right while holding the left mouse-button.

Actual

The object in the viewport moves down vertically NOT to the right

Expected

The object moves to the right

(It seems mouse movement does not compensate for the rotated angle of the viewport)

Workaround

None, except compensate for the angle in your head and moving the mouse the “wrong” way when correcting the placement of objects in the view-port

Johan Persson https://www.qcad.org/bugtracker/:1916
FS#1915: Viewport does not rotate view-port when changed in paper space 2019-07-05T10:28:04Z 2019-07-05T09:52:58Z

To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport.

Actual

The object in the viewport changes but the viewport itself remains unchanged

Expected

That both the view-port and the object changes angle as the angle is updated

Motivation

If you abort the placement (but keep the angle) and go back to model-space and then redo the operation the view-port is rotated along the angle. It seems that the viewport only picks up the initial angle once the paper-space is open and ignores any changes thereafter

Workaround

1. Select the view-port per normal in model-space
2. Open the paper-space and set the wanted angle but do not place the view-port in paper space
3. Abort the placement on paper-space and redo the whole operation

Once the paper space is opened again the view-port will have the chosen angle

Johan Persson https://www.qcad.org/bugtracker/:1915
FS#1914: CAM layer On/Off 2019-07-04T14:31:40Z 2019-07-03T17:11:10Z

Hallo Andrew

If CAM layer invisible do not 3D Simulate and do not write G-code.

H. Stiekema https://www.qcad.org/bugtracker/:1914
FS#1913: 3D Simulation Behaves odd 2019-07-02T17:48:49Z 2019-07-02T17:48:49Z

Hallo Andrew,

testing the drill toolpath I used single point markers.

In 3D simulation the tool drills the toolpath AND uses the drill as a mill.

Cam Export and generated G-code is not effected.

H. Stiekema https://www.qcad.org/bugtracker/:1913
FS#1912: Tool Description Error 2019-07-04T14:32:45Z 2019-07-02T17:45:27Z

Hallo Andrew,

Testing the drill toolpath I find it hard to select the correct tool by a small bug

H. Stiekema https://www.qcad.org/bugtracker/:1912
FS#1911: Drill Toolpath 2019-07-04T14:30:51Z 2019-07-02T13:29:23Z

Hallo Andrew

It would be more than conveniant, defining the drilling locations of the drill toolpath, by selecting a circle’s center point.

H. Stiekema https://www.qcad.org/bugtracker/:1911