Flyspray:: Flyspray::QCAD Bugtracker: Recently closed tasks https://www.qcad.org/bugtracker/ 2020-06-26T06:31:50Z FS#2094: Leader and Datum - Tool tip for "Undo Last Segment" 2020-06-26T06:31:50Z 2020-06-26T05:08:11Z

Tools: Leader and Datum
Tool tip for “Undo Last Segment” - Segment instead of Segement

Husky https://www.qcad.org/bugtracker/:2094
FS#2093: Datum tool, option bar, missing icon for "Undo Last Segment" 2020-06-26T06:30:37Z 2020-06-26T04:51:04Z
Husky https://www.qcad.org/bugtracker/:2093
FS#2090: Snap > Auto Snap: intersections of pattern with other entities with cursor close to boundary 2020-06-18T07:39:02Z 2020-06-18T06:54:51Z

- Create hatch with pattern “ANSI31” (or other).
- Move cursor along boundary with auto snap
- Auto snap finds intersections between hatch pattern and boundary or other entities close to the hatch boundary

Andrew https://www.qcad.org/bugtracker/:2090
FS#2089: Property Editor: Linetype Scale and Draw Order wrongly marked with inch symbol 2020-06-17T06:48:42Z 2020-06-16T22:00:50Z

Case:

Drawing unit = inch,

Dimension Label Format set to Engineering or Architectural,

Husky https://www.qcad.org/bugtracker/:2089
FS#2086: Font formatting in text dialog 2020-06-11T08:38:24Z 2020-06-11T06:29:12Z

QCadPro (snapshot, but can be reproduced with 3.24.3 as well)

OS: MacOS 10.14.6
Version: 3.24.3.8 (3.24.3.8)
Build Date: Jun 3 2020
Revision: 828df3a
Qt Version: 5.13.2
Architecture: x86_64
Compiler: Clang 10.0.0

To reproduce:
1. Add some text to a drawing
2. Double click on the text to open the text-edit dialogue
3. Select all text, change font, press OK

Expected behavior: The font has been updated

Actual behavior: The font seems to visually change in the edit box but as soon as you press OK to close the dialogue the text on the drawing is not changed. Viewing the text with the font information (via properties) it can be seen that the embedded font information has not been updated.

Workaround:
- Select text and edit the properties

Johan Persson https://www.qcad.org/bugtracker/:2086
FS#2085: Drag and drop: moving single polyline vertex moves also polyline segment 2020-06-09T11:05:35Z 2020-06-09T10:44:09Z

See the steps to reproduce in the attached drawing.

reint kamp https://www.qcad.org/bugtracker/:2085
FS#2084: File > Save: Fixed extension line length of dimensions not saved if scale != 1 2020-06-08T09:01:51Z 2020-06-08T09:01:24Z

Create dimension with fixed extension line length.
Set scale to 2.
Save / Load or Reload.

→ Extension line length no longer fixed.

Andrew https://www.qcad.org/bugtracker/:2084
FS#2083: Viewport: Fixed extension line length of dimensions not scaled with viewport 2020-06-08T08:59:29Z 2020-06-08T08:58:29Z

See:
https://qcad.org/rsforum/viewtopic.php?f=89&t=7313

Andrew https://www.qcad.org/bugtracker/:2083
FS#2031: Ordinate Dimensions don't act as expected 2020-06-03T08:12:26Z 2020-01-21T03:45:32Z

Hi Andrew

I wasn’t sure if this was a bug or feature request, when I’m drawing part sets that only change in lengths I dimension them
to save time then I stretch and save as whatever filename... I was surprised when Qcad reacted the way it did when stretching ordinate
dimensions on a part, the 1st thing I did was window select over the dimensions which didn’t work ( this is the typical way for
stretching ordinate dimensions in AutoCAD,IntelliCad,Draftsight etc )... anyway Husky and I had a fairly long debate and he told me
I had to select the object and only parts of the ordinate dimensions which when stretched leaves a bit of tidying up to do..
Please let me know if I’m going about this the wrong way.. do i really have to do multiple stretches and move all the jogged dimensions?

See Topic https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6901&start=15 It started off with negative values for ordinate dimensions then turned into problems stretching ordinate dimensions..
I also posted dropbox links to quite a few videos..

Attached is a zip file containing some screenshots plus the original dxf file..

Best Regards
John Hyslop

John Hyslop https://www.qcad.org/bugtracker/:2031
FS#2047: QCAD quits when inserting a library item, Ubuntu 19.10 or Windows 10, but not on all computers! 2020-06-03T08:11:50Z 2020-02-16T18:14:42Z

Description:
QCAD quits when trying to insert a library item (PC_1kW.dxf) from the library browser. Both by dragging it or clicking on insert.
Joined a copy of the terminal and dmesg (Linux) and what I found on the windows logs.

- Tested with other libraries elements of the same origin with the same result.
- The file opens normally in QCAD. When you create a block from it, you can re-insert it and it works as expected, try with PC_1kWblock.dxf...
- If you re-create a library item from the file with another name it fails also to insert.
- Tested with a new empty file or with a file containing same blocks...

Now the strange part:

-On a brand new HP Zbook 14u G6 it works flawlessly on Windows but fails on Linux... That was the first computer I tried (with Windows) when I decided that it will replace Draftsight... I was lucky...
-On a 4 years old Lenovo Yoga 14 it fails both on Linux & Windows... This computer has only 8Gb of RAM, but dedicated graphics...
-On a customer’s HP Pavillon 17’’ it fails... He bought a licence & Book of QCAD because of me...
-On my Dell 7720 it fails both on Windows and Linux. This workstation has everything to run any CAD software (64Gb RAM, Xeon 1535M v6, Quadro P5000)
-Reinstallation of the software doesn’t solve the problem. 2 independent sources tested (my download and my customer’s download)

These blocks have a lot of attributes on different layers, needed for the intended usage. I’m developping a script to extract them to a CSV file based on a template file... As on Draftsight.

Looks a lot like  FS#1938 ... But now you have files to test...

I made further testings and this bug is definitely related to the fact that the attributes definitions are on different layers...

If the layer definition exists before the library items is inserted, it works as expected.

If one layer existing in the item definition is missing from the layer list before the item is inserted it fails.

If you create a block from an instance of the library item, and create a new library item with the block, then it can be inserted without problems and the layers are created... But you must explode it first to access the attributes which is not the idea behind the block attributes that should be editable when a block with attributes is inserted.

So at the moment the only way to work is to start with a template document with all the possible layers on which attributes definitions are defined...

Can’t go further in debugging as block attributes are one of the feature of the ‘professional’ version I paid for and are not open source...

Ready and willing to sign a NDA to get access to the sources and make this work if nobody else takes care of this.

Luc JOB https://www.qcad.org/bugtracker/:2047