Flyspray:: https://www.qcad.org/bugtracker/ Flyspray::QCAD Bugtracker: Recently opened tasks 2019-09-23T08:09:45Z FS#1944: Block toggle switch for visibility fails https://www.qcad.org/bugtracker/index.php?do=details&task_id=1944 2019-09-23T08:09:45Z Husky 3.23.02 Block toggle switch for visibility fails.3.23.0 Block toggle switch for visibility works. 3.23.02 Block toggle switch for visibility fails.
3.23.0 Block toggle switch for visibility works.

]]>
FS#1943: Tool "New from Template" fails https://www.qcad.org/bugtracker/index.php?do=details&task_id=1943 2019-09-20T19:37:35Z Husky QCAD 3.23.0.2File / New from Template fails in different situation like immediately after launching the tool, sometimes after changing directories in the dialog like from imperial to metric etc..QCAD tries for ever (wait cursor) or even quits QCAD. It’s not a clear pattern ... See also:https://www.qcad.org/rsforum/viewtopic.php?f=89&t=6585 3.23.0.2 doesn’t works3.23.0 works Reported on Ubuntu 19.4, Win10 QCAD 3.23.0.2
File / New from Template fails in different situation like immediately after launching the tool, sometimes after changing directories in the dialog like from imperial to metric etc..
QCAD tries for ever (wait cursor) or even quits QCAD. It’s not a clear pattern ...

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=89&t=6585

3.23.0.2 doesn’t works
3.23.0 works

Reported on Ubuntu 19.4, Win10

]]>
FS#1942: Draw > Circle > Two tangents and point: fails for case with point on bisector https://www.qcad.org/bugtracker/index.php?do=details&task_id=1942 2019-09-18T18:51:57Z Thomas Stoelting The result of the tool CT2 depends on the position where the circle is constructed. See also https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6577&p=24772#p24772 The result of the tool CT2 depends on the position where the circle is constructed.

See also https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6577&p=24772#p24772

]]>
FS#1941: Invisible layers displayed https://www.qcad.org/bugtracker/index.php?do=details&task_id=1941 2019-09-17T21:43:10Z Andrew Snapshot release 3.23.0.2 See also:https://qcad.org/rsforum/viewtopic.php?p=24757 Snapshot release 3.23.0.2

See also:
https://qcad.org/rsforum/viewtopic.php?p=24757

]]>
FS#1940: CAM > CAM Configuration: Add program description https://www.qcad.org/bugtracker/index.php?do=details&task_id=1940 2019-09-16T07:45:07Z Andrew Add a program description to the CAM configuration dialog and export to postprocessors as variable. See also:https://www.qcad.org/rsforum/posting.php?mode=quote&f=32&p=24649 Add a program description to the CAM configuration dialog and export to postprocessors as variable.

See also:
https://www.qcad.org/rsforum/posting.php?mode=quote&f=32&p=24649

]]>
FS#1939: Right click not working in QCAD Community Edition https://www.qcad.org/bugtracker/index.php?do=details&task_id=1939 2019-09-09T06:40:14Z ali After I remove the .dll files from the pro trial version, right click stop working on Windows 10. I went a little further to try identifying which of the 5 files specifically causes right click to stop working, and I found that it is qcadproscripts.dll. The presence or absence of the other 4 dll files that make up the pro version has no influence on this behavior. After I remove the .dll files from the pro trial version, right click stop working on Windows 10.
I went a little further to try identifying which of the 5 files specifically causes right click to stop working, and I found that it is qcadproscripts.dll. The presence or absence of the other 4 dll files that make up the pro version has no influence on this behavior.

]]>
FS#1938: Segfault when trying to insert block from library (Fedora 30) https://www.qcad.org/bugtracker/index.php?do=details&task_id=1938 2019-09-09T06:41:01Z kurt (base) [kforrester@FedoraWorkStation qcad-3.23.0-pro-linux-x86_64]$ ./qcadQCAD version 3.23.010:21:34: Debug: calling odInitialize10:21:34: Debug: dropped global XDATA (no res buf): “ViewportCenter” 10:21:52: Debug: importing file: /home/kforrester/Resilio Sync/Technical/Process Engineering/equipment_tag_and_name.dxf./qcad: line 9: 3844 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” “$@” QCAD has unexpectedly quit. Please use the offscreen platform plugin for headless systems(without a running X11 server):./qcad -platform offscreen In addition, you might have to override the default Qt styleto prevent the loading of a native desktop style (such as GTK):./qcad -style plastique I have tested this in version 3.22.1 too and get the same result. Reverting all the way back to 3.13.1 results in an operable version of qcad when working on the same file and library blocks. (base) [kforrester@FedoraWorkStation qcad-3.23.0-pro-linux-x86_64]$ ./qcad
QCAD version 3.23.0
10:21:34: Debug: calling odInitialize
10:21:34: Debug: dropped global XDATA (no res buf): “ViewportCenter” 10:21:52: Debug: importing file: /home/kforrester/Resilio Sync/Technical/Process Engineering/equipment_tag_and_name.dxf
./qcad: line 9: 3844 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” “$@”

QCAD has unexpectedly quit.

Please use the offscreen platform plugin for headless systems
(without a running X11 server):
./qcad -platform offscreen

In addition, you might have to override the default Qt style
to prevent the loading of a native desktop style (such as GTK):
./qcad -style plastique

I have tested this in version 3.22.1 too and get the same result. Reverting all the way back to 3.13.1 results in an operable version of qcad when working on the same file and library blocks.

]]>
FS#1937: Circle shown in QCAD but not in AutoCAD https://www.qcad.org/bugtracker/index.php?do=details&task_id=1937 2019-08-27T09:40:20Z Ian Howell The attached drawing shows two large concentric circles when viewed in QCAD but the inner circle is missing when viewed in other CAD programmes. This cost $50 in rework as my laser cutting was not cut correctly! The attached drawing shows two large concentric circles when viewed in QCAD but the inner circle is missing when viewed in other CAD programmes. This cost $50 in rework as my laser cutting was not cut correctly!

]]>
FS#1936: ver 3.23 not saving font information https://www.qcad.org/bugtracker/index.php?do=details&task_id=1936 2019-08-23T20:21:04Z Larry Buller The attached file is not saving font preference.All fonts on the online layer are reported as the standard font. If I highlight one or all of the text entities and change the font to something like Yu gothic light, the property page reports yu gothic light and the screen reflects the changed font.If I save, close and reload, the fonts for all text is again “standard”. So then I try to enter new text via the “A” draw text command icon. I select “Broadway.ttf” as the main font in the text entry dialog.One word “Broadway” is entered as the text. it appears on the upper left of the screen as expected and the font name is Broadway in the property editor. If I look at the dxf file source there is a whole bunch of text styles. I save and close the file, and then open it again. Now the word Broadway has changed to font name “standard” in the property editor and is very definitely not the Broadway.ttf font. I am not the originator of the file, I am just trying to change the font. If I start a new file and enter new text the font saves just fine, so I am thinking it is a setting somewhere, but I am unable to find it. We (me and my customers) use these files for engraving so exact font is critical. The attached file is not saving font preference.
All fonts on the online layer are reported as the standard font. If I highlight one or all of the text entities and change the font to something like Yu gothic light, the property page reports yu gothic light and the screen reflects the changed font.
If I save, close and reload, the fonts for all text is again “standard”.

So then I try to enter new text via the “A” draw text command icon. I select “Broadway.ttf” as the main font in the text entry dialog.
One word “Broadway” is entered as the text. it appears on the upper left of the screen as expected and the font name is Broadway in the property editor. If I look at the dxf file source there is a whole bunch of text styles.
I save and close the file, and then open it again. Now the word Broadway has changed to font name “standard” in the property editor and is very definitely not the Broadway.ttf font.

I am not the originator of the file, I am just trying to change the font. If I start a new file and enter new text the font saves just fine, so I am thinking it is a setting somewhere, but I am unable to find it.

We (me and my customers) use these files for engraving so exact font is critical.

]]>
FS#1935: Startup preferences https://www.qcad.org/bugtracker/index.php?do=details&task_id=1935 2019-08-20T14:37:46Z Simon Miller Startup preferences On Mac 10.14.6: QCAD Pro → Preferences... → Startup Check or uncheck “Enable Splash Screen” 1. Restart of QCAD, the splash screen with Initialising add-ons xx% is identical 2. Apply, Cancel and OK buttons - why have both Apply and OK buttons? Startup preferences

On Mac 10.14.6: QCAD Pro → Preferences... → Startup

Check or uncheck “Enable Splash Screen”

1. Restart of QCAD, the splash screen with Initialising add-ons xx% is identical

2. Apply, Cancel and OK buttons - why have both Apply and OK buttons?

]]>