Flyspray:: Fri, 19 Jul 2019 13:26:06 +0000 Flyspray::QCAD Bugtracker: Recently opened tasks https://www.qcad.org/bugtracker/ FS#1922: Add error message when requesting raster for a non-existent layer with dwg2bmp Garciadelcastillo Fri, 19 Jul 2019 13:22:34 +0000 It would be nice if QCAD spit some kind of warning message when trying to render a layer with a name that doesn’t exist (and perhaps render nothing), rather than silently rendering an empty image. :D

See https://qcad.org/rsforum/viewtopic.php?f=33&t=6453

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1922 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1922
FS#1921: Add error message when requesting raster for a non-existent layer with dwg2bmp (duplicate) Garciadelcastillo Fri, 19 Jul 2019 13:22:17 +0000 (sorry for duplicate task, cannot remove it now)

It would be nice if QCAD spit some kind of warning message when trying to render a layer with a name that doesn’t exist (and perhaps render nothing), rather than silently rendering an empty image. :D

See https://qcad.org/rsforum/viewtopic.php?f=33&t=6453

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1921 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1921
FS#1920: Edit > Application Preferences: Add preference to disable dark mode Andrew Wed, 17 Jul 2019 10:37:57 +0000 See also:
https://www.qcad.org/rsforum/viewtopic.php?f=89&t=6447

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1920 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1920
FS#1919: Wrong order XY(Z) for Ordinate Dimension in property editor CVH Tue, 09 Jul 2019 11:51:22 +0000 Win7pro Qcad Pro 3.22.1.2

In property editor
properties of an Ordinate Dimension

Without Show Z
DefPoint is displayed in order YX?

With Show Z
Origin is displayed in order XZY?
DefPoint is displayed in order YZX?
LeaderEndPoint is displayed in order ZXY?

Regards

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1919 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1919
FS#1918: Splines whit control points of order 1 and 4 not selected with partially selecting cursor R>L draw CVH Sat, 06 Jul 2019 13:31:55 +0000 Set up a spline with control points let’s say of the order 3.
Clone it 3 times with some offset in x&y.
Edit the degree property and set 1ste to 1, 2nd to 2, aso
Draw select partially from right to left.
Those of the order 1 and 4 aren’t selected.

Regards

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1918 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1918
FS#1917: Automatic labels with static information of the drawing Johan Persson Fri, 05 Jul 2019 10:23:20 +0000 I would like static information of the drawing (like scale, creation-date, modified-date, revision etc) to be available as automatic labels to be placed in the drawing (with selectable style, font etc)

This would greatly simplify the creatin of title sections in the drawing and making sure it is consistent with the actual drawing and not requiring manual “synchronization”.

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1917 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1917
FS#1916: Moving an object in an angled viewport with mouse does not compensate for angle Johan Persson Fri, 05 Jul 2019 10:12:03 +0000 To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport to 90 degrees
4. Place view-port in paper space
5. Select the view-port in paper-space by clicking it
6. Try to move the object itself in the view-port (by clicking the “top” dot) to the right by moving the mouse to the right while holding the left mouse-button.

Actual

The object in the viewport moves down vertically NOT to the right

Expected

The object moves to the right

(It seems mouse movement does not compensate for the rotated angle of the viewport)

Workaround

None, except compensate for the angle in your head and moving the mouse the “wrong” way when correcting the placement of objects in the view-port

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1916 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1916
FS#1915: Viewport does not rotate view-port when changed in paper space Johan Persson Fri, 05 Jul 2019 09:52:58 +0000 To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport.

Actual

The object in the viewport changes but the viewport itself remains unchanged

Expected

That both the view-port and the object changes angle as the angle is updated

Motivation

If you abort the placement (but keep the angle) and go back to model-space and then redo the operation the view-port is rotated along the angle. It seems that the viewport only picks up the initial angle once the paper-space is open and ignores any changes thereafter

Workaround

1. Select the view-port per normal in model-space
2. Open the paper-space and set the wanted angle but do not place the view-port in paper space
3. Abort the placement on paper-space and redo the whole operation

Once the paper space is opened again the view-port will have the chosen angle

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1915 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1915
FS#1914: CAM layer On/Off H. Stiekema Wed, 03 Jul 2019 17:11:10 +0000 Hallo Andrew

If CAM layer invisible do not 3D Simulate and do not write G-code.

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1914 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1914
FS#1913: 3D Simulation Behaves odd H. Stiekema Tue, 02 Jul 2019 17:48:49 +0000 Hallo Andrew,

testing the drill toolpath I used single point markers.

In 3D simulation the tool drills the toolpath AND uses the drill as a mill.

Cam Export and generated G-code is not effected.

]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1913 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1913