QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System Windows 10
  • Severity Low
  • Priority Very Low
  • Reported Version 3.26.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: QCAD Bugtracker
Opened by Ladislav Sebo - 06.03.2021
Last edited by Andrew - 26.05.2021

FS#2198 - International characters change when saving and reloading the file [OpenDesign 4]

Text font changes when saving and reloading the file.
Original text before saving:
ľščťžýáíé ôúäň
Text after reopening the file:
¾šèžýáíé ôúäò
See also attachments.

Closed by  Andrew
26.05.2021 10:17
Reason for closing:  Fixed
03.06.2021 : A request to re-open the task has been made. Reason for request: Same issue persists even after update to 3.26.3
Admin
Andrew commented on 07.03.2021 19:58

Please attach the DXF file, thanks.

Ladislav Sebo commented on 07.03.2021 20:23

Here comes the file.

   xxx.dxf (237.6 KiB)
Admin
Andrew commented on 08.03.2021 08:27

Thanks.

I cannot reproduce the problem here.

When opening the file, the text is "¾šèžýáíé ôúäò". That is the text string saved in the file. However, if I change the text to "ľščťžýáíé ôúäň", save and reload it stays like that. I've attached that file. Please try to load on your system and post the result. Thanks.

   xxx_w.dxf (237.5 KiB)
Ladislav Sebo commented on 08.03.2021 14:17

Hi,

I have tried it and the result is attached. I'll try to reinstall QCAD and let you know.

Ladislav Sebo commented on 08.03.2021 15:41

Reinstallation of QCAD did not help. I, however, am not sure how to get new - clean - installation as some settings remained the same after removing the program and restarting the PC. Maybe this is a special case for Slovakian environment.

Admin
Andrew commented on 08.03.2021 16:12
Maybe this is a special case for Slovakian environment

Yes, could be. Can you post your system info under
Help > About... > System > Locale

Thanks.

Ladislav Sebo commented on 08.03.2021 17:20

Here it is:

Locale
QCAD locale: en
Name: sk_SK
Country: 191
Country name: Slovensko
Language: 108
Language name: slovenčina
Script: 0
Script name: Default
Decimal point: 44
Negative sign: 45
Positive sign: 43
Text direction: 0
System codec: System

Admin
Andrew commented on 11.03.2021 19:10

Unfortunately, this appears to be an OpenDesign bug in the OpenDesign libraries 4.x. It was fixed in the 20.x version, however, that version contains another bug which cripples splines on load. So it's the choice between two bugs.

Ladislav Sebo commented on 12.03.2021 09:31

So what is the next step? Shall we wait for new version of OpenDesign or is there anything to be done from our/my side?

Admin
Andrew commented on 12.03.2021 09:38

You could downgrade to QCAD 3.25.2 which uses OpenDesign 20.x and has the problem with loading certain types of splines instead. Note that these splines are relatively rare and cannot be produced with QCAD itself.

Ladislav Sebo commented on 12.03.2021 15:28

OK I can go a step down for the time being. Will this issue be followed/solved in future releases?

Admin
Andrew commented on 13.03.2021 13:09

The spline regression is in their system, but hasn't been fixed so far. Unfortunately, there is no way of telling for us when this will be addressed.

Ladislav Sebo commented on 14.03.2021 18:44

I think that the only thing to do is put this on hold, wait for OpenDesign and hope that this issue will be addressed soon.

Admin
Andrew commented on 08.04.2021 08:25

The OpenDesign spline regression has been fixed for OpenDesign version 22.4, so we hope to be able to update OpenDesign soon.

Ladislav Sebo commented on 21.04.2021 14:58

Checked with version 3.26.2.0 - issue persists.

Admin
Andrew commented on 21.04.2021 15:56

Note that this will be marked as "fixed" when it is fixed.

Ladislav Sebo commented on 27.05.2021 06:27

How can I check this?

Aleksey Ushakov commented on 02.06.2021 17:42

Updated to 3.26.3 - same issue with Russian language - test file attached.

   test.dxf (97.2 KiB)
Ladislav Sebo commented on 03.06.2021 09:40

Seems to be fixed for Slovakian environment in 3.26.3. No changes after saving and reopening the file.

Aleksey Ushakov commented on 04.06.2021 13:58

Update 3.26.4 has fixed this for Russian text too.

Admin
Andrew commented on 04.06.2021 19:51

OK, thanks for the feedback.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing